14' Overland now only accelerates in straight line? - Page 2 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 01-28-2016, 06:33 PM
Angler's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jan 2012
Location: San Antonio, TX
Posts: 382
Thanks: 29
Thanked 16 Times in 16 Posts
Rep Power: 62725
Angler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond repute
Re: 14' Overland now only accelerates in straight line?

Quote:
Originally Posted by JeepCares View Post
AAAA,

I am I customer care representative for Jeep. Iíve joined this Forum as a way to monitor concerns Jeep customers may be experiencing and offer assistance if needed. If you have any questions you can always send me a private message!

Thank you,
Welcome, Emily! We are so glad to have you here with us. Thank you so much for joining us.

Reply With Quote
Sponsored Links
Advertisement
 
  #14  
Old 02-07-2016, 06:03 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Aug 2014
Posts: 6
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 846
Moef is on a distinguished road
Re: 14' Overland now only accelerates in straight line?

So as an update,
I took it to a nearby service center and got it back within almost 2-3 days (Pretty fast, neat.)

Turns out it WAS the rear differential that was damaged. They replaced it with a new one. Car behaves like normal again with no further issues!

I didn't get to speak to the mechanics themselves to find out any specifics (if it was a damaged gear etc), and the service paper just states it had internal fluid contamination, replaced unit.

Anyone know if I have to drive slowly/lightly for the first couple of miles with this to "break it in" or is that not necessary?

Quote:
Originally Posted by JeepCares View Post
AAAA,

I am I customer care representative for Jeep. Iíve joined this Forum as a way to monitor concerns Jeep customers may be experiencing and offer assistance if needed. If you have any questions you can always send me a private message!

Thank you,
That's pretty awesome you guys are on the forums too. I had a nearby service center I went to but thanks anyways for the offer!
Reply With Quote
Reply

Tags
overland

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The only place to go straight from the dealer Kafdog Members Rides 2 08-22-2014 12:04 AM
Any '12 GC Overland Trailer Charging Experts Out There? (Can't get a straight answer) gowestwardho Troubleshooting/Problems Discussion 1 06-21-2013 04:04 AM
I hope your SRT is not on the assembly line now.... BostonDMD Grand Cherokee SRT - WK2 3 09-23-2012 01:13 AM
2005 5.7L accelerates by itself out of control? oldgeezer Troubleshooting/Problems 16 08-12-2012 07:16 PM
Pro-line V. Consumer line TJXJWJ Detailing 1 03-09-2011 10:29 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.