2012 Laredo Shift Issue - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-23-2016, 02:08 PM
Member
 
Join Date: Dec 2015
Posts: 7
Thanks: 3
Thanked 0 Times in 0 Posts
Rep Power: 413
Amost is on a distinguished road
2012 Laredo Shift Issue

Had my '12 Lardeo X for a few months now and overall happy. On my drive to work yesterday I was doing about 70-75 on the highway when I noticed the transmission wouldn't shift up. I'm not sure what gear it was in, but the RPMs were staying in between 3,500-4,000 and when I gave it gas they went up but there was no shift. Even when inlet off the gas the RPMs didn't drop below 3500. Due to the flow of traffic I couldn't really just let the car slow down to see what happened so after a while I let off the gas to shift to neutral then back to drive. After that everything seemed fine. Is this something I should be concerned about? A symptom of a common issue?


Sent from my iPhone using JeepGarage

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 02-23-2016, 03:59 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,720
Thanks: 291
Thanked 296 Times in 231 Posts
Rep Power: 91369
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: 2012 Laredo Shift Issue

If you have paddle shifters, you may have inadvertently hit one. If you push the right one and hold it, it should return to normal shift mode. At least that's how my '14 works. If you don't have paddle shifters, you may have put it into sport mode, not sure how that works in a '12.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #3  
Old 02-24-2016, 11:12 AM
NetworkTV's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Apr 2015
Posts: 833
Thanks: 3
Thanked 191 Times in 144 Posts
Rep Power: 6974
NetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond repute
Re: 2012 Laredo Shift Issue

Quote:
Originally Posted by jacko15 View Post
If you have paddle shifters, you may have inadvertently hit one. If you push the right one and hold it, it should return to normal shift mode. At least that's how my '14 works. If you don't have paddle shifters, you may have put it into sport mode, not sure how that works in a '12.
Agreed - it sounds like the OP bumped one of the paddles. By going to Neutral and back, it shut them off.
__________________
2015 Jeep Grand Cherokee Limited
Deep Cherry Red Crystal Pearl Coat

Reply With Quote
  #4  
Old 02-27-2016, 06:06 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2016
Location: New Jersey
Posts: 27
Thanks: 7
Thanked 3 Times in 3 Posts
Rep Power: 381
Bob Perry is on a distinguished road
Re: 2012 Laredo Shift Issue

If you have access to a scanner, you may want to check for any trouble codes. Just because the check engine is not on, does not mean codes are not being stored. One issue I have seen many times on the NAG1 transmissions is that the case connectors leak transmission fluid. If you can unplug the connector, see if there are any signs of fluid leaking into the connector. This can cause many shifts complaints and or speed sensor codes. The fix is to replace the case connector.
Reply With Quote
Reply

Tags
2012

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Jeep Grand Cherokee Laredo :: 2012 Jeep Laredo Chidester14 Member Garage Discussions 0 02-16-2016 11:47 AM
Shift Lever Override/Remote Start issue r063r Trouble Shooting/Problems/Service 3 11-18-2012 08:42 PM
Shift issue, TSB 18-012-11 update result REALM Trouble Shooting/Problems/Service 2 04-27-2011 04:45 PM
Issue with the 3-4 Shift Robert Palmer Trouble Shooting/Problems/Service 5 04-27-2010 03:03 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:11 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.