Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-01-2013, 08:52 PM
Member
My Jeep: 2013 3.6L WK2
 
Join Date: Jan 2013
Location: MD
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 667
ecolon1 is on a distinguished road
2013 WK2 Navigation screen issues in cold weather

The weather in the northeast has been blistering cold. I've noticed when the outside temp is below the 30's and start up my 2013 Wk2 (Limited w/ luxury II package)the navigation screen flickers.

When the vehicle warms up the flickering stops, I noticed it doesn't happen during warm days above 40 or higher.

Any ideas, it's kind of annoying and the car has only 1300 miles on it.
__________________

__________________
Reply With Quote
  #2  
Old 02-01-2013, 11:57 PM
AKHLK's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Aug 2012
Location: Anchorage, Alaska
Posts: 94
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 883
AKHLK is on a distinguished road
I had the same problem. Dealer replaced the camera, that didn't work, then they replaced the head unit, and that did the trick. It works fine in cold temps now.

Search "Rear Camera Cold Weather Problem" thread.
__________________

__________________
Reply With Quote
  #3  
Old 02-02-2013, 08:01 PM
Member
My Jeep: 2013 3.6L WK2
 
Join Date: Nov 2012
Location: Oregon
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 752
glassmtn is on a distinguished road
Re: 2013 WK2 Navigation screen issues in cold weather

I have a 2013 WK2 Limited with Luxury II and 1300 miles as well. I have had zero problems with the camera in temps. in the low teens, although we have yet to have temps. in single digits. Actually I have had not a single problem with my Jeep although as mentioned, I only have 1300 miles on the odometer.

eric.
__________________
Reply With Quote
  #4  
Old 02-03-2013, 09:55 AM
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Oct 2011
Location: Avon, CT USA
Posts: 204
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1532
PECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond repute
Re: 2013 WK2 Navigation screen issues in cold weather

Quote:
Originally Posted by glassmtn View Post
I have a 2013 WK2 Limited with Luxury II and 1300 miles as well. I have had zero problems with the camera in temps. in the low teens, although we have yet to have temps. in single digits.
I haven't had any rear camera issues with my 2012 Overland, either, other than a frequently filthy lens.
__________________
2012 Jeep Grand Cherokee Overland 4x4 5.7L ORAII Mineral Gray Dark/Light Frost Beige
Reply With Quote
  #5  
Old 02-03-2013, 12:29 PM
AAAA's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jan 2011
Location: Upstate NY
Posts: 2,690
Thanks: 38
Thanked 49 Times in 44 Posts
Rep Power: 1543509
AAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond repute
Re: 2013 WK2 Navigation screen issues in cold weather

Get thee to thy dealership.
__________________
Overland- Nokian WRG3 SUV tires, front and t. c. skid plates, Bosch Icon blades, Husky X-Act Contour slush mats, MOPAR cargo mat. Successor to trouble-free 2011 Limited.
(Avatar- http://www.ussslater.org/)
Reply With Quote
  #6  
Old 02-04-2013, 09:26 PM
Member
My Jeep: 2013 3.6L WK2
 
Join Date: Jan 2013
Location: MD
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 667
ecolon1 is on a distinguished road
Re: 2013 WK2 Navigation screen issues in cold weather

So I took my jeep into the dealership with phone in hand and ready to show 5 videos of the navigation flickering. I showed the videos of the flickering to the rep that was taking care of me, he indicated yes most likely I would need a new navi unit but the technician would have to check it out.

Few hours later I showed up again, to check on the diagnosis per the technician's evaluation. The tech of course couldn't duplicate the issue and could not just go by the video I provided. The tech indicated he couldn't order the part unless the issue is duplicated. I told him well it on occurs in frigid cold weather while the car is just starting up. He suggested I leave the jeep at the dealer this coming week so they could try to duplicate it.

They are going to call me again to set an appointment to bring it in. So let's see what they come up with, I dropped 40k on this car this is unacceptable.
__________________
Reply With Quote
  #7  
Old 02-05-2013, 12:36 AM
AKHLK's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Aug 2012
Location: Anchorage, Alaska
Posts: 94
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 883
AKHLK is on a distinguished road
Oh for crying out loud, why, why, why are some dealers such a holes?!?!
Just look at the damn video and get the guy a new head unit! I can understand needing to duplicate some issues to diagnose the problem but this should be cut and dry. Do they think treating people like this will bring return business or referrals?

When I took mine in it worked fine because the vehicle had warmed up enough inside (the camera would malfunction when the interior was below freezing) but I explained what was going on and asked them if they wanted to see a video....they said it wasn't necessary. They just FIXED it, like they should have.

Ugh, sorry, got to rant, the posts I read about some dealers just piss me off.
__________________
Reply With Quote
  #8  
Old 02-24-2013, 07:49 PM
Member
My Jeep: 2013 3.6L WK2
 
Join Date: Jan 2013
Location: MD
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 667
ecolon1 is on a distinguished road
Re: 2013 WK2 Navigation screen issues in cold weather

So I went ahead to the dealership again. They kept the car for another 4 hrs while I waited trying to duplicate the Navi screen issue, mean while I had more videos in hand to show the service manager. (weren't really interested in looking at them)

The service manager believes that there is an issue with the Navigation antenna causing and electromagnetic field around the system causing it to flicker during cold weather. They want to rip the dash apart and relocate the navi antenna.

I explained again I have no navi issues on guidance, it's the darn screen when it's cold that flickers. Service Manager stated they needed to email the Chrysler Engineers and get their input.

Chrysler mothership emailed back, they want me to bring the car back to run a few more checks before ordering a new Navi Unit. So I will be going back again this week. It's like pulling teeth with this issue.
__________________
Reply With Quote
  #9  
Old 02-24-2013, 07:59 PM
FAUEE's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Feb 2012
Location: Hickory, NC
Posts: 941
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 4632
FAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond repute
Re: 2013 WK2 Navigation screen issues in cold weather

Quote:
Originally Posted by ecolon1 View Post
The service manager believes that there is an issue with the Navigation antenna causing and electromagnetic field around the system causing it to flicker during cold weather.
Your service advisor is an idiot, or is just trying to spout something that uses concepts that you hopefully aren't familiar with to sound "like an expert". Either way, he's totally off base, and completely wrong.

There's probably a not so great solder joint inside the unit itself, causing intermittent connection until it heats up enough to have a full connection.
__________________
Reply With Quote
  #10  
Old 02-25-2013, 12:27 PM
AAAA's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jan 2011
Location: Upstate NY
Posts: 2,690
Thanks: 38
Thanked 49 Times in 44 Posts
Rep Power: 1543509
AAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond repute
Re: 2013 WK2 Navigation screen issues in cold weather

This is nuts customer service. The nav unit after all is warrantied to Chrysler by its manufacturuer so swapping it out will not cost Chrysler anything other than filing the claim and shipping the unit back to its maker.
__________________
Overland- Nokian WRG3 SUV tires, front and t. c. skid plates, Bosch Icon blades, Husky X-Act Contour slush mats, MOPAR cargo mat. Successor to trouble-free 2011 Limited.
(Avatar- http://www.ussslater.org/)
Reply With Quote
  #11  
Old 03-08-2013, 04:39 PM
Member
My Jeep: 2013 3.6L WK2
 
Join Date: Jan 2013
Location: MD
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 667
ecolon1 is on a distinguished road
Re: 2013 WK2 Navigation screen issues in cold weather

Took the jeep again back to the dealer, they are finally ordering a new navi unit to replace the defective one. Going back again next week for replacement.
__________________
Reply With Quote
  #12  
Old 03-14-2013, 08:38 PM
Member
My Jeep: 2013 3.6L WK2
 
Join Date: Jan 2013
Location: MD
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 667
ecolon1 is on a distinguished road
Re: 2013 WK2 Navigation screen issues in cold weather

Hopefully last update....New navi was installed this week. I haven't had any issues with flickering. I'll have to check again when the weather is cold just to verify.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cold Weather Diesel Operation WK2 wk2hopeful Diesel Powered 2012+ Export Grand Cherokee 11 03-24-2013 10:18 AM
Cold weather no start kaflyboy Trouble Shooting/Problems/Service 0 01-25-2013 06:27 PM
Starting in cold weather Randomhero180 Troubleshooting/Problems 16 01-24-2013 10:22 AM
Bad Cold Weather Noises JeepMe Troubleshooting/Problems 7 12-22-2010 04:45 PM
Belts in cold weather GiggityGiggity Troubleshooting/Problems 7 12-09-2010 02:19 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.