Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-31-2013, 07:26 PM
2014GC's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2013
Location: Atlanta Ga.
Posts: 225
Thanks: 1
Thanked 5 Times in 4 Posts
Rep Power: 784
2014GC is on a distinguished road
2014 AC Issue and guestion

Maybe someone else has experienced this.
When I have the AC in the Automatic mode sometimes on the interstate the AC will start blowing at a lower speed and a good deal warmer.So warm it feels like it not cooling at all. I can cut it off and on and it will start blowing and cooling like it should.So cool I have to raise the temp to 74 or higher for it to be comfortable on a 90 degree day. Now something else has started to show up.On start up with the AC in the Auto mode it will only blow through the floor and the defroster vents. I can restart the GC and play with the controls but it will only blow through the dash vents if I select the manual mode and it works fine. If I let is sit for about an hour the auto mode will work fine. The dealer can't reproduce it but it did it again today. Something else is strange, almost every time it happens the the unit reads 81Degress outside regardless what the outside temp is. As today when it was acting up it read 81,The correct temp was 94. After sitting for several hours it reads 92 the true outside temp and it worked as it should in the Auto mode. I have a Star Case started,and would like to get it fixed.
Please let me know if you have experienced anything like this.
__________________

__________________
Reply With Quote
  #2  
Old 08-31-2013, 07:44 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,225
Thanks: 321
Thanked 349 Times in 305 Posts
Rep Power: 1801721
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 AC Issue and guestion

If this is your first post about the problem, then somebody else recently reported the same thing, or something very similar.


___
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #3  
Old 08-31-2013, 07:48 PM
2014GC's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2013
Location: Atlanta Ga.
Posts: 225
Thanks: 1
Thanked 5 Times in 4 Posts
Rep Power: 784
2014GC is on a distinguished road
Re: 2014 AC Issue and guestion

I posted earlier about Erratic ATC. Posted today because it's doing something different. I just read the other post. I hate to say it but I'm glad someone else is having the same issue.Maybe we can it it fixed.
__________________
Reply With Quote
  #4  
Old 08-31-2013, 09:46 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2010
Posts: 1,210
Thanks: 1
Thanked 25 Times in 25 Posts
Rep Power: 3154
jp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond repute
Re: 2014 AC Issue and guestion

Mine has done that a couple times but not since I had the radio updated to 13.19
__________________
Reply With Quote
  #5  
Old 09-01-2013, 09:16 PM
2014GC's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2013
Location: Atlanta Ga.
Posts: 225
Thanks: 1
Thanked 5 Times in 4 Posts
Rep Power: 784
2014GC is on a distinguished road
Re: 2014 AC Issue and guestion

I started my GC about an hour latter and it's working fine. No rhime or reason why it does it. Taking the family away this weekend and I'm driving the other vehicle. Wife is just pissed that we can't take the GC because the Ac might act up. But I'm sure the dealer will get it worked out. But it's close to hell living with this and her not wanting to drive it. I am hearing I told you so or you should have bought this or that. I am in a position to just dump it but I really like the Jeep. Just wish we could find out what the problem is.
__________________
Reply With Quote
  #6  
Old 09-01-2013, 10:56 PM
Member
 
Join Date: Jul 2013
Location: Westminster, CO
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 443
mountain95 is on a distinguished road
Mine did this once this past Friday for the 1st time, acted exactly like yours. I put it in auto and left in in the garage for a couple of hours and it started working again when I started it. Hasn't done it again yet but I'm just waiting on it. It appears to me the climate control temperature measurement stops functioning correctly and it gets into the wrong mode. It would work in manual mode though the A/C did not seem to be as cold even with it all the way down.
__________________
Reply With Quote
  #7  
Old 09-03-2013, 06:00 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 721
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1210
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: 2014 AC Issue and guestion

2nd time now... outside temp 64 deg... and it was HOT inside - could not get it to blow through the dash vents again.. even setting it to LO on auto.
__________________

__________________
Reply With Quote
Reply

Tags
2014

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 RA4 Issue/Update - DETAILED BELOW jdchamp31 Audio/Visual/Navigation 22 06-09-2014 02:37 PM
2014 V6 4X4 Steering issue jrein Trouble Shooting/Problems/Service 11 09-03-2013 09:25 AM
2014 Transmission Issue...maybe? LetMeRide Grand Cherokee - WK2 - 1 06-28-2013 12:02 AM
2014 Bluetooth streaming issue............. rvf1 Trouble Shooting/Problems/Service 8 04-17-2013 03:25 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community