Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #49  
Old 07-05-2013, 01:04 AM
Member
 
Join Date: Jul 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 409
Krikaleak is on a distinguished road
Re: 2014 climate control woes

Well got it back from the dealer after leaving it overnight, they said no fix was available and that one would be coming sometime in the third quarter.

I think I'm going to call jeep and tell them this is bs. I live in phoenix, az and currently have 110 degree highs. By the time they have a fix, I won't need it! Has anyone been successful in getting any sort of compensation?
__________________

__________________
Reply With Quote
  #50  
Old 07-09-2013, 11:15 AM
New Member
 
Join Date: Jul 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
YonkasTone is on a distinguished road
Re: 2014 climate control woes

Just picked up 2 Laredos for me and my wife. My climate control is always off when i use the remote start and hers seems to stay on until you open the driver door and then it turns off. I'm just glad I found this thread to see that it's a known issue. Hopefully a fix is coming soon
__________________

__________________
Reply With Quote
  #51  
Old 07-09-2013, 07:33 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 970
Thanks: 34
Thanked 58 Times in 49 Posts
Rep Power: 1950
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Re: 2014 climate control woes

If I leave mine set on auto and I remote start on a hot day the ac system does nothing until I go over to it and open the drivers door. Upon opening the drivers door the ac then turns on and starts blowing cold. So this does nothing for cooling the car off before you get to it, no sense in remote starting. this sounds like the opposite problem many are having of ac shutting off when the door is opened. Summit built mid march with 13.19.0 installed
__________________
Reply With Quote
  #52  
Old 07-09-2013, 08:41 PM
New Member
 
Join Date: Jul 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
YonkasTone is on a distinguished road
Re: 2014 climate control woes

so i noticed when i got home from work that when i turned the car off it automatically turned off he climate control (and then stayed off when i started my car w/remote start). tomorrow i'm going to try to open the door first and then shut the car off (so the radio and everything are off the second i turn the car off) to see if it makes a difference
__________________
Reply With Quote
  #53  
Old 07-12-2013, 11:20 AM
New Member
 
Join Date: Jul 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
YonkasTone is on a distinguished road
Re: 2014 climate control woes

if i open the driver door and then shut the car off my climate control stays where it was so it'll be on when i use the remote start the next time. not exactly the solution i was hoping for but it's a nice workaround until an update is released.
__________________
Reply With Quote
  #54  
Old 07-14-2013, 03:19 PM
Member
 
Join Date: Jun 2013
Posts: 52
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 460
GCL2014 is on a distinguished road
Re: 2014 climate control woes

Driving in my wife's GC limited today, high temps in th northeast and high humidity. The A/c seems to be just passable at the low setting. I would expect I to be ice cold an make your skin feel cold on the highest setting. I am comparing the output to my VW GTI that is 10 years old.
__________________
Reply With Quote
  #55  
Old 07-14-2013, 05:25 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2011
Location: NOVA
Posts: 24
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1349
turn1racing has a reputation beyond reputeturn1racing has a reputation beyond repute
Re: 2014 climate control woes

Quote:
Originally Posted by YonkasTone View Post
if i open the driver door and then shut the car off my climate control stays where it was so it'll be on when i use the remote start the next time. not exactly the solution i was hoping for but it's a nice workaround until an update is released.
That's quite interesting especially if it works every time. Since the door is open when you shut the car off then does the radio and everything turn off right away? If everything does turn off right away maybe you can try setting the "Engine off power delay" to 0 seconds to turn the feature off since it seems having the door open causes the same thing. (I would try it, but don't have my Jeep yet)
__________________
Reply With Quote
  #56  
Old 08-05-2013, 02:59 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Aug 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 367
lilaustino is on a distinguished road
Re: 2014 climate control woes

I have a similar issue as two other posters. I keep my A/C on AUTO. When I remote start the car, the A/C only turns on once I have opened the driver door, which is absolutely useless living in Houston. I called the dealership and they had no clue about it, but said there was a "radio enhancement" update that I could have installed. This doesn't sound like the same Q3 software update that some people have been talking about. I'll let y'all know what this probably dinky update does.
__________________
Reply With Quote
  #57  
Old 03-28-2014, 09:49 AM
New Member
 
Join Date: Mar 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mishigos is on a distinguished road
Re: 2014 climate control woes

Quote:
Originally Posted by Burrogs View Post
Ok, biggest issue I have with my new summit is the climate control. I have to reset everything each time I restart the car. In fact the default setting is all ac off. This is so annoying, certainly I'm just doing something wrong or don't have the right options selected, right? Is there a way to have this just save the most recent setting that was on prior o shutdown? This is the Eco button squared!

Burrogs have you had any luck with resolving this issue??? My 2014 GC limited always starts up with the Climate Control off (except for the times I restart vehicle within a couple minutes of shutdown). Im dreading a trip to the dealer.... Whats worse, when I hit "auto" to get the CC going it always sets at 72 degrees no matter what I had it on when the vehicle was last running.

Did anyone actually get this issue resolved??

Thanks guys!
__________________
Reply With Quote
  #58  
Old 03-28-2014, 11:59 AM
Premium Member
 
Join Date: Aug 2012
Location: Oshkosh WI
Posts: 135
Thanks: 22
Thanked 9 Times in 6 Posts
Rep Power: 1056
shewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond repute
Yes, there is a fix for auto climate not being on with remote start. The dealer will flash the HVAC controller. My previous 2014 Limited had this issue and was addressed by the flash.
__________________
2014WK2 Overland 4x4 ADV, Granite
Reply With Quote
  #59  
Old 03-28-2014, 02:35 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Location: Bristol WI
Posts: 82
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 462
Supertech30 is on a distinguished road
Re: 2014 climate control woes

This is a problem that I have been trying to fix since day one I like to call it the remote reset problem. My Overland has been in the for over 30 days in 7 months trying to fix this and other problems. The last time I took it in they replaced the whole center stack and that didn't fix it. Try this when you remote start go out to your car grab the handle but wait for a few seconds before you open the door. I think this is a software timing issue if I wait a few seconds for things like to change my temperature setting will go back to where I left them. I also noticed the the the colder it is the more often it happens. I can say that they gave me a free extended max care warranty for not fixing my car if that is worth anything.

Sent from my Nexus 4 using Tapatalk
__________________
Reply With Quote
  #60  
Old 03-28-2014, 03:48 PM
Premium Member
 
Join Date: Aug 2012
Location: Oshkosh WI
Posts: 135
Thanks: 22
Thanked 9 Times in 6 Posts
Rep Power: 1056
shewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond reputeshewstring has a reputation beyond repute
Re: 2014 climate control woes

SuperTech: That is weird. Mine always resorts to that last Auto temp with remote start (after the flash) and with my new Overland. When I open the door the fan stops, but once the vehicle starts, it is back on with the Auto setting where I left it. When in remote start mode, the fan seems to be on high defrost you can test it if you leave a window open or try the passenger door). Makes sense for winter starts.
__________________

__________________
2014WK2 Overland 4x4 ADV, Granite
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Automatic climate control CAN be ADDED to manual climate controlled vehicles Scottina06 Interior/Exterior/Visual 110 01-04-2014 06:44 PM
Climate control Thlinks Grand Cherokee - WK 1 12-27-2012 03:13 PM
Climate control on, but not really on? armoredsaint Trouble Shooting/Problems/Service 5 11-16-2012 05:27 PM
climate control 4wd4me Troubleshooting/Problems 4 06-13-2012 08:53 AM
Climate control is way off (8-10 F) with A/C JoeSchmoe007 Trouble Shooting/Problems/Service 1 07-31-2011 08:41 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community