2014 climate control woes - Page 7 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Reply
 
Thread Tools Display Modes
 
  #73  
Old 01-03-2015, 09:01 PM
silvermax04's Avatar
Senior Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 3,538
Thanks: 283
Thanked 623 Times in 484 Posts
Rep Power: 30667
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Quote:
Originally Posted by Jigarner2 View Post
Hey everyone I am late to this thread but I have been having the same issues since I got my 2014 in April of 2013.

No matter how I start my jeep, either remote or just using the push button if my car has been sitting for several hours the hvac setting reset.

1. Push button - the car turns on, hvac is off, when I turn it on it goes back to 72 and the front two seats are no longer synced, regardless of any settings I had when I turned off the car.

2. Remote start - hvac is on warming up the car, if I open the trunk or any other door besides the drivers I can hear it working. As soon as I open the drivers door it cuts off. When I push the start button to take it out of remote start mode the hvac is still off and when I turn it back on it goes to the settings above 72 ect..

My jeep is a metallic steel 2014 limited with the navigation. It has been into the dealer attest 6 times over the past year for this issue and they have no clue how to fix it.

It has all the most recent updates and software. They even tried replacing a control module. The biggest problem, for me, is that this only happens after the car has been sitting so they can't duplicate it. So I've had to leave it over night, come back first thing the next morning and start the car for them to show them what's going on, still no clue.

I've had the jeep for almost 2 years, and it's getting close to the point where lawyers are going to get involved because it still hasn't been fixed.
If you verified that one of the flashes they did was the HVAC flash sbove then something else you might try is removing the negative battery cable for a half hour or longer then put it back on. The cable reset has been know to fix various electrical gremlins. No guarantees but worth a try, also dont assume the dealer tried that chaces are they probably didnt. Good luck

Reply With Quote
Sponsored Links
Advertisement
 
  #74  
Old 01-03-2015, 10:32 PM
New Member
 
Join Date: Jan 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Jigarner2 is on a distinguished road
Re: 2014 climate control woes

Quote:
Originally Posted by silvermax04 View Post
If you verified that one of the flashes they did was the HVAC flash sbove then something else you might try is removing the negative battery cable for a half hour or longer then put it back on. The cable reset has been know to fix various electrical gremlins. No guarantees but worth a try, also dont assume the dealer tried that chaces are they probably didnt. Good luck
Thanks for the advice, trying that now, have about 15 min left. You would think this would be one of the first things they would have tried, like unplugging a computer when it's giving you issues.

Oh well, thanks again
Reply With Quote
  #75  
Old 01-03-2015, 11:35 PM
silvermax04's Avatar
Senior Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 3,538
Thanks: 283
Thanked 623 Times in 484 Posts
Rep Power: 30667
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Quote:
Originally Posted by Jigarner2 View Post

Thanks for the advice, trying that now, have about 15 min left. You would think this would be one of the first things they would have tried, like unplugging a computer when it's giving you issues.

Oh well, thanks again
Yes you would think that would be one of the first things they would try for certain issues but from my experiance and what i have read from others it does not seem to be on the dealer list much to try. I agree cars now are like computers and a reset allowing all the various modules to come up together gracefully can sometimes solve certain issues. Its worked for me more than once usually due to anomilies after a reflash.
If you do it, is also best to check your uconnect settings it does reset a couple of the check boxes and radio equalizer if iremember correctly.
Anyway its something quick and easy to try, hope it helps.
Reply With Quote
Sponsored Links
Advertisement
 
  #76  
Old 10-01-2016, 08:57 PM
Member
 
Join Date: Sep 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 278
rbboot is on a distinguished road
Re: 2014 climate control woes

Bringing this back to life. My new to me 14 Laredo is having the same problem where the AC defaults to off and comes back on unsyced at 72.

Has the previously listed TSB HVAC updates solved this issue for anyone?

Thanks for any help
Reply With Quote
  #77  
Old 10-08-2016, 05:06 PM
HemiSummit2014's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jul 2013
Location: New Jersey
Posts: 97
Thanks: 4
Thanked 16 Times in 12 Posts
Rep Power: 1523
HemiSummit2014 is on a distinguished road
Re: 2014 climate control woes

Had the same problem in my '14 summit that I just purchased used about 6 weeks ago. I complained to my salesperson he said they would fix it for free. First thing they tried was reprogramming Climate control module, didn't work. They ordered me a new climate control module, they installed it today and no more problems, fixed so far. Holds setting after shutoff and during auto starts.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Automatic climate control CAN be ADDED to manual climate controlled vehicles Scottina06 Interior/Exterior/Visual/Lighting 111 07-11-2016 12:36 PM
Climate control Thlinks Grand Cherokee - WK 1 12-27-2012 02:13 PM
Climate control on, but not really on? armoredsaint Trouble Shooting/Problems/Service 5 11-16-2012 04:27 PM
climate control 4wd4me Troubleshooting/Problems 4 06-13-2012 08:53 AM
Climate control is way off (8-10 F) with A/C JoeSchmoe007 Trouble Shooting/Problems/Service 1 07-31-2011 08:41 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:07 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.