Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-17-2014, 05:17 PM
New Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2014
Location: Dubai
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
shyammohan32 is on a distinguished road
2014 GC Limited Speakers Dead

Hi,

My sound system was working fine till yesterday night but today when i started, there was no music at all. Radio was tuning to different channels and the display was showing current channel but no sound! No sound when playing ipod via bluetooth also even though track display was correct. And even phone calls were not audible.

Another change i noticed was that the Surround Sound option in audio settings is disabled and it is not allowing me to change. It says "surround sound not available in this mode"

It was working perfectly till late night yesterday and suddenly went dead! My uconnect version says 13.43.7

Anyone else face this? Or any suggestions pls...
__________________

__________________
Reply With Quote
  #2  
Old 01-17-2014, 08:11 PM
Member
 
Join Date: Jul 2013
Posts: 494
Thanks: 3
Thanked 21 Times in 16 Posts
Rep Power: 17784
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
I'd try resetting the head unit but if that doesn't work I'm guessing the amp ate it.
__________________

__________________
2014 Overland - Granite, Hemi
Reply With Quote
  #3  
Old 01-17-2014, 09:50 PM
Paradiso's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Pittsburgh, Pa
Posts: 152
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 674
Paradiso is on a distinguished road
I had a dead speaker on my 2011 found out it was the Amp.
__________________
Reply With Quote
  #4  
Old 01-17-2014, 10:54 PM
New Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2014
Location: Dubai
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
shyammohan32 is on a distinguished road
Re: 2014 GC Limited Speakers Dead

can i reset the head unit on my own? and how do i check if its the amp?
__________________
Reply With Quote
  #5  
Old 01-18-2014, 01:26 AM
New Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2014
Location: Dubai
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
shyammohan32 is on a distinguished road
Re: 2014 GC Limited Speakers Dead

Took it to the service centre in the morning. Apparently the amp system needed reset. The service rep said it gets corrupted sometimes. Work got done in 5 mins... system working fine now.
__________________
Reply With Quote
  #6  
Old 01-18-2014, 03:21 AM
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Jun 2013
Location: San Diego, Ca
Posts: 640
Thanks: 0
Thanked 16 Times in 16 Posts
Rep Power: 22463
YjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond repute
Interesting...my 2013 GC with 730 rhr radio was acting odd Thursday night too. Changing stations for no reason but still showing the original station on the screen. Today all is O.K.....Go figure!
__________________
Reply With Quote
  #7  
Old 01-18-2014, 10:24 AM
Member
 
Join Date: Jul 2013
Posts: 494
Thanks: 3
Thanked 21 Times in 16 Posts
Rep Power: 17784
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Quote:
Originally Posted by shyammohan32 View Post
Took it to the service centre in the morning. Apparently the amp system needed reset. The service rep said it gets corrupted sometimes. Work got done in 5 mins... system working fine now.
Did he mention how that's done by chance? Would be good to know for future instances on the forum.
__________________

__________________
2014 Overland - Granite, Hemi
Reply With Quote
Reply

Tags
2014, limited

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 GC Limited Speakers Dead shyammohan32 Grand Cherokee - WK2 - 2 01-20-2014 09:19 AM
2014 JGC 8.4AN screen dead gda01 Troubleshooting/Problems Discussion 10 01-18-2014 06:29 PM
2014 GC Totally $#@% dead amc2002 Trouble Shooting/Problems/Service 677 08-23-2013 07:54 PM
2014 Grand Cherokee 7" Screen Dead markus316 Trouble Shooting/Problems/Service 27 08-08-2013 10:38 AM
05' 4.7 Limited Dead Transmission Crashtown Troubleshooting/Problems 5 01-31-2012 11:35 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.