Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 06-17-2013, 09:02 PM
Member
My Jeep: 2014 3.6L
 
Join Date: Jun 2013
Location: ATX
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 477
balanced is on a distinguished road
Re: 2014 Grand Cherokee Limited Electronics Problem

Took delivery of my 2014 GC Limited on June 8 with 15 miles on the OD, now at 386 miles. Today I came out of my office to head home and had the same issues: ABS, Engine, Park Assist, Airbag and Engine all showing faults, no backup sensors or screen guides. Also speedo wouldn't register any type of movement, yet while parked the U-connect had me locked out due to detected motion. Restarted it two times at the office, still same issue. Hit the "Assist" button, but the operator couldn't offer any suggestions, other then taking it to the dealer, so I drove it in, but service was closed for the day. My sales person was accommodating put it in the service bay to be checked tomorrow, she also pulled a new 200 off the lot for me to drive in the meantime. I am guessing it is some sort of software bug that hasn't been addressed yet. My wife drives a 2013 Dodge Durango Crew and have yet to have any issue with it.
__________________

__________________
Reply With Quote
  #14  
Old 06-18-2013, 08:00 AM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,537
Thanks: 0
Thanked 24 Times in 21 Posts
Rep Power: 80159
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: 2014 Grand Cherokee Limited Electronics Problem

To get that many errors would require something like a general failure of the communications bus.

In my GM cars the bus makes a loop so a single point failure will not take the whole bus down. I do not know how CJF designed it but understand that '14s are "different".
__________________

Reply With Quote
  #15  
Old 06-18-2013, 08:20 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,172
Thanks: 318
Thanked 346 Times in 302 Posts
Rep Power: 1801659
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Grand Cherokee Limited Electronics Problem

Quote:
Originally Posted by balanced View Post
Took delivery of my 2014 GC Limited on June 8 with 15 miles on the OD, now at 386 miles. Today I came out of my office to head home and had the same issues: ABS, Engine, Park Assist, Airbag and Engine all showing faults, no backup sensors or screen guides. Also speedo wouldn't register any type of movement, yet while parked the U-connect had me locked out due to detected motion. Restarted it two times at the office, still same issue. Hit the "Assist" button, but the operator couldn't offer any suggestions, other then taking it to the dealer, so I drove it in, but service was closed for the day. My sales person was accommodating put it in the service bay to be checked tomorrow, she also pulled a new 200 off the lot for me to drive in the meantime. I am guessing it is some sort of software bug that hasn't been addressed yet. My wife drives a 2013 Dodge Durango Crew and have yet to have any issue with it.
Very common issue. When they start the car today everything will be fine, with the possible exception of the check engine light. That will go out after a couple of restarts. If the dealer contacts Jeep with the codes they will tell them to check all the grounds. That's because a number of cars came off the line with a loose ground strap.

When mine did it a second time they changed the PCM. It has not happened since. A number of people had it happen once, did nothing, and so far it seems to have quieted down.

At least that is my take on it.
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #16  
Old 06-18-2013, 10:19 AM
Member
My Jeep: 2014 3.6L
 
Join Date: Jun 2013
Location: ATX
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 477
balanced is on a distinguished road
Re: 2014 Grand Cherokee Limited Electronics Problem

Quote:
Originally Posted by bill_de View Post
Very common issue. When they start the car today everything will be fine, with the possible exception of the check engine light. That will go out after a couple of restarts. If the dealer contacts Jeep with the codes they will tell them to check all the grounds. That's because a number of cars came off the line with a loose ground strap.

When mine did it a second time they changed the PCM. It has not happened since. A number of people had it happen once, did nothing, and so far it seems to have quieted down.

At least that is my take on it.
Thanks for the reply Bill and the information. I'm still waiting to hear back from the service department, will update my post once I hear back.
__________________
Reply With Quote
  #17  
Old 06-18-2013, 05:03 PM
Member
My Jeep: 2014 3.6L
 
Join Date: Jun 2013
Location: ATX
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 477
balanced is on a distinguished road
Re: 2014 Grand Cherokee Limited Electronics Problem

So just as Bill and a few others expressed it was a ground strap issue. The service rep told me that they have seen a few of these. They tightened it down and cleared the codes, he told me it should be good going forward. He also mentioned that they have seen it damage the PCM, but that was not the case with mine. Very happy that it happened to be something pretty minor.

Now they just need to reprogram the torque setting for that tool at the factory.
__________________
Reply With Quote
  #18  
Old 06-23-2013, 11:41 PM
New Member
 
Join Date: Jun 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Skipper is on a distinguished road
Re: 2014 Grand Cherokee Limited Electronics Problem

So picked up from the dealer a day before leaving on vacation with it. Needless to say I was somewhat worried but 1000 miles with no issues. The dealer said they loaded new software. The service invoice made no indication that had been done which I thought was odd. The new software doesn't specifically address this issue since they don't know what is actually causing it so it's a hail mary if they really did that. We'll see what happens.
__________________
Reply With Quote
  #19  
Old 06-23-2013, 11:54 PM
Member
 
Join Date: Jun 2012
Posts: 116
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 981
Jackspat2 has a reputation beyond reputeJackspat2 has a reputation beyond repute
Re: 2014 Grand Cherokee Limited Electronics Problem

Mine did the same thing on day 2. Dealer reset, it's been ok for 5500 miles.
__________________
2014 Jeep Grand Cherokee Limited 4X4
V6 | Bright White | ORAII |
Reply With Quote
  #20  
Old 06-24-2013, 06:08 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,172
Thanks: 318
Thanked 346 Times in 302 Posts
Rep Power: 1801659
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Grand Cherokee Limited Electronics Problem

Quote:
Originally Posted by balanced View Post
So just as Bill and a few others expressed it was a ground strap issue. The service rep told me that they have seen a few of these. They tightened it down and cleared the codes, he told me it should be good going forward. He also mentioned that they have seen it damage the PCM, but that was not the case with mine. Very happy that it happened to be something pretty minor.

Now they just need to reprogram the torque setting for that tool at the factory.
I didn't say that. I said Chrysler told them to tighten the ground strap. I had already checked it, before I ever had a problem, and it was never loose. I checked it based on Milous posting the Star information. The dealer took the strap off and 'cleaned up' the connection only because the ground was the only information Chrysler provided.

When it happened again, Chrysler had them change the PCM because "they couldn't think of anything else" that could throw so many codes. Nobody said a loose ground damaged the PCM, because I never had a bad ground.

More recently we are hearing that they are reflashing the PCMs. So maybe mine didn't even need to be replaced, but could have been reflashed if they had the new software ready.

My guess is that Chrysler took mine and others (plus other parts they replaced) and used them to drill down until they found the problem. Remember, one person was told it was a shifter module and I believe somebody else got an ABS module. With intermittent problems like this, the scatter gun approach is often the only way to approach it.

Hopefully the flash has solved the problem.



.
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #21  
Old 06-24-2013, 07:25 AM
Member
My Jeep: 2014 3.6L
 
Join Date: Jun 2013
Location: ATX
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 477
balanced is on a distinguished road
Re: 2014 Grand Cherokee Limited Electronics Problem

Quote:
Originally Posted by bill_de View Post
I didn't say that. I said Chrysler told them to tighten the ground strap. I had already checked it, before I ever had a problem, and it was never loose. I checked it based on Milous posting the Star information. The dealer took the strap off and 'cleaned up' the connection only because the ground was the only information Chrysler provided.

When it happened again, Chrysler had them change the PCM because "they couldn't think of anything else" that could throw so many codes. Nobody said a loose ground damaged the PCM, because I never had a bad ground.

More recently we are hearing that they are reflashing the PCMs. So maybe mine didn't even need to be replaced, but could have been reflashed if they had the new software ready.

My guess is that Chrysler took mine and others (plus other parts they replaced) and used them to drill down until they found the problem. Remember, one person was told it was a shifter module and I believe somebody else got an ABS module. With intermittent problems like this, the scatter gun approach is often the only way to approach it.

Hopefully the flash has solved the problem.



.
Well I apologize for the misquote. My service department expressed that my issue was a loose ground strap, so that is what they told me they tightened. He didn't mention anything about flashing the module. It appears to have resolved the issue for now.
__________________
Reply With Quote
  #22  
Old 06-24-2013, 07:34 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,172
Thanks: 318
Thanked 346 Times in 302 Posts
Rep Power: 1801659
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Grand Cherokee Limited Electronics Problem

Quote:
Originally Posted by balanced View Post
Well I apologize for the misquote. My service department expressed that my issue was a loose ground strap, so that is what they told me they tightened. He didn't mention anything about flashing the module. It appears to have resolved the issue for now.
No apology necessary. When things are discussed this long in multiple threads it's hard to keep track of who said what.

Did you still have the issue when you went to the dealer? In both my cases everything was back to normal (except for stored codes)by the time the Jeep got to the dealer.



---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #23  
Old 06-24-2013, 07:40 AM
Member
My Jeep: 2014 3.6L
 
Join Date: Jun 2013
Location: ATX
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 477
balanced is on a distinguished road
Re: 2014 Grand Cherokee Limited Electronics Problem

Quote:
Originally Posted by bill_de View Post
No apology necessary. When things are discussed this long in multiple threads it's hard to keep track of who said what.

Did you still have the issue when you went to the dealer? In both my cases everything was back to normal (except for stored codes)by the time the Jeep got to the dealer.



---
Yes I still was having the issue when I showed up to the dealer, but because it was after service hours it sat over night, so it could have resolved itself and they just cleared the codes. Though my service advisor did say they tightened the ground strap and cleared codes.
__________________
Reply With Quote
  #24  
Old 06-24-2013, 02:06 PM
New Member
 
Join Date: Jun 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Asher is on a distinguished road
So now for today's problem. My outside temperature gauge is reading 75 degrees and its 92 here in New York. Looked at three different family cars all say 90 degrees. What's wrong here. I'm getting very disappointed with this truck. I did nt have such issues in my 2012 overland.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Grand Cherokee Air Conditioning Problem curtispwns Trouble Shooting/Problems/Service 47 07-01-2014 01:42 PM
2011 Jeep Grand Cherokee limited Sunroof problem Greg7 Trouble Shooting/Problems/Service 2 06-01-2014 05:27 PM
2014 Grand Cherokee Limited :: 2014 Jeep Grand Cherokee Limited 4X4 desertdr Member Garage Discussions 2 06-21-2013 09:28 PM
97 Grand Cherokee Limited trans problem dfoxfish Grand Cherokee - ZJ 2 11-27-2011 09:46 PM
93 Grand Cherokee electronics don't work?? 93grand4x4 Troubleshooting/Problems Discussion 2 08-10-2011 08:40 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community