Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #145  
Old 12-20-2013, 12:25 AM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2012
Location: Victoria, Australia
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 886
baza32000 is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Hi,
Picked up new CRD Overland last week. 2 current issues:

1. Transmission shifts can be 1980'ish when lifting off throttle, apparently there is a fix for this.
2. Tailgate on passenger side is miss-aligned with the tail light and has chipped paint on the lip. We'll see what the dealer says about that one...

Glen.
__________________

__________________
Reply With Quote
  #146  
Old 12-26-2013, 01:32 AM
Jarse's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Sydney, Australia
Posts: 108
Thanks: 2
Thanked 6 Times in 6 Posts
Rep Power: 565
Jarse is on a distinguished road
Here's a new one - ROOF LEAK in the Laredo. Mine is leaking from the plastic roof lining in front of the tailgate. It's running out of the joins either end. Sufficient to fill both the rear tie downs and wet the carpet. I noticed water stains on the cargo blind, which indicates it's probably been happening since day one off the production line. Quality control? Hmmmmmmm.

I suspect it may be either the grommet in the body that feeds the wiring to the tailgate, or the roof rail mounting points.

Dealer will be advised tomorrow. I have the recall notice for the N58 (although mine isn't showing any symptoms) so hopefully will get both rectified at the same time.
__________________

__________________
Reply With Quote
  #147  
Old 12-29-2013, 08:52 PM
Premium Member
My Jeep: 2013 3.0L WK2
 
Join Date: Jan 2013
Location: Ballarat Victoria Australia
Posts: 40
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 695
nrb1748 is on a distinguished road
Cool Re: 2014 Grand Cherokee Problems - Australia

MY 2014 CRD Laredo July delivery 9600km. Engine oil leak. Dripping from area of sump plug (lowest point) but leak from some where else. Dealer had quick look but unable to find source because of accumulation of oil. Area washed, oil added and will look again next Friday at 10000km service.
__________________
MY2014 Laredo CRD Bright White
Reply With Quote
  #148  
Old 12-30-2013, 04:26 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Brisbane QLD Australia
Posts: 769
Thanks: 13
Thanked 31 Times in 26 Posts
Rep Power: 2140
iboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond repute
Quote:
Originally Posted by nrb1748 View Post
MY 2014 CRD Laredo July delivery 9600km. Engine oil leak. Dripping from area of sump plug (lowest point) but leak from some where else. Dealer had quick look but unable to find source because of accumulation of oil. Area washed, oil added and will look again next Friday at 10000km service.
Join the club. Ours has had the same leak you have described since August. Its been looked at 3 times, had the lower and upper sump seals replaced, last time it was in for 3 days. They were so happy they fixed it.... only for me to call the service manager the next day with the good news that it was still leaking. Goes in for attempt #4 on Thursday. My wifes dealing with them this time.... no more mr nice guy
__________________
2014 Maximum Steel Overland, but the misses won't let me drive it!
Reply With Quote
  #149  
Old 01-03-2014, 04:23 AM
Butts_Oz's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Brisbane, QLD
Posts: 201
Thanks: 7
Thanked 14 Times in 10 Posts
Rep Power: 1107
Butts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond repute
Interesting situation since my 10000 km service. I found a small leak of oil from the sump plug just before leaving for my trip from Brisbane to Perth. Whilst the leak wasn't a major concern, I wasn't prepared to travel the Nullarbor and not have this looked into. I discussed the issue with my current service manager in Brisbane and whilst they had said they had some failures with the sump washer, it was more concerning that after a service check in Adelaide today, they identified that the sump plug that had been replaced after the service was not genuine and therefore did not properly seal the sump. So I now have a genuine part and a new belly of oil to test before I leave this weekend for Perth. I can't say that this may fix some of your oil issues, but you might like to check to ensure you have the right parts on your vehicles. The concern from the Adelaide service department was that maybe the thread had been damaged with the non genuine parts which would cause the leak.
__________________
Reply With Quote
  #150  
Old 01-03-2014, 06:17 AM
Premium Member
My Jeep: 2013 3.0L WK2
 
Join Date: Jan 2013
Location: Ballarat Victoria Australia
Posts: 40
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 695
nrb1748 is on a distinguished road
Cool Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by nrb1748 View Post
MY 2014 CRD Laredo July delivery 9600km. Engine oil leak. Dripping from area of sump plug (lowest point) but leak from some where else. Dealer had quick look but unable to find source because of accumulation of oil. Area washed, oil added and will look again next Friday at 10000km service.
Serviced today. Leak caused by poor sealing of the sump which was removed and resealed. Hopefully all good!
__________________
MY2014 Laredo CRD Bright White
Reply With Quote
  #151  
Old 01-03-2014, 07:42 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Brisbane QLD Australia
Posts: 769
Thanks: 13
Thanked 31 Times in 26 Posts
Rep Power: 2140
iboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond repute
Quote:
Originally Posted by nrb1748 View Post

Serviced today. Leak caused by poor sealing of the sump which was removed and resealed. Hopefully all good!
Which service center do you use?

Ours went in for attempt #3 to fix the oil leak yesterday. Expect it back on Monday.

Attempt #1: replace lower sump seal.
Attempt #2: replace lower and upper sump seals
Attempt #3: will keep you posted.
__________________
2014 Maximum Steel Overland, but the misses won't let me drive it!
Reply With Quote
  #152  
Old 01-03-2014, 08:07 AM
Premium Member
 
Join Date: Jun 2013
Posts: 524
Thanks: 1
Thanked 17 Times in 15 Posts
Rep Power: 1104
mmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond repute
Quote:
Originally Posted by nrb1748 View Post
Serviced today. Leak caused by poor sealing of the sump which was removed and resealed. Hopefully all good!

Due to human error or poor quality in parts?
__________________
Reply With Quote
  #153  
Old 01-04-2014, 01:32 AM
Premium Member
My Jeep: 2013 3.0L WK2
 
Join Date: Jan 2013
Location: Ballarat Victoria Australia
Posts: 40
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 695
nrb1748 is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by iboughtajeep View Post
Which service center do you use?

Ours went in for attempt #3 to fix the oil leak yesterday. Expect it back on Monday.

Attempt #1: replace lower sump seal.
Attempt #2: replace lower and upper sump seals
Attempt #3: will keep you posted.
The Jeep dealer at Ballarat. I've owned Nissans previously (the same dealership) and found the dealership to be good. Hope you get yours sorted, and I don't have any further problems.
__________________
MY2014 Laredo CRD Bright White
Reply With Quote
  #154  
Old 01-04-2014, 01:35 AM
Premium Member
My Jeep: 2013 3.0L WK2
 
Join Date: Jan 2013
Location: Ballarat Victoria Australia
Posts: 40
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 695
nrb1748 is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by mmcrh View Post
Due to human error or poor quality in parts?
I'm assuming from the engine assembly process. Not sure whether the problem would be human error or automation?
__________________
MY2014 Laredo CRD Bright White
Reply With Quote
  #155  
Old 01-09-2014, 04:17 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2013
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 325
Fredescu is on a distinguished road
Diesel Limited. Have the issue where the air con blows hot on one side and cold on the other. From reading this thread it sounds pretty common. I assume it's a dealer fix?
__________________
Reply With Quote
  #156  
Old 01-09-2014, 04:35 PM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2013
Location: NSW Australia
Posts: 979
Thanks: 80
Thanked 108 Times in 96 Posts
Rep Power: 1700
SJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond repute
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by Fredescu View Post
Diesel Limited. Have the issue where the air con blows hot on one side and cold on the other. From reading this thread it sounds pretty common. I assume it's a dealer fix?
It sounds like the dealer hasn't applied this TSB Fredescu.

http://www.wk2jeeps.com/tsb/tsb_wk2_2400113.pdf

It takes about 20 minutes.
__________________

__________________
'07 WK Limited 5.7 Hemi
'14 WK2 Overland CRD ORAII

Ordered May 26th:
MY15 KL Limited Cherokee. True Blue/Moroccan Black. 2.0L CRD with Tech group, Electronics group, Pano and Stop/Start.
Estimated Delivery to Port Kembla: Nov 1st
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Grand Cherokee information - Australia Milous Export Grand Cherokee 2011+ 12365 10-20-2014 07:43 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.