Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #193  
Old 01-21-2014, 11:26 PM
Jarse's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Sydney, Australia
Posts: 120
Thanks: 2
Thanked 9 Times in 8 Posts
Rep Power: 640
Jarse is on a distinguished road
Don't hold your breath waiting for the door handle. Mine's been on order since early Nov, along with a glove box lid and lock.
They must be made of unobtanium or some other rare plastic.
__________________

__________________
Reply With Quote
  #194  
Old 01-21-2014, 11:27 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2014
Location: Melbourne, Australia
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 355
Acesi7 is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by Jarse View Post
Don't hold your breath waiting for the door handle. Mine's been on order since early Nov, along with a glove box lid and lock.
They must be made of unobtanium or some other rare plastic.
He did tell me it would be between 4-8 weeks. So I wasn't expecting it anytime soon.

Hopefully your will arrive soon!
__________________

__________________
2014 Jeep Grand Cherokee Overland 4x4 - Granite Crystal - 3.6l Pentastar V6 Petrol
Reply With Quote
  #195  
Old 01-22-2014, 12:51 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jul 2013
Posts: 110
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 631
chooke is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by Peterjw View Post
Had GC Limited just a few months & having same problem with Cruise Control as mentioned in several posts. Stops working after using the Set + or Set - and cannot be reset until ignition is turned off & back on again. Dealer just changed the CC switch & 'module' but has not fixed the problem.
Can anyone who has had the same problem tell me what the fix was?
Mine appears to have been fixed with the current uconnect software update.

On another front, I'm dropping my Jeep to another dealer tomorrow for its 6mth service and to try and resolve two of the issues I had since new which the dealer I purchased the car from has not been able to diagnose, let alone fix - engine vibration at idle and clunking/rattling noise over bumps.

In regard to the latter, I have been told it is most likely to be the shock absorbers as it is a well known fault on the 2014 series. I also heard that Jeep Australia has replaced the shocks for some owners. Does anyone know anything about this issue?
__________________
Reply With Quote
  #196  
Old 01-23-2014, 04:47 AM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Sep 2013
Location: Northern Suburbs, Brisbane
Posts: 36
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 507
WK2Doug is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by chooke View Post
Mine appears to have been fixed with the current uconnect software update.

On another front, I'm dropping my Jeep to another dealer tomorrow for its 6mth service and to try and resolve two of the issues I had since new which the dealer I purchased the car from has not been able to diagnose, let alone fix - engine vibration at idle and clunking/rattling noise over bumps.

In regard to the latter, I have been told it is most likely to be the shock absorbers as it is a well known fault on the 2014 series. I also heard that Jeep Australia has replaced the shocks for some owners. Does anyone know anything about this issue?
Mine are about to be replaced. Complained a couple of months ago about the clunking noise in the rear and received a call from the dealer yesterday explaining the new shocks have arrived and arrange a time for fitting.
__________________
Reply With Quote
  #197  
Old 01-23-2014, 08:22 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: PERTH West Australia
Posts: 37
Thanks: 3
Thanked 2 Times in 2 Posts
Rep Power: 544
Gustlock is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Are any 2014 WK2 CRD owners having issues when taking off slowly. It seems to have a null spot just out of idle. When I push slowly down on the throttle nothing happens initially, then all of a sudden it gets a boot full, making taking off very erratic and not progressive.
Other than this issue and the cruise control fault it performs WELL.
__________________
Reply With Quote
  #198  
Old 01-23-2014, 10:12 PM
Member
 
Join Date: Mar 2012
Posts: 44
Thanks: 0
Thanked 10 Times in 5 Posts
Rep Power: 1073
DS84 is on a distinguished road
Quote:
Originally Posted by chooke View Post
Mine appears to have been fixed with the current uconnect software update. On another front, I'm dropping my Jeep to another dealer tomorrow for its 6mth service and to try and resolve two of the issues I had since new which the dealer I purchased the car from has not been able to diagnose, let alone fix - engine vibration at idle and clunking/rattling noise over bumps. In regard to the latter, I have been told it is most likely to be the shock absorbers as it is a well known fault on the 2014 series. I also heard that Jeep Australia has replaced the shocks for some owners. Does anyone know anything about this issue?
Think I may have said this in an earlier post, however ours had a vibration at idle from new. Turned out that the mounting bolts for the AC compressor weren't tightened correctly. It was quite obvious that it was the AC as it disappeared once you turned the AC off at idle. May be worth a shot...
__________________
Reply With Quote
  #199  
Old 01-23-2014, 10:13 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jul 2013
Posts: 110
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 631
chooke is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by DS84 View Post
Think I may have said this in an earlier post, however ours had a vibration at idle from new. Turned out that the mounting bolts for the AC compressor weren't tightened correctly. It was quite obvious that it was the AC as it disappeared once you turned the AC off at idle. May be worth a shot...
The idle vibration in mine is the same whether the A/C is on or off.
__________________
Reply With Quote
  #200  
Old 01-24-2014, 01:18 AM
Premium Member
 
Join Date: Jun 2013
Posts: 561
Thanks: 1
Thanked 20 Times in 17 Posts
Rep Power: 1204
mmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond repute
Quote:
Originally Posted by Gustlock View Post
Are any 2014 WK2 CRD owners having issues when taking off slowly. It seems to have a null spot just out of idle. When I push slowly down on the throttle nothing happens initially, then all of a sudden it gets a boot full, making taking off very erratic and not progressive. Other than this issue and the cruise control fault it performs WELL.
Same for mine. I guess that's how diesel works.
__________________
Reply With Quote
  #201  
Old 01-24-2014, 03:55 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Brisbane QLD Australia
Posts: 835
Thanks: 13
Thanked 37 Times in 32 Posts
Rep Power: 2268
iboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond repute
Quote:
Originally Posted by Gustlock View Post
Are any 2014 WK2 CRD owners having issues when taking off slowly. It seems to have a null spot just out of idle. When I push slowly down on the throttle nothing happens initially, then all of a sudden it gets a boot full, making taking off very erratic and not progressive.
Other than this issue and the cruise control fault it performs WELL.
Check you haven't got hill start assist turned on. If it is, turn it off... I hated it on
__________________
2014 Maximum Steel Overland, but the misses won't let me drive it!
Reply With Quote
  #202  
Old 01-24-2014, 04:37 AM
SNUKE's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2013
Location: Sydney, Aus
Posts: 3,179
Thanks: 85
Thanked 326 Times in 266 Posts
Rep Power: 5960
SNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond repute
Garage
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by Gustlock View Post
Are any 2014 WK2 CRD owners having issues when taking off slowly. It seems to have a null spot just out of idle. When I push slowly down on the throttle nothing happens initially, then all of a sudden it gets a boot full, making taking off very erratic and not progressive.
Other than this issue and the cruise control fault it performs WELL.
Unless you are level, then look at Hill Start Assist as the culprit, drove us insane, sure the car won't move down a hill when you take the foot off the brake, but it also doesn't move until the revs hit about 1,200-1,300.

If that is not the issue, then turn ECO mode OFF, and it will be completely different as well, also revs to about 1,200 before moving. Very strange an not economical. If I don't turn Eco off, then I simply don't notice it as I put my foot down more and it goes straight to the right rev.

Somewhere here in this or another thread someone mention that a high stall converter could be the culprit. Either way, i don;t get it with Hill Start Assist and Eco mode off.

The bottom option in this pic, un-tick it.

__________________
I'm just want it for the "shorter headlamps".

MY14 GC Limited, 3.0 CRD, Lux II, Granite Crystal, 18" Wheels, Tubular Side Steps.
Could I get my avatar much larger?
Ordered: July 7 2013 Delivered Nov 25th
Reply With Quote
  #203  
Old 01-24-2014, 05:01 AM
Premium Member
 
Join Date: Jun 2013
Posts: 561
Thanks: 1
Thanked 20 Times in 17 Posts
Rep Power: 1204
mmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond repute
Quote:
Originally Posted by mmcrh View Post
Same for mine. I guess that's how diesel works.
Mine is on level surface, Eco mode off.
__________________
Reply With Quote
  #204  
Old 01-24-2014, 05:51 AM
SNUKE's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2013
Location: Sydney, Aus
Posts: 3,179
Thanks: 85
Thanked 326 Times in 266 Posts
Rep Power: 5960
SNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond repute
Garage
Do you have Hill Start Assist on?
If so turn it off and see if it makes a difference.
__________________

__________________
I'm just want it for the "shorter headlamps".

MY14 GC Limited, 3.0 CRD, Lux II, Granite Crystal, 18" Wheels, Tubular Side Steps.
Could I get my avatar much larger?
Ordered: July 7 2013 Delivered Nov 25th
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Grand Cherokee information - Australia Milous Export Grand Cherokee 2011+ 12664 12-24-2014 05:01 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.