Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #217  
Old 01-26-2014, 03:46 AM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2013
Location: NSW Australia
Posts: 814
Thanks: 52
Thanked 69 Times in 61 Posts
Rep Power: 1374
SJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond repute
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by Aus summit View Post
Mine had the same problem until I took it in for the 1k km check up. They did a software update and hey presto when I got it back perfect. Not sure if it was a coincidence or not but all fixed nonetheless.
Yes, a flash to the software is always an option available to a car manufacturer.

ZF market the 8 speed and 9 speed transmissions as having 'adaptive logic/intelligence' and as such in best case scenarios, learn the driving style of the primary driver ie: who drives it the most and adjust the transmission to suit.

However, it doesn't always do that, (and logically it can't if multiple drivers use the vehicle over an average of the same number of hours) in which case the manufacturer can always reflash the software to change the 'adaptive' capability.

I have read and read and read ZF stuff over the last few months including not only their own marketing/selling material but also a lot of Audi owner forums and Jaguar owner forums that report the same issue and also the ability of the manufacturers to change the software that changes the adaptive ability.

I think that is the brilliance of the ZF transmission. It is changeable - be that via driver or via manufacturer through a flash if too many owners get the irrits.

In our case, it adapted - in other case's it may not, in which case I believe that CJD have a flash available.

That is my understanding of how the ZF transmissions work.
__________________

__________________
'07 WK Limited 5.7 Hemi
'14 WK2 Overland CRD ORAII

Ordered: MY14 KL Limited Cherokee. True Blue/Moroccan Black. 2.0L CRD with Tech group, Electronics group and Pano. Delivery - ??
Reply With Quote
  #218  
Old 01-26-2014, 04:53 AM
SNUKE's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2013
Location: Sydney, Aus
Posts: 2,466
Thanks: 53
Thanked 198 Times in 167 Posts
Rep Power: 5083
SNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond repute
Garage
Re: 2014 Grand Cherokee Problems - Australia

There were a few posts about it this week, for anyone that did not see those threads, here is an overview of the MY14 Altitude Editions - Jeep Grand Cherokee WK2 - 2012-2014 Jeep Altitude limited editions
__________________

__________________
I'm just want it for the "shorter headlamps".

MY14 GC Limited, 3.0 CRD, Lux II, Granite Crystal, 18" Wheels, Tubular Side Steps.
Could I get my avatar much larger?
Ordered: July 7 2013 Delivered Nov 25th
Reply With Quote
  #219  
Old 01-26-2014, 03:25 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Nov 2013
Location: Sunshine coast QLD
Posts: 70
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 299
knight rider is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by SNUKE View Post
Do you have Hill Start Assist on?
If so turn it off and see if it makes a difference.
Thanks SNUKE
Drove mine yesterday with the Hill Start Assist off made a world of difference.
No more flat spot or dead spot when taking off. Cheers
__________________
Reply With Quote
  #220  
Old 01-27-2014, 02:00 AM
Twscoot's Avatar
Member
 
Join Date: Jul 2011
Location: Brisbane Australia
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1141
Twscoot is on a distinguished road
Quote:
Originally Posted by Twscoot View Post

Forced regen they tell me today. I fear they have seen several MY14s with the same issue. Only once though then they are ok........ (Hold breath).
Servicing dealer have been responsive (thanks).
So a week later the car is running fine. But of course I'm worried about it all happening again.
Anyone who has had a MY14 CRD go into limp mode due to a full DPF (which has since been fine) please put my mind at rest!
__________________
Reply With Quote
  #221  
Old 01-29-2014, 01:47 AM
Premium Member
 
Join Date: May 2013
Location: Brisbane
Posts: 27
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 452
zacaxel1975 is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by SNUKE View Post
SOFT RESET:
This reset will retain your settings.
Hold MUTE and TUNE buttons for reboot. .

If that does nothing.... then:

FACTORY RESET:
This engineering reset will wipe all your settings.
Hold TEMP up and TEMP down buttons to access engineering menu.
When it restarts it will do so with SRT screen, and take a few minutes to get back to normal.
Thanks Snuke, tried both of those but hasnt fixed the problem.
It has stopped the text messages being available through the Uconnect since the reset unfortunately.
__________________
Reply With Quote
  #222  
Old 01-29-2014, 06:21 AM
Domo10's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jun 2013
Location: Melbourne VIC AU
Posts: 284
Thanks: 29
Thanked 11 Times in 10 Posts
Rep Power: 679
Domo10 is on a distinguished road
Quote:
Originally Posted by knight rider View Post
Thanks SNUKE Drove mine yesterday with the Hill Start Assist off made a world of difference. No more flat spot or dead spot when taking off. Cheers
I did the same - makes the world of difference!
__________________
MY14 GC Limited CRD, Maximum Steel, LuxII, Pano Roof, Side Steps, Enjoying it!!
Reply With Quote
  #223  
Old 01-29-2014, 06:23 AM
Twscoot's Avatar
Member
 
Join Date: Jul 2011
Location: Brisbane Australia
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1141
Twscoot is on a distinguished road
Quote:
Originally Posted by Domo10 View Post

I did the same - makes the world of difference!
Ditto. Mine's off as of yesterday. Much smoother.
__________________
Reply With Quote
  #224  
Old 01-29-2014, 06:46 AM
SNUKE's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2013
Location: Sydney, Aus
Posts: 2,466
Thanks: 53
Thanked 198 Times in 167 Posts
Rep Power: 5083
SNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond repute
Garage
Re: 2014 Grand Cherokee Problems - Australia

I did some tests on the weekend. We have just under 3,500km on the car.

I notice the difference between eco on and off was minimal at best.
I turned Hill Assist back on, and it made no difference from the lights on a flat section of road.

I think there is simply an amount of learning that the gearbox does, engine braking in, and learning throttle response that makes the initial lag to launch sensation go away.

Hill Assist will still stay off, as it kills throttle control when we are reversing the horse float.
__________________
I'm just want it for the "shorter headlamps".

MY14 GC Limited, 3.0 CRD, Lux II, Granite Crystal, 18" Wheels, Tubular Side Steps.
Could I get my avatar much larger?
Ordered: July 7 2013 Delivered Nov 25th
Reply With Quote
  #225  
Old 01-29-2014, 02:49 PM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Sydney, Australia
Posts: 97
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 453
Jarse is on a distinguished road
Quote:
Originally Posted by zacaxel1975 View Post
Thanks Snuke, tried both of those but hasnt fixed the problem. It has stopped the text messages being available through the Uconnect since the reset unfortunately.
If you have an iphone: Delete the bluetooth pairings between the phone & Uconnect. Re-pair,then once you've done so, go to bluetooth settings on the phone and select the Uconnect pairing. Switch on 'Show Notifications' and she'll be tickety-boo within a couple of minutes.

Snuke, I don't think Hill Start is active on level ground, which would explain your observations. I remember reading something about needing to be on a x% gradient and in the right gear or something......
__________________
Reply With Quote
  #226  
Old 01-29-2014, 04:57 PM
SNUKE's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2013
Location: Sydney, Aus
Posts: 2,466
Thanks: 53
Thanked 198 Times in 167 Posts
Rep Power: 5083
SNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond repute
Garage
Re: 2014 Grand Cherokee Problems - Australia

Sounds right Jarse, and what i would expect, I tried it as mmcrh was having the issue on level ground.
__________________
I'm just want it for the "shorter headlamps".

MY14 GC Limited, 3.0 CRD, Lux II, Granite Crystal, 18" Wheels, Tubular Side Steps.
Could I get my avatar much larger?
Ordered: July 7 2013 Delivered Nov 25th
Reply With Quote
  #227  
Old 01-30-2014, 01:33 AM
Premium Member
 
Join Date: Jun 2013
Posts: 404
Thanks: 0
Thanked 11 Times in 9 Posts
Rep Power: 883
mmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond repute
Quote:
Originally Posted by SNUKE View Post
Sounds right Jarse, and what i would expect, I tried it as mmcrh was having the issue on level ground.
Snuke,

A couple of reasons contributed to my lagging take off from still position on level ground:

1) engine not fully warm up as lagging is conspicuous in the morning
2) the transmission is going through learning curve, n is improving noticeably

I like Eco mode (default to on when engine starts) as it lowers to aero mode when certain speed is exceeded.

Fuel consumption is great, average 6.7L/100km so far at speed between 100-110, n was 6.1L when speed was around 85.
__________________
Reply With Quote
  #228  
Old 01-30-2014, 03:13 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2013
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 224
Fredescu is on a distinguished road
Quote:
Originally Posted by mmcrh View Post
Fuel consumption is great, average 6.7L/100km so far at speed between 100-110, n was 6.1L when speed was around 85.
That's amazing, I haven't seen it that low yet. I've done a few long trips too but it was fairly hilly country.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Grand Cherokee information - Australia Milous Export Grand Cherokee 2011+ 11642 07-14-2014 12:28 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community