Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #289  
Old 03-21-2014, 03:35 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Brisbane QLD Australia
Posts: 734
Thanks: 13
Thanked 28 Times in 23 Posts
Rep Power: 2071
iboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond repute
Quote:
Originally Posted by Jeepski View Post
I'm really pissed off with Jeep Australia and AAMI
Not Parts!
I love my new Grand Cherokee 2014 Laredo CRD with Quadra lift Air suspension but miss it terribly. My 1st trip into the country in Kosciusko National park my two month old Jeep was struck by a falling gum tree while travelling on sealed road.

This was the 3rd of January 2014. Now 11 weeks later I am still waiting for roof parts because there are none in Australia. Today I was told that Jeep Australia ordered the wrong roof parts and I may have to wait another 5 weeks. That will be 15 weeks waiting for panel parts for the roof.

I cannot understand why a four wheel drive vehicle company does not carry spare roof parts in Australia and why does it take so long to get them.

$16,000 for the roof replacement and once the parts are received it is estimated repair will take another 5 weeks.

So my Jeep story is this.
Ordered 2014-model 10 April 2013
Delivered 6 month later 28 October 2013
2 months use
1st country trip a tree fell on roof 3rd Jan 2014
11 weeks waiting for parts to date 21/03/2014
Still waiting and may be another 10 weeks until I get it back.
Total time will be 21 weeks for a roof repair.
Who wants a Jeep with no spare parts in Australia?
Insured with AAMI. – No loan car or assistance.
Thanks for listening to my bitching.
Is there anyone else out there having similar problems?
Cheers
Jeepski7
Yeah, I hear you. 6 weeks wait for a crank angle sensor. Have you tried approaching Jeep for a courtesy car?, ..... actually on second thought, don't waste your time.. they don't know what customer service is and would be unfamiliar with what a courtesy car is. Maybe the panel shop? Unfortunately we have a pretty good relationship with a panel shop due to our employees company vehicles, and they have vehicles they loan us.
__________________

__________________
2014 Maximum Steel Overland, but the misses won't let me drive it!
Reply With Quote
  #290  
Old 03-21-2014, 08:33 PM
Premium Member
 
Join Date: Jun 2013
Posts: 508
Thanks: 1
Thanked 15 Times in 13 Posts
Rep Power: 1055
mmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond repute
I encountered a weird problem today. While listening to the radio, I pressed VR button, after beep, voice command TUNE TO PRESET 2, there's no response, Uconnect went into absolute silent mode, i.e. no sound from radio (the screen showed station and name of music playing w/o sound), navigation sill navigated w/o turn-by-turn votive guidance. I pressed VR button, no response, pressed Green Phone button, no response. Shut down and restarted engine to no avail. I tried reset (hold down Mute and Tune buttons, thanks to this forum), voila! it brought the sound back.

Has anyone experienced, or heard of this kinda problem, or known TSB for the fix? Thanks in advance.

Mmc
__________________

__________________
Reply With Quote
  #291  
Old 03-21-2014, 09:21 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth WA
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 435
Gustlock is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by mmcrh View Post
I encountered a weird problem today. While listening to the radio, I pressed VR button, after beep, voice command TUNE TO PRESET 2, there's no response, Uconnect went into absolute silent mode, i.e. no sound from radio (the screen showed station and name of music playing w/o sound), navigation sill navigated w/o turn-by-turn votive guidance. I pressed VR button, no response, pressed Green Phone button, no response. Shut down and restarted engine to no avail. I tried reset (hold down Mute and Tune buttons, thanks to this forum), voila! it brought the sound back.

Has anyone experienced, or heard of this kinda problem, or known TSB for the fix? Thanks in advance.

Mmc
Similar but VR seems to corrupts SD and USB drives when VR used to select a song. Media will only play that song repeatedly and will not recognize the other songs on the drives. Have to delete that song from the drives to reset system. Have waited for latest update to supposedly address this issue but now when VR used it doesn't recognize all the tracks on the drive after a song is selected. Just hope it hasn't corrupted some other fragile system with this latest update.
__________________
Reply With Quote
  #292  
Old 03-22-2014, 05:36 AM
Gforce's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2013
Location: Queensland, Australia
Posts: 313
Thanks: 0
Thanked 14 Times in 13 Posts
Rep Power: 924
Gforce is a name known to all
Quote:
Originally Posted by SNUKE View Post
I guess you will be making sure you have hire car coverage in your policy next time.
Good reminder Snuke, I will be checking my policy ASAP.
__________________
2014 GC Limited, CRD, White.
Reply With Quote
  #293  
Old 03-22-2014, 05:56 AM
SNUKE's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2013
Location: Sydney, Aus
Posts: 2,852
Thanks: 68
Thanked 267 Times in 217 Posts
Rep Power: 5537
SNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond repute
Garage
Re: 2014 Grand Cherokee Problems - Australia

I paid $99 a year extra for 20 days coverage.
__________________
I'm just want it for the "shorter headlamps".

MY14 GC Limited, 3.0 CRD, Lux II, Granite Crystal, 18" Wheels, Tubular Side Steps.
Could I get my avatar much larger?
Ordered: July 7 2013 Delivered Nov 25th
Reply With Quote
  #294  
Old 03-22-2014, 06:50 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Brisbane QLD Australia
Posts: 734
Thanks: 13
Thanked 28 Times in 23 Posts
Rep Power: 2071
iboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond repute
Quote:
Originally Posted by SNUKE View Post
I paid $99 a year extra for 20 days coverage.
If you were to use it, you wll find that the 20 days were up before jeep even ordered any parts.... but I guess thats still 20 days less without a car than you would have had previously.
__________________
2014 Maximum Steel Overland, but the misses won't let me drive it!
Reply With Quote
  #295  
Old 03-27-2014, 11:46 PM
Bloggs's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2013
Location: Hervey Bay area, Queensland, Australia
Posts: 14
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 340
Bloggs is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

I had my Jeep first service on Wednesday, 1,000 klm, and there was no service bulletin to fix the Cruise Control that my dealer could find..

Today there were two issues:
1. Cruise Control and Adaptive Cruise Control - same issue, refused to work giving me the same error message.
2. Received error message on startup to get the air suspension serviced.

These two faults replicated themselves every startup this morning and as I was in town it was perhaps 4 or 5 times. Then it stopped doing it again and was working perfectly when I last used the car.

Also this morning I performed a U Turn and the car appeared to go into limp mode with a back wheel slipping on the road and the car moved sluggishly during the U Turn. I thought it must be in Limp Mode but I have not yet experienced that so am unsure. I stopped after the U Turn and the car appeared good after that. Noticeable it was after that event that the car other defects came good again on the next start.

Cheers
__________________
Bloggs!
Reply With Quote
  #296  
Old 03-28-2014, 01:41 AM
Bigskiddy's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Sydney - Australia
Posts: 316
Thanks: 4
Thanked 25 Times in 21 Posts
Rep Power: 818
Bigskiddy is on a distinguished road
Quote:
Originally Posted by Bloggs View Post

Also this morning I performed a U Turn and the car appeared to go into limp mode with a back wheel slipping on the road and the car moved sluggishly during the U Turn. I thought it must be in Limp Mode but I have not yet experienced that so am unsure. I stopped after the U Turn and the car appeared good after that. Noticeable it was after that event that the car other defects came good again on the next start.

Cheers
That would be the traction control kicking in.
__________________
Reply With Quote
The Following User Says Thank You to Bigskiddy For This Useful Post:
  #297  
Old 03-28-2014, 06:07 AM
Lewy2001's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2014
Location: Tamworth, NSW OZ
Posts: 32
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 278
Lewy2001 is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

I cracked the sump on a rock last weekend. The dealer estimated at least 6-8 week wait for new sump. None in Australia or the US... would have to order from manufacturer.

Have no rental car allowance in insurance but that is only good for fourteen days anyway.

Jeep need to get their spare parts inventory in order these cars are walking out the door at the moment. But lack of spares are giving them a bad name that will ultimately only hurt the brand. The insurance company was already aware of parts supply problems from Jeep.

Will try and get sump repaired by insurance company.

This problem brought to light another problem with these new high tech vehicles. With no oil in engine unable to start to put in neutral but you can not turn the engine off in neutral anyway. So that was no help to the situation anyway.

There most be a manual over ride somewhere but not mentioned in manual. Also lack of front recovery point is a problem. The flatbed tow truck driver was aware of the lightweight recovery eye in with the spare tyre but did not know how to remove the panel on front bar to get access.
__________________
Reply With Quote
  #298  
Old 03-28-2014, 06:11 AM
Lewy2001's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2014
Location: Tamworth, NSW OZ
Posts: 32
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 278
Lewy2001 is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by Bloggs View Post
I had my Jeep first service on Wednesday, 1,000 klm, and there was no service bulletin to fix the Cruise Control that my dealer could find..
18-019-14

Released on 18th March 14 for all WK with 3.0 Diesel Sales Code EXF
__________________
Reply With Quote
  #299  
Old 03-28-2014, 06:23 AM
xdra10's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Adelaide, South Australia
Posts: 94
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 493
xdra10 is on a distinguished road
Quote:
Originally Posted by Lewy2001 View Post
I cracked the sump on a rock last weekend. The dealer estimated at least 6-8 week wait for new sump. None in Australia or the US... would have to order from manufacturer.

Have no rental car allowance in insurance but that is only good for fourteen days anyway.

Jeep need to get their spare parts inventory in order these cars are walking out the door at the moment. But lack of spares are giving them a bad name that will ultimately only hurt the brand. The insurance company was already aware of parts supply problems from Jeep.

Will try and get sump repaired by insurance company.

This problem brought to light another problem with these new high tech vehicles. With no oil in engine unable to start to put in neutral but you can not turn the engine off in neutral anyway. So that was no help to the situation anyway.

There most be a manual over ride somewhere but not mentioned in manual. Also lack of front recovery point is a problem. The flatbed tow truck driver was aware of the lightweight recovery eye in with the spare tyre but did not know how to remove the panel on front bar to get access.
There is a neutral button below the 4wd mode control knob. Need to use a ball point pen to select it.
__________________
2014 Jeep Grand Cherokee Overland, CRD, White with Black leather interior
Tow Bar, Electric Brake controller and Tinted Windows
Reply With Quote
  #300  
Old 03-28-2014, 06:23 AM
Premium Member
 
Join Date: Mar 2012
Posts: 42
Thanks: 0
Thanked 10 Times in 5 Posts
Rep Power: 975
DS84 is on a distinguished road
Quote:
Originally Posted by Lewy2001 View Post
I cracked the sump on a rock last weekend. The dealer estimated at least 6-8 week wait for new sump. None in Australia or the US... would have to order from manufacturer. Have no rental car allowance in insurance but that is only good for fourteen days anyway. Jeep need to get their spare parts inventory in order these cars are walking out the door at the moment. But lack of spares are giving them a bad name that will ultimately only hurt the brand. The insurance company was already aware of parts supply problems from Jeep. Will try and get sump repaired by insurance company. This problem brought to light another problem with these new high tech vehicles. With no oil in engine unable to start to put in neutral but you can not turn the engine off in neutral anyway. So that was no help to the situation anyway. There most be a manual over ride somewhere but not mentioned in manual. Also lack of front recovery point is a problem. The flatbed tow truck driver was aware of the lightweight recovery eye in with the spare tyre but did not know how to remove the panel on front bar to get access.
Bummer, that sux... They must throw all their spare parts in the rear of all the GC's they send over on the boats!

There's a mechanical lever in the centre console underneath a plastic trim near where the hinges of the arm rest are. Takes a fair amount of force to lift up the lever but allows the car to be moved without the engine running.

Good luck with the repair!
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Grand Cherokee information - Australia Milous Export Grand Cherokee 2011+ 12183 09-17-2014 09:00 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community