Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #337  
Old 04-07-2014, 11:55 PM
Member
 
Join Date: Nov 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 303
SidSnot is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by SNUKE View Post
I’m fooling around, that is a balance spring for a mechanical watch.
I suspected as much but then again after seeing this pic of the JGC chassis I almost believed you!
Attached Images
File Type: jpg jeep.jpg (462.9 KB, 29 views)
__________________

__________________
Reply With Quote
  #338  
Old 04-09-2014, 08:52 PM
Bloggs's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2013
Location: Hervey Bay area, Queensland, Australia
Posts: 14
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 316
Bloggs is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Jeep have replaced the Steering Column Control Module for my JGC and believe they have fixed the problems. Time will tell.... but I trust they are right.
Cheers
__________________

__________________
Bloggs!
Reply With Quote
  #339  
Old 04-09-2014, 11:20 PM
Domo10's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jun 2013
Location: Melbourne VIC AU
Posts: 286
Thanks: 29
Thanked 11 Times in 10 Posts
Rep Power: 725
Domo10 is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Clock Spring relaced today - all is good now.
__________________
MY14 GC Limited CRD, Maximum Steel, LuxII, Pano Roof, Side Steps, Enjoying it!!
Reply With Quote
  #340  
Old 05-05-2014, 04:42 AM
New Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2014
Location: NSW Australia
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Peter 1 is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

MY2014 Grand Cherokee LTD 3.0

The usual ones plus one.

The thumping from the rear shock absorber mounts.

The voice control from the Uconnect, particulary the satnav

Complete throttle failure on at least 15 separate occasions.

I am sure the throttle failures are due to my driving style where I cover the brake with my left foot in slow speed dangerous situations. Sometimes an error message is created if it detects pressure on the brake and throttle and the engine goes to idle until you either dab the brake or remove your foot from the throttle and then plant it again.

I have reported it to my local CJD dealer after nearly having a serious accident when the car failed at a very busy roundabout and CJD Australia accept that there is a concern in this area ( probably from other owner reports) but there are no plans to seek a fix at this time.

Apart from that, the car is a great tug and soes everything else I ask of it.
__________________
Reply With Quote
  #341  
Old 05-05-2014, 05:06 AM
Barboots's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 1,077
Thanks: 12
Thanked 77 Times in 66 Posts
Rep Power: 2287
Barboots has disabled reputation
Re: 2014 Grand Cherokee Problems - Australia

Yeah she no likey two foot input at the same time. Must be too confusing.

I used this technique off road a lot... until now.

Cheers,
Steve
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #342  
Old 05-05-2014, 05:35 AM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2013
Location: NSW Australia
Posts: 896
Thanks: 65
Thanked 78 Times in 70 Posts
Rep Power: 1560
SJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond repute
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by Barboots View Post
Yeah she no likey two foot input at the same time. Must be too confusing.

I used this technique off road a lot... until now.

Cheers,
Steve
Steve's right - no likey two feet.

Sounds like the Aussie version of Mumaducks scenario in this US thread:

Welcome ALL 2014+ Jeep Grand Cherokee Ecodiesel owners!

Posts 1188 to 1191
__________________
'07 WK Limited 5.7 Hemi
'14 WK2 Overland CRD ORAII

Ordered: MY14 KL Limited Cherokee. True Blue/Moroccan Black. 2.0L CRD with Tech group, Electronics group and Pano. Delivery - ??
Reply With Quote
  #343  
Old 05-29-2014, 02:21 AM
New Member
 
Join Date: Sep 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
ayjay is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by Twscoot View Post
After a fantastic 6000kms of ownership, I have just succumbed to the dreaded limp mode.
Electronic Throttle control (flashing) and diesel regeneration message along with the check engine light.
Stuck in forth gear and little power.
Tray back to Jeep tomorrow…..
The car has been great until now. Owned diesel cars for some years and never had a regen problem. This car was on the freeway only over a week returning from a trip and hash't done extended city driving in the meantime. I did however have cause to move it around the front yard three times yesterday (started and stopped each time) and didn't drive anywhere. Not long periods of idling though…..
:-(
Andrew
G'Day Andrew, Did your dealer work out what the problem with the ETC was? Our MY14 GJC has now been towed to 2 different dealers with ETC problems, the first dealer "tightened a loose hose" I believe to do with low boost on the turbo, the second dealer can find nothing wrong with the car. THe car has done 16500km has towed a 3t caravan to Qld and back but on its second outing with the van on the ETC and engine warning lights came on and went into limp mode. Jeep assist were very good and we were towed to the first dealer who tightened the hose. The remainder of the trip home went without incident. About 2 weeks later without the van on it happened again this time because of weekend we left the car for about 2 hours then restarted and everything was good again for about 3 weeks. Yesterday I hooked the van up again for a service prior to another trip to Qld starting next week when within 5km the ETC came on again and once more we were in limp mode in 3rd gear. Limped home disconnected the van when the engine stalled and a low oil pressure warning light came on as well. Called Jeep assist and had the car towed to our nearest dealer. In the mean time all the warning lights have reset and the dealer can find no fault with the car. As you can well expect we are more than a little bit conserned about our trip with the van to Qld next week. Is there anyone out there with any ideas.
AJ
__________________
Reply With Quote
  #344  
Old 05-29-2014, 03:03 AM
Barboots's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 1,077
Thanks: 12
Thanked 77 Times in 66 Posts
Rep Power: 2287
Barboots has disabled reputation
Re: 2014 Grand Cherokee Problems - Australia

What peeves me with these experiences is that these clowns are just resetting the warnings... like that is a solution in itself. I appreciate these ECUs log countless events, but if you're too lazy to do your job in reviewing it, at least print out the dump and give it to someone who can be bothered.

I think you're in need of an OBD monitor to do your own diagnostics AJ. Tragic... but probably the quickest way forward without too much limping.

Best of luck,
Steve
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #345  
Old 05-29-2014, 05:16 AM
Twscoot's Avatar
Member
 
Join Date: Jul 2011
Location: Brisbane Australia
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1189
Twscoot is on a distinguished road
Quote:
Originally Posted by ayjay View Post

G'Day Andrew, Did your dealer work out what the problem with the ETC was? Our MY14 GJC has now been towed to 2 different dealers with ETC problems, the first dealer "tightened a loose hose" I believe to do with low boost on the turbo, the second dealer can find nothing wrong with the car. THe car has done 16500km has towed a 3t caravan to Qld and back but on its second outing with the van on the ETC and engine warning lights came on and went into limp mode. Jeep assist were very good and we were towed to the first dealer who tightened the hose. The remainder of the trip home went without incident. About 2 weeks later without the van on it happened again this time because of weekend we left the car for about 2 hours then restarted and everything was good again for about 3 weeks. Yesterday I hooked the van up again for a service prior to another trip to Qld starting next week when within 5km the ETC came on again and once more we were in limp mode in 3rd gear. Limped home disconnected the van when the engine stalled and a low oil pressure warning light came on as well. Called Jeep assist and had the car towed to our nearest dealer. In the mean time all the warning lights have reset and the dealer can find no fault with the car. As you can well expect we are more than a little bit conserned about our trip with the van to Qld next week. Is there anyone out there with any ideas.
AJ
Just a forced regen and everything reset. No problem since (6000+km) but I know how you feel. I never got a straight answer about the cause.
__________________
Reply With Quote
  #346  
Old 05-30-2014, 02:12 AM
New Member
 
Join Date: Sep 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
ayjay is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

THanks for your suggestions, spoke to dealer again today going to do some more running around this weekend with van attached and the dealer is going to do some more diagnostics on monday. Hope they find something.
AJ
__________________
Reply With Quote
  #347  
Old 06-27-2014, 08:08 PM
Member
My Jeep: 2013 3.0L WK2
 
Join Date: Jul 2013
Location: Central West New South Wales
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 443
kunwok is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

All,

Have just been advised by local dealer that my vehicle has been added to a list to have the rear shocks replaced (2nd effort) with newly designed shocks and mounts (?); no date on when, though.

Does anyone know of what CJA is proposing in this space, and when it may happen?

David
__________________
Regards,

David

MY14 JGC Laredo 3.0 CRD - Maximum Steel
Reply With Quote
  #348  
Old 07-25-2014, 05:06 PM
Bigskiddy's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Sydney - Australia
Posts: 306
Thanks: 3
Thanked 23 Times in 19 Posts
Rep Power: 784
Bigskiddy is on a distinguished road
Good to see this thread has been asleep awhile, time to wake it up.

Oil leak again discovered at 17500km. Took back to dealer who confirmed there was too much oil everywhere to pin point. They cleaned it down and said come back in a week.
Took it back again, they said it was leaking but unable to tell where from as it had only leaked a small amount. This makes no logical sense to me. Told to drive it more and bring back.

Put another 1500km on it and took back. No sign of a leak apparently...

My GC must have created antibodies and healed itself.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Grand Cherokee information - Australia Milous Export Grand Cherokee 2011+ 12074 08-27-2014 04:57 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community