2014 Grand Cherokee Problems - Australia - Page 43 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Reply
 
Thread Tools Display Modes
 
  #505  
Old 01-18-2016, 12:10 AM
Twscoot's Avatar
Member
 
Join Date: Jul 2011
Location: Brisbane Australia
Posts: 98
Thanks: 12
Thanked 13 Times in 6 Posts
Rep Power: 2259
Twscoot is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Steering rack was replaced under warranty on mine after 2 years and numerous attempts to fix it. Chalk and cheese in driving now. No longer a drift to the left and a much more relaxing drive.


Sent from my iPhone using JeepGarage

Reply With Quote
Sponsored Links
Advertisement
 
  #506  
Old 04-13-2016, 04:03 AM
Grandhaze's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2014
Location: Lismore NSW
Posts: 69
Thanks: 3
Thanked 11 Times in 7 Posts
Rep Power: 1069
Grandhaze is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

After 14 months of no problems I got two today.
The lift gate won't open but I can hear the motor running.
The engine light is on and so is the electronic throttle service light and does max of 60 ks/h.
That happened 4 times in the first 3 months... now what....
Reply With Quote
  #507  
Old 04-13-2016, 04:03 AM
Grandhaze's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2014
Location: Lismore NSW
Posts: 69
Thanks: 3
Thanked 11 Times in 7 Posts
Rep Power: 1069
Grandhaze is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

After 14 months of no problems I got two today.
The lift gate won't open but I can hear the motor running.
The engine light is on and so is the electronic throttle service light and does max of 60 ks/h.
That happened 4 times in the first 3 months... now what....
Reply With Quote
Sponsored Links
Advertisement
 
  #508  
Old 04-13-2016, 04:31 PM
Bigskiddy's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Sydney - Australia
Posts: 664
Thanks: 99
Thanked 123 Times in 88 Posts
Rep Power: 2178
Bigskiddy is on a distinguished road
Quote:
Originally Posted by Grandhaze View Post
After 14 months of no problems I got two today.
The lift gate won't open but I can hear the motor running.
The engine light is on and so is the electronic throttle service light and does max of 60 ks/h.
That happened 4 times in the first 3 months... now what....
Make up a rap song and post it on YouTube...

Looking at your previous posts you definitely got a lemon. What's the dealer response?
Reply With Quote
  #509  
Old 04-14-2016, 02:49 AM
Grandhaze's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2014
Location: Lismore NSW
Posts: 69
Thanks: 3
Thanked 11 Times in 7 Posts
Rep Power: 1069
Grandhaze is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Rang the dealer today who said , Under warranty? Call Jeep assist they will help.
Rang Jeep Assist who said, we don't have mechanics just technicians so cannot help today.
They then arranged a flat bed to collect "Recall" tomorrow morning to take to Dealer. Which dealer Im not sure yet. This third time I will wait to get that iconic pic of it being flatbedded away to fixit world. Still have 18 months of warranty so should be fixed along with the "locked" tail gate. Last time this happened Dealer told me i was using the wrong brand of diesel... Caltex................
Reply With Quote
  #510  
Old 04-14-2016, 02:54 AM
Bigskiddy's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Sydney - Australia
Posts: 664
Thanks: 99
Thanked 123 Times in 88 Posts
Rep Power: 2178
Bigskiddy is on a distinguished road
Wrong brand of fuel..Caltex? Idiots!
For the record I only use Caltex.

Seriously though, I'd be contacting the ACCC or start proceedings through NCAT.
Reply With Quote
  #511  
Old 04-14-2016, 06:20 PM
Grandhaze's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2014
Location: Lismore NSW
Posts: 69
Thanks: 3
Thanked 11 Times in 7 Posts
Rep Power: 1069
Grandhaze is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

If I change the plates would it make any difference.........
Attached Images
File Type: jpg 20160415_085858_resized.jpg (527.5 KB, 45 views)
Reply With Quote
  #512  
Old 04-19-2016, 06:25 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Apr 2014
Location: Blue Mountains, Australia
Posts: 14
Thanks: 0
Thanked 7 Times in 3 Posts
Rep Power: 1183
Blue Max is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

March 2014 3lt Diesel Lerado - Cherry Red.

One Saturday, just a hand-full of days before Christmas 2015 the vehicle suddenly went into limp mode whilst we were towing our caravan. Fortunately we were able to 'limp' it to the nearby Jeep dealer at Penrith (NSW). The workshop was open, it being their busy period, and they were able to analysis the problem which turned out to be a faulty exhaust temperature sensor. This was not an item they had in stock so I had no option but to leave the vehicle with them and took steps to have the caravan towed away. They had the vehicle fixed within three days. I was very happy with their response to the problem but I am now somewhat cautious about doing any remote travels with this vehicle in case it breaks down again. Nevertheless, it is a great car to drive and it tows just fantastic.
Reply With Quote
  #513  
Old 07-06-2016, 03:53 AM
Twscoot's Avatar
Member
 
Join Date: Jul 2011
Location: Brisbane Australia
Posts: 98
Thanks: 12
Thanked 13 Times in 6 Posts
Rep Power: 2259
Twscoot is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Hi all.
Seeking anyone who has had oil appear on the large air transport(?) hose on the passenger side of the engine. Almost like it is 'sweating' through the braided mesh which covers it.
I've found one reference to it but am not sure it's the same. Blow by oil perhaps? Not enough to drip.
Cheers


Sent from my iPhone using JeepGarage
Reply With Quote
  #514  
Old 07-06-2016, 04:16 AM
Boxheadmr's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2014
Location: Sydney, Australia
Posts: 468
Thanks: 82
Thanked 57 Times in 35 Posts
Rep Power: 17360
Boxheadmr has a reputation beyond reputeBoxheadmr has a reputation beyond reputeBoxheadmr has a reputation beyond reputeBoxheadmr has a reputation beyond reputeBoxheadmr has a reputation beyond reputeBoxheadmr has a reputation beyond reputeBoxheadmr has a reputation beyond reputeBoxheadmr has a reputation beyond reputeBoxheadmr has a reputation beyond reputeBoxheadmr has a reputation beyond reputeBoxheadmr has a reputation beyond repute
Re: 2014 Grand Cherokee Problems - Australia

Did u happen to take a photo?
Reply With Quote
  #515  
Old 07-06-2016, 06:01 AM
Twscoot's Avatar
Member
 
Join Date: Jul 2011
Location: Brisbane Australia
Posts: 98
Thanks: 12
Thanked 13 Times in 6 Posts
Rep Power: 2259
Twscoot is on a distinguished road
2014 Grand Cherokee Problems - Australia

It's this one in the photo. The lower of the two braided pipes.
The 'oil' pictured on my finger after running my finger under the pipe looks too light to be engine oil but doesn't smell like diesel. ImageUploadedByJeepGarage1467802839.323765.jpgImageUploadedByJeepGarage1467802854.414893.jpg


Sent from my iPhone using JeepGarage
Reply With Quote
  #516  
Old 07-08-2016, 04:17 AM
Twscoot's Avatar
Member
 
Join Date: Jul 2011
Location: Brisbane Australia
Posts: 98
Thanks: 12
Thanked 13 Times in 6 Posts
Rep Power: 2259
Twscoot is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Ok. A theory after more investigation.
After the last service the plastic engine cowling was gleaming and clean. I wondered why.
Today I removed the cover (hadn't known how easy this was before) to see if there was a source of the 'leak'.
Tracing the pipe all the way to the top of the engine I couldn't find any source of oil.
So I am thinking oil was spilt on the cowling at last service.
It then dripped along one of the ridges and some of it fell onto the pipe. Just enough to eventually settle within the braiding underneath.
They cleaned the cowling. Moped up the spilt oil.
As I'm in the middle of a big 5000km trip towing 2.7 tonnes of van, I've been particularly vigilant about checking things. Found the oil.
This explains why it's gold and not black. It must be 'new' oil!
Thanks for reading. If it's any different I'll let you know but thought it important to close the loop.
Ps. The car has performed faultlessly for the entire trip. Tows like a train.



Sent from my iPhone using JeepGarage
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Grand Cherokee information - Australia Milous Export Grand Cherokee 2011+ 13904 06-13-2017 04:47 AM
2014 Grand Cherokee availability Australia yoda New Members - Welcome! 2 03-24-2013 09:21 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:25 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.