Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #97  
Old 10-21-2013, 05:05 AM
Premium Member
 
Join Date: Jun 2013
Posts: 474
Thanks: 1
Thanked 14 Times in 12 Posts
Rep Power: 992
mmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond reputemmcrh has a reputation beyond repute
Quote:
Originally Posted by mmcrh View Post
Excerpt from owner manual (us version): "The use of fuel additives,.....is not recommended......Fuel system damage or vehicle perforance problems resulting from the use of such fuels or additives is not the responsibility of the manufacturer."

The above quote is for petrol engine. Below is the quote for Diesel engine:

"Commercially available fuel additives are not neces- sary for the proper operation of your diesel engine."
__________________

__________________
Reply With Quote
  #98  
Old 10-21-2013, 05:08 AM
Gforce's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2013
Location: Queensland, Australia
Posts: 313
Thanks: 0
Thanked 14 Times in 13 Posts
Rep Power: 896
Gforce is a name known to all
Quote:
Originally Posted by mmcrh View Post
Excerpt from owner manual (us version): "The use of fuel additives,.....is not recommended......Fuel system damage or vehicle perforance problems resulting from the use of such fuels or additives is not the responsibility of the manufacturer."
Would depend on the additive, some I would imagine could cause a problem, the one I use is Australian and guaranteed not to cause any problems. In any case how would you prove it one way or another? ... Personal choice hey.
__________________

__________________
2014 GC Limited, CRD, White.
Reply With Quote
  #99  
Old 10-25-2013, 04:09 AM
Butts_Oz's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Brisbane, QLD
Posts: 200
Thanks: 6
Thanked 14 Times in 10 Posts
Rep Power: 1044
Butts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond reputeButts_Oz has a reputation beyond repute
Has anyone noticed any increased noises appearing from the rear of the vehicle? We may have inherited some creaks and groans. It's almost like we are sailing in an old wooden boat. Could this be a result of towing?
__________________
Reply With Quote
  #100  
Old 10-25-2013, 05:14 AM
Member
 
Join Date: Jun 2013
Posts: 80
Thanks: 0
Thanked 4 Times in 3 Posts
Rep Power: 517
Buster01 is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

We have a really annoying creak, seemingly from the sunroof, although I am not convinced. Not due to towing, mainly random although it seems to settle at speed.
__________________
Reply With Quote
  #101  
Old 10-25-2013, 06:04 AM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Sep 2013
Location: Northern Suburbs, Brisbane
Posts: 33
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 379
WK2Doug is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by Butts_Oz View Post
Has anyone noticed any increased noises appearing from the rear of the vehicle? We may have inherited some creaks and groans. It's almost like we are sailing in an old wooden boat. Could this be a result of towing?
Hooked the van up for the first time last week and the first thing I noticed when I started moving were creaks and groans coming out of the back. Mine is going in for it's first check-up on Monday and I have listed this to be looked at.
__________________
Reply With Quote
  #102  
Old 10-25-2013, 08:44 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Brisbane QLD Australia
Posts: 725
Thanks: 13
Thanked 25 Times in 22 Posts
Rep Power: 2034
iboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond repute
No creaky noises, but it has developed an oil leak the service manager tells us requires the front diff, steering rack and sump removed to fix..... goes in for surgery on Tuesday and has to stay in overnight, possibly two. Will let you know the outcome.
__________________
2014 Maximum Steel Overland, but the misses won't let me drive it!
Reply With Quote
  #103  
Old 10-26-2013, 12:46 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Brisbane QLD Australia
Posts: 725
Thanks: 13
Thanked 25 Times in 22 Posts
Rep Power: 2034
iboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond reputeiboughtajeep has a reputation beyond repute
Update. Today the car turned yellow. Had the following display up on the dash:
Service air suspension
Service air bags
Service ABS
Vehicle not in park (while it was in park)

Contacted Jeep Assist, and they sent out Alliance Road side assist. The mechanic turned up and said Second brand new Jeep for the day. Plugged in his scan tool and it came back with "0415 - invalid data received from ABS module"

I think we better get used to the bitter taste of Lemons.
Attached Images
File Type: png ForumRunner_20131026_153835.png (426.2 KB, 33 views)
File Type: png ForumRunner_20131026_153858.png (426.2 KB, 39 views)
File Type: png ForumRunner_20131026_153921.png (426.2 KB, 28 views)
File Type: png ForumRunner_20131026_153947.png (426.2 KB, 33 views)
File Type: png ForumRunner_20131026_154029.png (426.2 KB, 24 views)
__________________
2014 Maximum Steel Overland, but the misses won't let me drive it!
Reply With Quote
  #104  
Old 10-26-2013, 08:41 AM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2013
Location: Adelaide, South Australia
Posts: 14
Thanks: 4
Thanked 3 Times in 3 Posts
Rep Power: 1473
Berg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond repute
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by Gustlock View Post
The vibration is definitely engine related as it is most noticeable when the vehicle is stationary. Haven't been informed if they have fixed it or not.The vehicle drove really nice with good shifts except when slowing down for lights, the downshift to 1st seemed a bit harsh but not on all occasions. These problems are frustrating and with the additional expenses far beyond normal warranty issues even for a new model to the purchasers. JEEP and some dealerships don't seem to be to worried but they should.

"Don't Hold Back" or maybe "There Wont Be A Next Time."
Hey Gustlock, I picked up my Overland CRD 2 days ago and exactly the same symptoms/issues. Otherwise I think the car is brilliant, but definitely not all as it should be with drivetrain somewhere. Have you had any luck getting a solution as yet. I went back to dealer today who offered to have a 'look at it during the week'. Mine has the same issues you described when driving but also a noticeable 'clunk' when going from P to D or N to D and back. I would like to have an idea of the issue, or the frequency of this happening with any of the 8 speed autos before I get another 'she'll be right' type response from dealer.
__________________
Reply With Quote
  #105  
Old 10-26-2013, 03:51 PM
Premium Member
 
Join Date: Mar 2012
Posts: 42
Thanks: 0
Thanked 10 Times in 5 Posts
Rep Power: 946
DS84 is on a distinguished road
Ours too had an annoying vibration/noise in the engine at idle when we first picked up our GC. It turned out to be caused by loose mounting bolts on the air conditioner compressor. Once they were tightened up she was as good as gold. Try turning off your AC at idle and see if the vibration goes away, if it does, it's a good chance that this may be your issue.
__________________
Reply With Quote
  #106  
Old 10-26-2013, 05:06 PM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2013
Location: Adelaide, South Australia
Posts: 14
Thanks: 4
Thanked 3 Times in 3 Posts
Rep Power: 1473
Berg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond reputeBerg570 has a reputation beyond repute
Thanks very much for the tip DS84. I'll give it a go but from the way the transmission behaves coming to a stop and at idle I think that the auto box might be the culprit. The issues as previously described by Gusta is the same as what I'm experiencing. Other than that little worry, the car is brilliant.
__________________
2014 Black JGC Overland CRD

"If you are going to skate on thin ice, you may as well dance"
Reply With Quote
  #107  
Old 10-27-2013, 04:12 AM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Sep 2013
Location: Northern Suburbs, Brisbane
Posts: 33
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 379
WK2Doug is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

I have another issue I'll put out there. I have my door lock setting activated and at around 25/30 Km/h the doors automatically lock. When I stop I cannot open the driver's door from the inside until I depress the door unlock button. However the passenger's door can be opened from the inside without touching the unlock button. Sometimes (randomly) if the passenger's door is opened, that action will unlock all doors. Anyone having the same problem?
__________________
Reply With Quote
  #108  
Old 10-27-2013, 07:55 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth WA
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 406
Gustlock is on a distinguished road
Re: 2014 Grand Cherokee Problems - Australia

Quote:
Originally Posted by Berg570 View Post
Hey Gustlock, I picked up my Overland CRD 2 days ago and exactly the same symptoms/issues. Otherwise I think the car is brilliant, but definitely not all as it should be with drivetrain somewhere. Have you had any luck getting a solution as yet. I went back to dealer today who offered to have a 'look at it during the week'. Mine has the same issues you described when driving but also a noticeable 'clunk' when going from P to D or N to D and back. I would like to have an idea of the issue, or the frequency of this happening with any of the 8 speed autos before I get another 'she'll be right' type response from dealer.
I have a NEW GC it's done only 350km. The dealership replaced the other one due to the time it was taking for solution to some of the problems, mainly the engine vibration / rough running causing the frustration for all concerned. They tell me it was a fuel pump in the end, causing the vibration thru the vehicle and after driving it a few Km's, all came good. This one is absolutely perfect in ever way, at this stage. The auto initially down shifted the same but after taking it for a quick run down south it was fine (auto learning ?????). Engine is sweet as, can't wait till it has a few more K's on it to give it the big towing test. Have noticed the Trans Temp to be a bit high at freeway speed but that's ALL (93deg) will see if it settles down with a few more K's. On the auto clunking both vehicles were good, just takes a bit of getting use to the shifter. This is not a fix forum but my 07 WH GC had that problem with clunking and it was a front Diff bushing.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Grand Cherokee information - Australia Milous Export Grand Cherokee 2011+ 12033 08-22-2014 08:09 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community