Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 03-22-2013, 03:46 PM
SnoFire's Avatar
The Negotiator
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 4,872
Thanks: 55
Thanked 135 Times in 114 Posts
Rep Power: 390036
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
Re: 2014 issues

Quote:
Originally Posted by kohj1978 View Post
You think Microsoft is bad, But the Bad news is that our system runs Blackberry type OS made by RIM, and anyone with a blackberry knows its going to have some bugs, and god help you if you have too many things going on or change settings to quick, they just dont like it.
I've had BB for years but haven't had a chance to play with the BB10 OS. There were little problems with their OS but nothing I've ever seen or hear like this. Where did you find out that this uses BB OS?
__________________

__________________
2014 GC Limited V6 LuxII/Tow/RA4 Max Steel/Blk Michelin LTX M/S2

Reply With Quote
  #14  
Old 03-22-2013, 06:05 PM
weck's Avatar
Member
 
Join Date: Nov 2012
Location: Wisco
Posts: 747
Thanks: 14
Thanked 24 Times in 24 Posts
Rep Power: 3655
weck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond repute
Re: 2014 issues

Quote:
Originally Posted by SnoFire View Post
I've had BB for years but haven't had a chance to play with the BB10 OS. There were little problems with their OS but nothing I've ever seen or hear like this. Where does did you find out that this uses BB OS?
Here ya go sno

2013 UConnect 2: the next generation
__________________

__________________
Reply With Quote
The Following User Says Thank You to weck For This Useful Post:
  #15  
Old 03-22-2013, 06:14 PM
SnoFire's Avatar
The Negotiator
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 4,872
Thanks: 55
Thanked 135 Times in 114 Posts
Rep Power: 390036
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
Re: 2014 issues

Can anyone go here and use the last 8 of their VIN to see if there is an update?

https://rsur.extra.chrysler.com/rsur/Uconnect.do
__________________
2014 GC Limited V6 LuxII/Tow/RA4 Max Steel/Blk Michelin LTX M/S2

Reply With Quote
  #16  
Old 03-22-2013, 06:31 PM
SnoFire's Avatar
The Negotiator
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 4,872
Thanks: 55
Thanked 135 Times in 114 Posts
Rep Power: 390036
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
Re: 2014 issues

Looking at the Dodge Dart forums it seems they are experiencing the same issues with the radio. A few of them took it into the dealer and got some part ordered and it fixed it. Others, not so much.
__________________
2014 GC Limited V6 LuxII/Tow/RA4 Max Steel/Blk Michelin LTX M/S2

Reply With Quote
  #17  
Old 03-22-2013, 06:46 PM
SnoFire's Avatar
The Negotiator
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 4,872
Thanks: 55
Thanked 135 Times in 114 Posts
Rep Power: 390036
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
Re: 2014 issues

I got this from the Dodge Forum, maybe it will help if someone wants to give it a shot

NOTE: do at your own risk!!

"Hold both the Heating and cooling buttons for 5 seconds, I have dual climate so I held both drivers and passenger side heating and cooling, for 5 seconds.

Then you will enter the "secret" engineering menu.

You can scroll down and reset to factory settings

the system will reboot, and you have now reset your system."

After The reset the radio and menus were completely different from when I received the truck. I thought I really screwed up. Prior to doing the reset I had the ram logo on the screen and everything was orange and black. After the reset i had the uconnect emblem and everything was blue and black. The buttons in the bottom menu were different as well. The settings were complete different too.

The next morning I called and made an appointment to bring my truck in. Well, when I got off the phone, I went out and started the truck. When the radio came on everything was back to normal. The only thing I can think is the radio download the correct software over the air through the night.

So far everything has been working great. Hopefully this will correct my reset issues.

Again do the following at your own risk.
__________________
2014 GC Limited V6 LuxII/Tow/RA4 Max Steel/Blk Michelin LTX M/S2

Reply With Quote
  #18  
Old 03-22-2013, 06:58 PM
JTS97Z28's Avatar
Premium Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jan 2011
Location: Plainfield, IL
Posts: 1,451
Thanks: 0
Thanked 29 Times in 19 Posts
Rep Power: 25175
JTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond repute
Send a message via AIM to JTS97Z28
Re: 2014 issues

Quote:
Originally Posted by SnoFire View Post
The only thing I can think is the radio download the correct software over the air through the night.
lol im pretty sure your Jeep didn't download anything on its own over night. Not sure if you were being sarcastic or not, but either way it did not do that.
What happens is these radios/nav/computer systems were made to work in pretty much all the Chrysler vehicles. Since you reset the unit it defaulted back to Dodge settings. Not sure why it goes to Dodge, but as long as I have known that's what they do. Once you started your Jeep all the computers and modules were able to interact again and find out which vehicle it was in and boot as it should. If you ripped out your vehicles nav/radio system and hooked it up into a Chrysler 300 for example, it would automatically display Chrysler settings once it "paired" with that cars computer modules. Back in the day I installed an Chrysler RB1 nav (the original Chrysler nav system), that came out of a PT Cruiser. Upon initial installation it showed the Dodge logo until I started my Jeep in which after that everything showed up how it should.
__________________
2012 Overland...sold
2007 Acura TL Type S 6mt
Reply With Quote
  #19  
Old 03-22-2013, 07:02 PM
SnoFire's Avatar
The Negotiator
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 4,872
Thanks: 55
Thanked 135 Times in 114 Posts
Rep Power: 390036
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
Re: 2014 issues

I don't have a Jeep yet so I didn't try this, just got it from the Dodge Ram forums. Just reposting to see if someone wanted to try it..The person that posted this supposedly go it from the Ram customer service person who helped him reset his radio.
__________________
2014 GC Limited V6 LuxII/Tow/RA4 Max Steel/Blk Michelin LTX M/S2

Reply With Quote
  #20  
Old 03-22-2013, 07:02 PM
FAUEE's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Feb 2012
Location: Hickory, NC
Posts: 941
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 4596
FAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond reputeFAUEE has a reputation beyond repute
Re: 2014 issues

Quote:
Originally Posted by JTS97Z28 View Post
lol im pretty sure your Jeep didn't download anything on its own over night. Not sure if you were being sarcastic or not, but either way it did not do that.
What happens is these radios/nav/computer systems were made to work in pretty much all the Chrysler vehicles. Since you reset the unit it defaulted back to Dodge settings. Not sure why it goes to Dodge, but as long as I have known that's what they do. Once you started your Jeep all the computers and modules were able to interact again and find out which vehicle it was in and boot as it should. If you ripped out your vehicles nav/radio system and hooked it up into a Chrysler 300 for example, it would automatically display Chrysler settings once it "paired" with that cars computer modules. Back in the day I installed an Chrysler RB1 nav (the original Chrysler nav system), that came out of a PT Cruiser. Upon initial installation it showed the Dodge logo until I started my Jeep in which after that everything showed up how it should.
We had that nav unit in a PT Cruiser. It was... less than awesome. Never sent us the wrong way, but the maps were way outdated and entering things via the spinny knob SUCKED.
__________________
Reply With Quote
  #21  
Old 03-22-2013, 07:03 PM
Member
 
Join Date: Mar 2013
Posts: 137
Thanks: 3
Thanked 5 Times in 3 Posts
Rep Power: 754
glock17 has a reputation beyond reputeglock17 has a reputation beyond reputeglock17 has a reputation beyond reputeglock17 has a reputation beyond repute
Re: 2014 issues

Tried - stated all is up to date - of course Uconnect isn't working
__________________
2014 Jeep Grand Cherokee Summit
Reply With Quote
  #22  
Old 03-22-2013, 07:05 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,155
Thanks: 317
Thanked 345 Times in 301 Posts
Rep Power: 1801638
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 issues

Tried it ... got invalid vin.
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #23  
Old 03-22-2013, 07:55 PM
kevkaz's Avatar
Member
 
Join Date: Dec 2012
Posts: 40
Thanks: 1
Thanked 8 Times in 2 Posts
Rep Power: 717
kevkaz has a reputation beyond reputekevkaz has a reputation beyond reputekevkaz has a reputation beyond repute
Re: 2014 issues

Also got invalid VIN. Took delivery yesterday and had uconnect working very quickly. My only complaint is there is a 2 minute lag to send commands from your phone, as others have reported. But it does work.
__________________
2014 Jeep GC Overland Hemi
2009 BMW ///M3 - Garage Queen
1997 BMW ///M3 - Track Rat
Reply With Quote
  #24  
Old 03-22-2013, 09:39 PM
Member
 
Join Date: Jul 2012
Location: NJ
Posts: 63
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 850
emsrescue is on a distinguished road
I did the heat cold button I do not recommend it. You then have to call XM to get it loaded again and uconnect to reset your system.
The jeeps update automatically if you turn the key off and hold the door open 30 seconds get in turn the key on.
BUT the real updates you have to get from your computer. Supposedly you download the update on a USB flash drive and then plug it into the USB port. Now I was told this but I have not tried it until the updates come in on Monday for all of us.
I really think the 2014 came out prematurely so this is catch up.
Also on the sd card if it has a file that is not an mp3 it will freeze your radio and you might get the BSOD. Reformat the card with only mp3. This is going to be fixed on the Monday update (I was told)
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Grand Cherokee Summit issues! Rockford Trouble Shooting/Problems/Service 130 03-04-2014 11:31 AM
poll: 20" Wheels on 2014 Overland vs. 2014 Summit jgc4ever Grand Cherokee - WK2 - 14 08-18-2013 12:17 AM
Paint issues and windscreen issues mm1964 Export Grand Cherokee 2011+ 41 03-28-2013 09:26 PM
2014 Cherokee issues emsrescue Trouble Shooting/Problems/Service 6 03-26-2013 06:53 PM
2014 Jeep Grand Cherokee and 2014 MB E-class Comparison Dan JGC Grand Cherokee - WK2 - 7 01-15-2013 10:39 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community