Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #109  
Old 09-11-2013, 12:50 PM
amc2002's Avatar
Member
My Jeep: 2002 4.0L TJ
 
Join Date: Apr 2013
Location: Long Island, NY
Posts: 519
Thanks: 0
Thanked 12 Times in 12 Posts
Rep Power: 236988
amc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by TurboRush View Post
Interesting that Ram is all the way up at 9...
I thought that was interesting as well.

Also note that there are variations in reliability for particular models. Some models did well even when the parent company was rated poorly overall.

For instance, even thought Hyundai didn't fare well, the Sonata was the highest-ranked mid-size car and the Accent is one of the higher ranked sub-compacts.

Likewise, Volvo did poorly overall, but the C70 is one of the top three cars in the "Compact Premium Sporty Car" segment, and the S80 is the second-ranked car in the "Midsize Premium Car" segment.

So for Volvo and Hyundai to not do well despite appearing in the "top three" of a couple segments, that must mean the rest of their cars are complete rubbish, or a few models are REALLY dragging down the numbers overall.
__________________

__________________
Reply With Quote
  #110  
Old 09-11-2013, 02:40 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 858 Times in 469 Posts
Rep Power: 1927053
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Ram was a fresh start and more in line with current experiences.

AMC, you know what I am like, I will help anyone. I also have no reason to even defend Jeep, but someone jumping on a Jeep Forum to say it is the worst globally is asking for it from someone.... I would have continued the discussion but it like running into a Rolling Stones concert and picking fights with the crowd.

Anyway, just a stupid exchange!

Quote:
Originally Posted by amc2002 View Post
I thought that was interesting as well.

Also note that there are variations in reliability for particular models. Some models did well even when the parent company was rated poorly overall.

For instance, even thought Hyundai didn't fare well, the Sonata was the highest-ranked mid-size car and the Accent is one of the higher ranked sub-compacts.

Likewise, Volvo did poorly overall, but the C70 is one of the top three cars in the "Compact Premium Sporty Car" segment, and the S80 is the second-ranked car in the "Midsize Premium Car" segment.

So for Volvo and Hyundai to not do well despite appearing in the "top three" of a couple segments, that must mean the rest of their cars are complete rubbish, or a few models are REALLY dragging down the numbers overall.
__________________

__________________
Reply With Quote
  #111  
Old 09-11-2013, 03:16 PM
amc2002's Avatar
Member
My Jeep: 2002 4.0L TJ
 
Join Date: Apr 2013
Location: Long Island, NY
Posts: 519
Thanks: 0
Thanked 12 Times in 12 Posts
Rep Power: 236988
amc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by Willx View Post
AMC, you know what I am like, I will help anyone. I also have no reason to even defend Jeep, but someone jumping on a Jeep Forum to say it is the worst globally is asking for it from someone.... I would have continued the discussion but it like running into a Rolling Stones concert and picking fights with the crowd.
Yeup. I hear you. All I can say is that car frustration can do that to a person as you've seen, and I'm probably more willing to give the benefit of the doubt (given what I've been through) that it was just hyperbole. Still, no need for direct lies if that is indeed what he was doing, and yeah, he isn't gonna garner much sympathy/help like that.

To his credit, he didn't really criticize Jeep or its parent. He was talking about some company by the name of Chrystler, which doesn't appear on the JD Power list at all for some reason.
__________________
Reply With Quote
  #112  
Old 09-11-2013, 03:43 PM
Member
 
Join Date: Aug 2013
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 422
arh8338 is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by mehow View Post
I have the 2014 overland and the dealer told me it is the abs module and I will be picking up my car later today
Exact same thing they told me, only they had to order the new ABS module and it could take weeks to get in. This was after I sat there for 4 hours while they replaced my radio. I think I am going to look for another service center after the ABS module is replaced...they seem to take longer for service than most owner's experiences on here.
__________________
'14 Overland v6, Max Steel, ATG Package
Reply With Quote
  #113  
Old 09-11-2013, 05:18 PM
Member
 
Join Date: Jul 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 457
Krikaleak is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

So this just happend to me as well. is there anyway to temporarily fix it until I get over to a dealer? Or should i just drive it as is
__________________
Reply With Quote
  #114  
Old 09-11-2013, 05:22 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 858 Times in 469 Posts
Rep Power: 1927053
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by Krikaleak View Post
So this just happend to me as well. is there anyway to temporarily fix it until I get over to a dealer? Or should i just drive it as is
You can turn it off for an hour and when you restart it very likely will just have a MIL (Malfunction Indicator Lamp) on.
__________________
Reply With Quote
  #115  
Old 09-11-2013, 05:23 PM
Member
 
Join Date: Aug 2013
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 422
arh8338 is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by Krikaleak View Post
So this just happend to me as well. is there anyway to temporarily fix it until I get over to a dealer? Or should i just drive it as is
Unless the check engine light is flashing, you should ok to drive it. Also, powering down the vehicle and restarting it seems to clear the warnings.
__________________
'14 Overland v6, Max Steel, ATG Package
Reply With Quote
  #116  
Old 09-11-2013, 05:27 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,149
Thanks: 316
Thanked 343 Times in 299 Posts
Rep Power: 1801631
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by arh8338 View Post
Unless the check engine light is flashing, you should ok to drive it. Also, powering down the vehicle and restarting it seems to clear the warnings.
For some reason it helps to open and close the driver's door in between starts.


---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #117  
Old 09-11-2013, 05:30 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 858 Times in 469 Posts
Rep Power: 1927053
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by bill_de View Post
For some reason it helps to open and close the driver's door in between starts.


---
Yes, that requests a shut down.... Usually it will completely shut down after 20 minutes, but I say an hour for all modules to go back to sleep.
__________________
Reply With Quote
  #118  
Old 09-11-2013, 07:01 PM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 816
Thanks: 0
Thanked 31 Times in 24 Posts
Rep Power: 73077
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

I think this thread should be stickied.

Anyway Recent Build Limited (Late July, has 13.28 UConnect), 1500 miles just lit up like xmas tree

However, it really feels like Torque App with ODBLink MX Adapter triggered it.

Car was fine.

Plugged it in last night first time.

As soon as I had it in ACC position I got a Service Shifter Message.

I just ignored it.

App seemed to run fine.

I did scan for codes and none.

I wanted to customize it this evening.

I was playing with it, in ACC mode (which seams like it won't work in).

Again the Service Shifter Message came up.

Then I started it, to check my new layout and I got the xmas tree.

I did a scan and saved the log. See bottom of this post.

I tried to Clear the Codes with Torque.

First attempt didn't do anything.

Then it mentioned shutting engine off and doing in ACC mode. But that does not communicate, but I did it anyway. It also suggested immediately shutting off after Clear Codes.

Most of the codes were now gone now. 4 left.

Tried a couple times. 4 left MIL still on.

Then I tried the ODBLink app that came with adapter. It works MUCH better for diagnostics and gave descriptions of all the codes. Lots of communication errors.

It could not clear all codes either, and warned damage could be done clearing codes while running. But it does not run when engine not running.

Googled a bit and some folks said wait 1 hr, others said opening closing door effects things regarding clear codes.

It's been like 30 minutes, went out to drive car around to see if Gauges were working.

MIL is OUT !!! All seems normal.

Kind of a afraid to hook ODBLink up again to scan again. I probably will, I can never leave well enough alone.



#Fault log file generated by Torque for Android
#Wed Sep 11 18:46:34 EDT 2013
faultCode7=U0405
faultCode8=U0416
faultCode9=U0155
faultCode3=U1411
faultCode4=U110F
faultCode5=P03C4
faultCode6=P02D4
calId=68172003AH\nH
faultCode0=U0402
faultCode1=U0100
faultCode2=U0001
logType3=2
logType2=1
logType5=2
logType4=2
manufacturer=Chrysler
logType1=1
vin=1C4xxx
logType0=1
logType7=5
logType6=2
logType9=5
logType8=5
__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #119  
Old 09-11-2013, 07:08 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 858 Times in 469 Posts
Rep Power: 1927053
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

ummm, did they say that it works with the 2014 with the new transmissions???
__________________
Reply With Quote
  #120  
Old 09-11-2013, 08:46 PM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 816
Thanks: 0
Thanked 31 Times in 24 Posts
Rep Power: 73077
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by Willx View Post
ummm, did they say that it works with the 2014 with the new transmissions???
You talking to me?

I didn't ask. But you are right there are differences in 2014.

Jeep 2014 is still OBD-II Compliant.

I did check reviews on the OBDLink and others were using it on a 2014 Jeep GC successfully before I bought it, because I was concerned about that. It was also the highest recommended by the Torque.

I poked with it some more.

I'm pretty sure the OBDLink instigated it.

I'm an idiot, partly. I'm still not used to this KeyLess Ignition.

It needs to be in RUN with Engine Off. Not ACC with Engine Off to Clear Codes

I had it in ACC position. When it's trying different protocols, when it gets to one Protocol, the Dash immediately throws a Service Shifter Error, every time. It's not happy and it was shortly after that I started engine and it xmas treed. I suspect it was still recovering from the "What the hell was that" when I started it. I bet if I waited after Service Shifter error and shut ODBLink off it would have never xmas treed.

I narrowed down which Protocol it likes to connect on and locked it, into that. Then I Cleared Codes in the ON Position, Not Running and they all immediately cleared !!! Whohoo.

I still suspect something is vulnerable on the Buss. Weeks ago I had the false Service Throttle Error (immediately after connecting trailer).

Now when this ODBlink tries Protocols, only in ACC position, it throws a false Service Shifter error , which one time lead to xmas tree and 9 Error codes. I suspect though that when it's in Run position, it connects before it gets to the protocol it chokes on.

Now with it locked on the correct protocol, it quietly fails in ACC, and connects nice and snappy in Run - EngineOff or Run - EngineOn. And the Clear codes worked perfectly with Run - EngineOff.

I'm curious if the ABS Module is the culprit on the Buss and why they typically replace it. Hard to say if this episode is at all related to the "Normal" xmas tree.

Or could be when anything goes wrong on the buss, the symptom is a "xmas tree". It's like way back in the day on windows. the infamous "My Mouse Froze". Well it could freeze for 100 reasons, all nothing to do with the mouse. But the end user symptom is the same. I bet there is a bunch of watchdogs monitoring stuff and if the Buss goes down, all those sensors fail to be read and everyone throws an error. None are a positive error. They are all, I couldn't talk to X, I couldn't talk to Y and they assume failure when they can't read them.

By the way the protocol it likes is ISO 15765-4 CAN (11 bit ID, 500Kbaud)
__________________

__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replaced my 2014 Overland Dash Speaker Andoskyy Audio/Visual/Navigation 209 09-12-2014 02:19 PM
2014 overland in a tree! demontweak Grand Cherokee - WK2 - 36 07-20-2013 07:02 PM
How to tie down a Christmas tree? Echo22 Tech Tips/DIY/How To 40 12-12-2011 02:45 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:06 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community