Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 06-21-2013, 01:18 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2011
Posts: 160
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1712
jerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

I just checked my fuse box on the '14 Limited with the 8.4AN and every one of the larger green, purple, and beige 30 and 40 amp fuses seated with a noticeable "click" when I pushed down with my finger. The ground straps and battery cables appeared to be tight.

I was checking because the wife told me her seat setting had disappeared yesterday. When I checked, both seat settings had disappeared. I thought it might have just lost the setting to pair with the FOB but that was not the case. The settings were not working even when pushing the buttons on the door. We both reset and saved the settings and they seem to be working again, even with the FOBs.
__________________

__________________
2011 Grand Cherokee Laredo X 4x4 V6
2014 Grand Cherokee Limited 4x2 V6
Reply With Quote
  #26  
Old 06-21-2013, 02:40 PM
New Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
bobs4state is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by bobs4state View Post
I am in Cary, NC, and would like to hear if anyone has taken their Jeep to Autopark Jeep in Cary for this issue. I'm a newby here and found the forum when I searched to see if anyone else had seen this. I put my two-month-old Summit in the shop yesterday with this issue. I sent a link to this thread to my service advisor. I'll post my progress later today.

Got the Jeep back. They fixed it in less than 1/2 hour. Did a flash update to the PCM. He said that the Jeep had a long list of codes related to this failure, and that the new flash update is brand new. We'll see if it lasts.

On another note, the throttle tip-in is a little quicker now. They must have adjusted that too.
__________________

__________________
Reply With Quote
  #27  
Old 06-23-2013, 12:21 PM
New Member
 
Join Date: Jun 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
stewie is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

All,

I was considering purchasing a 2014 Jeep. After seeing these posts, I have to admit I am concerned. How would you guys gauge this issue? In other words, are you confident Chrysler will figure out what is wrong, has figured what is wrong? Before I buy should I have the dealership check anything? Please help, love the 2014, but....
__________________
Reply With Quote
  #28  
Old 06-23-2013, 06:49 PM
New Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
bobs4state is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

It's all fixed. Go for it!
__________________
Reply With Quote
  #29  
Old 06-23-2013, 09:29 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Ohio
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 467
B6770S is on a distinguished road
Nominate Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

At 744 miles we had a "Christmas Tree Event" which also included no speed odometer or odometer as well as a Uconnect error message that said "cannot be accesses while moving" while we were sitting still. Dealer replaced ABS Module.

Now at 2500 miles, aside from one time condensation in headlights, not another problem.

***We love our '14 in soooooo many ways and highly recommend it!***

One note: There is a Chrysler Bulletin saying that both Chrysler and Apple are aware that the IPhone4 is not compatible with Uconnect. It says both are working on the issue with resolution TBD.
__________________
2014 GC LIMITED; 3.6-Liter V6; Brilliant Black; Summit Chrome Grill & Rocker Panels; New Zealand Black & Light Frost Int; GC Door Sills; Jeep Illuminated Door Sills; Lux Pkg II; 20" Wheels. 1999 GC LAREDO; 6 Cyl; Original Owner; 202,000+ miles; looks great-runs great.
Reply With Quote
  #30  
Old 06-23-2013, 09:34 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Ohio
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 467
B6770S is on a distinguished road
Nominate Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

At 744 miles we had a "Christmas Tree Event" which also included no speedometer or odometer as well as a Uconnect error message that said "cannot be accesses while moving" while we were sitting still. Dealer replaced ABS Module.

Now at 2500 miles, aside from one time condensation in headlights, not another problem.

***We love our '14 in soooooo many ways and highly recommend it!***

One note: There is a Chrysler Bulletin saying that both Chrysler and Apple are aware that the IPhone4 is not compatible with Uconnect. It says both are working on the issue with resolution TBD.

P
__________________
2014 GC LIMITED; 3.6-Liter V6; Brilliant Black; Summit Chrome Grill & Rocker Panels; New Zealand Black & Light Frost Int; GC Door Sills; Jeep Illuminated Door Sills; Lux Pkg II; 20" Wheels. 1999 GC LAREDO; 6 Cyl; Original Owner; 202,000+ miles; looks great-runs great.
Reply With Quote
  #31  
Old 06-29-2013, 06:09 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: New Jersey
Posts: 37
Thanks: 0
Thanked 5 Times in 3 Posts
Rep Power: 463
Nomorecars is on a distinguished road
Check the posts in the Troubleshooting threads, under 2014 GC Limited Electronics Problems. (I have an Overland.) A faulty ABS module is being reported as the cause of the Christmas lights problem for many people, including me. Glad to hear that after replacement, the problem seems to be solved for you. I hope to have the same luck once they are able to get the part and fix my car.
__________________
Current: 2014 Jeep Grand Cherokee Overland V6 4x4, Max Steel - Indigo Blue/Brown interior, Advanced Tech Package
Traded: 2003 Murano SL ~98,000 miles
Other current rides: 2008 BMW 335xi Coupe
1998 BMW 528i
Reply With Quote
  #32  
Old 07-13-2013, 09:50 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2012
Location: Colorado
Posts: 98
Thanks: 0
Thanked 8 Times in 3 Posts
Rep Power: 786
abarbs30 has a reputation beyond reputeabarbs30 has a reputation beyond reputeabarbs30 has a reputation beyond reputeabarbs30 has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

1,000 miles later and its back. Will talk to the dealer about ABS and PCM. When I took it in before they said that the fuses weren't seated properly. I think that was just a fairy tale excuses..
__________________
Reply With Quote
  #33  
Old 07-14-2013, 01:14 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,497
Thanks: 0
Thanked 20 Times in 17 Posts
Rep Power: 80063
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Have the dealer tell you what trouble codes are reported and post please. Suspect high or low voltage reported. ABS module seems to provide a ground path for spikes. Wish a wiring diagram was available to owners.
__________________
Web home. Notary Sojac Y'all
One of these is a diesel:
Reply With Quote
  #34  
Old 07-16-2013, 09:44 AM
Premium Member
 
Join Date: Jun 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jeffreyloy is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Happened here too. At dealership now. Glad you guys posted I was able to get the Jeed right in. They seem to be working in the battery area.

2014 Overland 5.7 hemi, Advanced tech Group
__________________
Reply With Quote
  #35  
Old 07-16-2013, 11:26 PM
Premium Member
 
Join Date: Jun 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jeffreyloy is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Another One, Right after a car wash. Dealer tightened pin connectors etc. So far so Good

Overland 2014, 5.7 Hemi, Advanced Technology Group
__________________
Reply With Quote
  #36  
Old 07-17-2013, 09:51 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: New Jersey
Posts: 37
Thanks: 0
Thanked 5 Times in 3 Posts
Rep Power: 463
Nomorecars is on a distinguished road
Update to my Christmas Tree lights issue: My car was in the dealer's service garage from June 19 until yesterday, July 16 waiting for a replacement ABS module. .I left work early to pick it up, drove out of the dealer's lot and within a minute got a warning on the dash that "Park Sense is Off." I checked the button on the center console and the Uconnect settings and it was not off. The warning (notice on dash and warning sound) kept coming up every time I had to brake. Turned around, brought it back to the dealer and they said it probably just needs to be re-flashed.

Twenty minutes later, drove out of the dealer's lot and within a minute, it happened again. Turned around, drove back and this time on the drive back, I got the Christmas Tree lights again. I left the car running when I got to the service center to show the service manager and he immediately got me back in my loaner. So now I am driving around in a rented 2011 RWD GC Laredo instead of my brand new 2014 JGC Overland. I did not even have 500 miles on my new car.

I have been working with Chrysler Enhanced Customer Satisfaction group and now, after sending a note to the Global Head of Quality with a copy to Mr. Marcchionne, I am working with a Customer Satisfaction rep in the Executive Referral group. I am discussing the possibility of a replacement vehicle without having to go through the Lemon Law process in my State. In the meantime, the service manager spoke with me today and said he believes they found the problem and have corrected it. Apparently, and I am not a technical person so I may get some of the terms wrong here, there was a metal object in the wheel where they drill the holes for the hub. This was near the speed sensor and because it (or the sensor) was magnetic, it was screwing up the sensors and sending codes to the system. He said that these drill holes are usually blown out with air at the assembly plant to remove any metal filings but this appears not to have been done. He also said that Chrysler asked him to send the object to them for analysis.

The dealer will hold the car until Friday to test it a few more times before saying definitively that it is fixed. I am also still speaking with Chrysler about the replacement but I don't know if they will now tell me I have to take back this car if it is declared fixed. (I will try to post somewhere else my -mainly positive- comments about dealing with Chrysler customer service.) So Chrysler has had my money and my trade-in vehicle since May 30, and my new car since June 19, and I have nothing. Not the best experience so far.
__________________

__________________
Current: 2014 Jeep Grand Cherokee Overland V6 4x4, Max Steel - Indigo Blue/Brown interior, Advanced Tech Package
Traded: 2003 Murano SL ~98,000 miles
Other current rides: 2008 BMW 335xi Coupe
1998 BMW 528i
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replaced my 2014 Overland Dash Speaker Andoskyy Audio/Visual/Navigation 207 04-13-2014 04:24 PM
2014 overland in a tree! demontweak Grand Cherokee - WK2 - 36 07-20-2013 07:02 PM
How to tie down a Christmas tree? Echo22 Tech Tips/DIY/How To 40 12-12-2011 02:45 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community