Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #49  
Old 07-28-2013, 01:35 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,007
Thanks: 307
Thanked 317 Times in 279 Posts
Rep Power: 1801463
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by Tamilliken View Post
Help - I just dropped my 2014 JGC off at the dealer yesterday. Same issue on Friday -- every idiot light on that was imaginable. Started it up Saturday only the Malfunction light stayed on. Dealer said ABS communication problem, but needed more diagnostic tests. Not encouraged by reading everyone's problems. Dealer to call Monday afternoon with news. So instead of my GC I have a Chrysler 200 --big difference. Any encouraging news would be appreciated.
First of all, relax. It is common, cars keep running, and they have a pretty good handle on it. The MIL would have gone off after a few more starts, but codes are preserved.

While they were changing abs modules, pcm's, etc., I think the narrowed it down to a bad connector.

Whatever it turns out to be, Jeep is well aware of this, as obviously is your dealer.

---
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #50  
Old 07-28-2013, 03:32 PM
Member
My Jeep: 2014
 
Join Date: Jul 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 404
Tamilliken is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by bill_de View Post
First of all, relax. It is common, cars keep running, and they have a pretty good handle on it. The MIL would have gone off after a few more starts, but codes are preserved.

While they were changing abs modules, pcm's, etc., I think the narrowed it down to a bad connector.

Whatever it turns out to be, Jeep is well aware of this, as obviously is your dealer.

---
Thank you -- do you know an ETA on getting the car back? Call me spoiled, but really like my Jeep -- traded in a 2011 JGC and just loved it. Hoping I can love this one too.
__________________

__________________
Reply With Quote
  #51  
Old 07-28-2013, 04:33 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,007
Thanks: 307
Thanked 317 Times in 279 Posts
Rep Power: 1801463
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by Tamilliken View Post
Thank you -- do you know an ETA on getting the car back? Call me spoiled, but really like my Jeep -- traded in a 2011 JGC and just loved it. Hoping I can love this one too.
I can't say. I kept driving mine and just made an appointment to go back. I waited for the car while I read a book and drank their coffee, maybe two hours.



---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #52  
Old 07-28-2013, 06:24 PM
Member
My Jeep: 2014
 
Join Date: Jul 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 404
Tamilliken is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Thanks -- will let you know what I hear back tomorrow afternoon. Hopefully a quick fix.
__________________
Reply With Quote
  #53  
Old 07-29-2013, 05:51 AM
jer630's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: Greer, SC
Posts: 34
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 677
jer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Add us to the list of Jeep's getting the "Christmas tree" effect. Happened last night. Now, everything seems normal except the check engine light. Going to take it to dealer today. We've had multiple electronic issues of varying degrees before this big one. 5000+ miles on ours.
__________________
Reply With Quote
  #54  
Old 07-29-2013, 01:15 PM
Member
My Jeep: 2014
 
Join Date: Jul 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 404
Tamilliken is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Update -- spoke to the Dealership -- said it is ONLY the ABS module. Should have one in by Wednesday, will install it and have the car back that afternoon. Keeping my fingers and toes crossed. The service technician said NOTHING else wrong. Hmmm. Hopefully he is correct.
__________________
Reply With Quote
  #55  
Old 07-29-2013, 01:18 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Connecticut
Posts: 269
Thanks: 7
Thanked 11 Times in 11 Posts
Rep Power: 837
marosenb has a reputation beyond reputemarosenb has a reputation beyond reputemarosenb has a reputation beyond reputemarosenb has a reputation beyond reputemarosenb has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by Tamilliken View Post
Update -- spoke to the Dealership -- said it is ONLY the ABS module. Should have one in by Wednesday, will install it and have the car back that afternoon. Keeping my fingers and toes crossed. The service technician said NOTHING else wrong. Hmmm. Hopefully he is correct.
Good luck, I hope this resolves it for you! I know how frustrating this stuff can be...
__________________
[SIGPIC][/SIGPIC]

http://youtu.be/H7CbNn0cnUQ:slapfight:
Reply With Quote
  #56  
Old 07-31-2013, 02:05 PM
Member
My Jeep: 2014
 
Join Date: Jul 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 404
Tamilliken is on a distinguished road
Update. Dealer received ABS module, installed it, still error codes. Sending for another ABS module, hope to have it and have it installed on Friday. Starting to get concerned that it is something else. Also, the service technician was surprised about hearing of many of the 2014 JGC having this problem. Apparently, HQ didn't tell anyone what was going on. Not that it matters sent an email to HQ telling them they were remiss in their responsibilities by not informing dealers and/or customers. Guess no one monitors service requests or forums, like this one, for emerging problems. This tells me Chrysler doesn't have a fix.
__________________
Reply With Quote
  #57  
Old 07-31-2013, 11:01 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: New Jersey
Posts: 37
Thanks: 0
Thanked 5 Times in 3 Posts
Rep Power: 488
Nomorecars is on a distinguished road
I noted this in an earlier post, but I also had the dash light up after they put in a new ABS module. My dealer took off one of the tires and found some metal filings that were left after Chrysler drilled the hub holes in the wheel. The filings had attached themselves to the speed sensor which, apparently, is magnetic. No problems after the filings were discovered and removed. (I am still waiting to get my replacement vehicle, but until then have the original vehicle and have not experienced the same problem.)

Maybe you should ask your dealer to remove the tires and check around any sensors that are in the wheel area.
__________________
Current: 2014 Jeep Grand Cherokee Overland V6 4x4, Max Steel - Indigo Blue/Brown interior, Advanced Tech Package
Traded: 2003 Murano SL ~98,000 miles
Other current rides: 2008 BMW 335xi Coupe
1998 BMW 528i
Reply With Quote
  #58  
Old 08-01-2013, 04:16 AM
Member
My Jeep: 2014
 
Join Date: Jul 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 404
Tamilliken is on a distinguished road
Quote:
Originally Posted by Nomorecars View Post
I noted this in an earlier post, but I also had the dash light up after they put in a new ABS module. My dealer took off one of the tires and found some metal filings that were left after Chrysler drilled the hub holes in the wheel. The filings had attached themselves to the speed sensor which, apparently, is magnetic. No problems after the filings were discovered and removed. (I am still waiting to get my replacement vehicle, but until then have the original vehicle and have not experienced the same problem.)

Maybe you should ask your dealer to remove the tires and check around any sensors that are in the wheel area.
Thank you for the information. If you don't mind me asking, why are you waiting for a replacement vehicle if the original is fixed?
__________________
Reply With Quote
  #59  
Old 08-01-2013, 05:37 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: New Jersey
Posts: 37
Thanks: 0
Thanked 5 Times in 3 Posts
Rep Power: 488
Nomorecars is on a distinguished road
Quote:
Originally Posted by Tamilliken View Post

Thank you for the information. If you don't mind me asking, why are you waiting for a replacement vehicle if the original is fixed?
I had problems with that vehicle from day one. It was purchased in May buy built in late March. On this forum, I read about other issues people had with early-build MY2014 JGC. The car was in the shop for approximately 30 days. I was very concerned, and expressed my concerns to Chrysler, that I had purchased a lemon. I qualified for my State's lemon law process but Chrysler agreed to replace the vehicle without my having to submit a claim. (Actually, I expected more of a fight but Chrysler did the right thing, in my opinion.)

Basically, it became a trust issue: I did not trust the quality of the vehicle I originally purchased but did like (very much) the JGC and was willing to give a new vehicle a chance. (Not just my trust in the car, but my wife and kids also did not trust it.) Besides, no problems with the original vehicle in the week I have had it back does not mean something won't pop up again soon. Getting a replacement, while not quite validating my decision to purchase the Jeep, did make my wife happier. If there are any problems with the new one, though, I am sure the "I told you so" will still come out.
__________________
Current: 2014 Jeep Grand Cherokee Overland V6 4x4, Max Steel - Indigo Blue/Brown interior, Advanced Tech Package
Traded: 2003 Murano SL ~98,000 miles
Other current rides: 2008 BMW 335xi Coupe
1998 BMW 528i
Reply With Quote
  #60  
Old 08-01-2013, 08:53 AM
Member
My Jeep: 2014
 
Join Date: Jul 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 404
Tamilliken is on a distinguished road
Quote:
Originally Posted by Nomorecars View Post

I had problems with that vehicle from day one. It was purchased in May buy built in late March. On this forum, I read about other issues people had with early-build MY2014 JGC. The car was in the shop for approximately 30 days. I was very concerned, and expressed my concerns to Chrysler, that I had purchased a lemon. I qualified for my State's lemon law process but Chrysler agreed to replace the vehicle without my having to submit a claim. (Actually, I expected more of a fight but Chrysler did the right thing, in my opinion.)

Basically, it became a trust issue: I did not trust the quality of the vehicle I originally purchased but did like (very much) the JGC and was willing to give a new vehicle a chance. (Not just my trust in the car, but my wife and kids also did not trust it.) Besides, no problems with the original vehicle in the week I have had it back does not mean something won't pop up again soon. Getting a replacement, while not quite validating my decision to purchase the Jeep, did make my wife happier. If there are any problems with the new one, though, I am sure the "I told you so" will still come out.
Thanks. I have emailed Chrysler HQ expressing my concerns. They are supposed to reply today, in the meantime I will wait and see what happens. I traded a 2011 JGC and loved it, hopefully this will turn out well. Will post when I hear back from either HQ or the dealership.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replaced my 2014 Overland Dash Speaker Andoskyy Audio/Visual/Navigation 207 04-13-2014 04:24 PM
2014 overland in a tree! demontweak Grand Cherokee - WK2 - 36 07-20-2013 07:02 PM
How to tie down a Christmas tree? Echo22 Tech Tips/DIY/How To 40 12-12-2011 02:45 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:06 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community