Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #61  
Old 08-02-2013, 01:34 AM
Member
 
Join Date: Jul 2013
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 554
jamesritchie is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Same thing happened to my wife the other day. TFT screen started acting all funny and then got a check engine light. It went away after a couple of starts and the uconnect settings reset...gonna set up an appointment to get it checked out.
__________________

__________________
Reply With Quote
  #62  
Old 08-02-2013, 05:31 AM
Member
My Jeep: 2014
 
Join Date: Jul 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 525
Tamilliken is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by jamesritchie View Post
Same thing happened to my wife the other day. TFT screen started acting all funny and then got a check engine light. It went away after a couple of starts and the uconnect settings reset...gonna set up an appointment to get it checked out.


My dealer called yesterday. Put in the second ABS module (first part was apparently defective). Car appears to be running properly. However, he is a bit paranoid and will run more diagnostics this morning and test drives to make sure it is working properly. I should be able to pick up my JGC around 11:00am this morning. Keeping my fingers crossed.
__________________

__________________
Reply With Quote
  #63  
Old 08-03-2013, 05:00 AM
iwantanotherjeep's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2012
Location: Sydney, Australia
Posts: 317
Thanks: 9
Thanked 4 Times in 3 Posts
Rep Power: 2224
iwantanotherjeep has a reputation beyond reputeiwantanotherjeep has a reputation beyond reputeiwantanotherjeep has a reputation beyond reputeiwantanotherjeep has a reputation beyond reputeiwantanotherjeep has a reputation beyond reputeiwantanotherjeep has a reputation beyond reputeiwantanotherjeep has a reputation beyond reputeiwantanotherjeep has a reputation beyond reputeiwantanotherjeep has a reputation beyond reputeiwantanotherjeep has a reputation beyond reputeiwantanotherjeep has a reputation beyond repute
Just to add to this thread, the following came from the Export thread, worth a mention

"When I test drove Laredo CRD on the road in July, suddenly the TFT went blank with all lights off, the sales consultant next to me said that turn the light switch from AUTO to OFF which brought the screen back. He said that it's caused by AUTO mode. I did not pay attention then. Now other owners report the similar problem, join the dots, definitely there's 'bug'."
__________________
I have another Jeep :thumbsup:
MY14 Bright White GC Overland 3.0L CRD with Rock Rails :cool:
Reply With Quote
  #64  
Old 08-06-2013, 02:10 PM
New Member
My Jeep: 2014 3.6L WK2
 
Join Date: Aug 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
billyscho is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Happend to me... purchased 2014 Overland 3.6L early July... at about 1000 miles all the indicators light up, the automatic suspension stopped working, speedometer could only read zero.

Took it in... they noted the codes we all stored, but could not find anything wrong. Reset everything and it was fine. Problem happened again, exactly the same. Took it in. Again, they couldn't find anything wrong. Said it was the first time they had heard of this problem. I showed them this thread, and they contacted Chrysler.

After much troubleshooting, they pulled out and replaced the ABS module. Not sure if there was a fault or if they were just trying something. Will see if it holds.
__________________
Reply With Quote
  #65  
Old 08-06-2013, 03:15 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,568
Thanks: 0
Thanked 24 Times in 21 Posts
Rep Power: 80280
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

a) what were the codes please ?
b) maybe after they replace a third ABS, they'l troubleshoot the problem and not the symptom.
Reply With Quote
  #66  
Old 08-06-2013, 04:08 PM
Member
My Jeep: 2014
 
Join Date: Jul 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 525
Tamilliken is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Quote:
Originally Posted by billyscho View Post
Happend to me... purchased 2014 Overland 3.6L early July... at about 1000 miles all the indicators light up, the automatic suspension stopped working, speedometer could only read zero.

Took it in... they noted the codes we all stored, but could not find anything wrong. Reset everything and it was fine. Problem happened again, exactly the same. Took it in. Again, they couldn't find anything wrong. Said it was the first time they had heard of this problem. I showed them this thread, and they contacted Chrysler.

After much troubleshooting, they pulled out and replaced the ABS module. Not sure if there was a fault or if they were just trying something. Will see if it holds.

So far the replacement of the ABS module is working in my Overland. Still sitting on pins and needles as it hasn't bee a week yet. I had about 3100 miles on mine when the idiot lights went off. Keep us informed. My dealer was not aware of the problem either. Apparently either Chrysler has no clue what is going on or doesn't want to admit it. I received a "canned" response back to my email to customer service.

"Thank you for contacting the Jeep Customer Assistance Center.

We are sorry to learn of the problems you have encountered with your vehicle and have documented your concerns.

We appreciate the time and effort you took to tell us of your dissatisfaction in our product. Comments like yours are one way to learn of problems that develop and the improvements desired. We have documented your comments and will provide them to our product development team for review.

Your feedback is very important to us.

We hope this experience will not cause customers to misjudge our products.

Thanks again for your email.

Sincerely,

Christopher

Customer Service Representative
Jeep Customer Assistance Center"
__________________
Reply With Quote
  #67  
Old 08-06-2013, 04:16 PM
PurdueMET's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Aug 2013
Location: Indiana
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 536
PurdueMET is on a distinguished road
Same thing happened to me yesterday. Only 4,800 miles on my 14 limited. Abs light, break assist light and air bag light came on. Pulled the engine code u1412. Took it to the dealer today and they are running more test. Said they are getting communication errors on the lighting circuit and were not sure why. Has any one had good results with dealers actually finding the issue?
__________________
Reply With Quote
  #68  
Old 08-06-2013, 04:49 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,391
Thanks: 341
Thanked 368 Times in 319 Posts
Rep Power: 1801968
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Mine threw many codes, but the dash lights all went out after a few restarts. Jeep decided that the only thing that could cause so many errors and still have the car run would be a bad PCM. They changed it about 2500 miles ago and so far so good.

It could happen again at any time because they did just guess and not diagnose. But, I continued to drive the car while waiting for the part and everything was working.

Someday they will find the glitch is some program that can trigger this at any time and realize there was nothing wrong with all the parts they changed.

If they can guess, so can I.


---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!
Reply With Quote
  #69  
Old 08-06-2013, 05:08 PM
Member
My Jeep: 2014
 
Join Date: Jul 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 525
Tamilliken is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

In my case all the error codes, yes there were multiple codes, indicated a communication error with the ABS module. Changed out last Friday, so far so good. Not sure Jeep has an answer as you can tell with this thread, it appears there ae multiple fixes.
__________________
Reply With Quote
  #70  
Old 08-06-2013, 06:48 PM
Member
 
Join Date: Jul 2013
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 554
jamesritchie is on a distinguished road
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Just to add to my earlier post, this happened to me a little after 1k miles. I really need to take this thing in for an oil change too so I might as well kill two birds with one stone.
__________________
Reply With Quote
  #71  
Old 08-07-2013, 11:01 AM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,568
Thanks: 0
Thanked 24 Times in 21 Posts
Rep Power: 80280
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: 2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working

Interesting, U1412 is not a lighting error code, it is a PCM error, implausible vehicle speed signal received and the signal comes from the ABS module. I'd be looking for a bad connection on the CAN bus particularly if it repeats after module replacement.

If I were allowed to buy a wiring diagram I might be able to suggest what connectors are involved.
Reply With Quote
  #72  
Old 08-07-2013, 07:04 PM
PurdueMET's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Aug 2013
Location: Indiana
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 536
PurdueMET is on a distinguished road
Quote:
Originally Posted by PurdueMET View Post
Same thing happened to me yesterday. Only 4,800 miles on my 14 limited. Abs light, break assist light and air bag light came on. Pulled the engine code u1412. Took it to the dealer today and they are running more test. Said they are getting communication errors on the lighting circuit and were not sure why. Has any one had good results with dealers actually finding the issue?
Got my GC back from dealer tonight. They said they checked all grounds and removed connections from headlight and front body harness, cleaned inspected and reseated. They said the test they ran led them to those 2 connectors. Not sure if this repair makes sense. They also scratched my bumper taking the headlight out.
This repair seems different then most on here. Let me know if this repair makes sense to anyone.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replaced my 2014 Overland Dash Speaker Andoskyy Audio/Visual/Navigation 246 10-19-2014 12:52 AM
2014 overland in a tree! demontweak Grand Cherokee - WK2 - 36 07-20-2013 07:02 PM
How to tie down a Christmas tree? Echo22 Tech Tips/DIY/How To 40 12-12-2011 02:45 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.