Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-06-2014, 03:15 PM
Member
 
Join Date: Aug 2013
Location: Austin, TX
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 324437
Wino has a reputation beyond reputeWino has a reputation beyond reputeWino has a reputation beyond reputeWino has a reputation beyond reputeWino has a reputation beyond reputeWino has a reputation beyond reputeWino has a reputation beyond reputeWino has a reputation beyond reputeWino has a reputation beyond reputeWino has a reputation beyond reputeWino has a reputation beyond repute
2014 JGC Uconnect 13.48.3 + iPhone 7.0.4 = no Bluetooth pairing

Just got my 2014 JGC back from dealer due to the N58 safety recall. They updated software for both transmission TCM and Uconnect up to 13.48.3.

I can no longer get EITHER my wife's iPhone 5 or my iPhone 5c to pair with Uconnect via Bluetooth. Both phones are up to date with iOS 7.0.4.

I put the Uconnect screen into phone mode, settings, add phone. Then I turn on my phone's bluetooth and select Uconnect under devices. Same thing every time:

On iPhone - "Pairing Uncuccessful" Make sure "Uconnect" is turned on, in range, and is ready to pair.

I've also tried turning the phone's bluetooth on and off during the pairing, and tried to do the pairing in reverse order (disable then enable iPhone bluetooth.... THEN put the Uconnect screen into pairing mode). No dice.

I called Uconnect service and, to put it mildly, they were less than helpful.

Anyone had this problem and found a solution? I'd rather not roll back my iPhone to an older (less secure) software version.
__________________

__________________
Reply With Quote
  #2  
Old 02-06-2014, 04:49 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2013
Posts: 49
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 409
lectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond repute
Re: 2014 JGC Uconnect 13.48.3 + iPhone 7.0.4 = no Bluetooth pairing

Quote:
Originally Posted by Wino View Post
Just got my 2014 JGC back from dealer due to the N58 safety recall. They updated software for both transmission TCM and Uconnect up to 13.48.3.

I can no longer get EITHER my wife's iPhone 5 or my iPhone 5c to pair with Uconnect via Bluetooth. Both phones are up to date with iOS 7.0.4.

I put the Uconnect screen into phone mode, settings, add phone. Then I turn on my phone's bluetooth and select Uconnect under devices. Same thing every time:

On iPhone - "Pairing Uncuccessful" Make sure "Uconnect" is turned on, in range, and is ready to pair.

I've also tried turning the phone's bluetooth on and off during the pairing, and tried to do the pairing in reverse order (disable then enable iPhone bluetooth.... THEN put the Uconnect screen into pairing mode). No dice.

I called Uconnect service and, to put it mildly, they were less than helpful.

Anyone had this problem and found a solution? I'd rather not roll back my iPhone to an older (less secure) software version.
I don't have an I-phone but I happen to be reading the manual today and remember it saying that the Apple needed to be paired with a USB cord. I don't know if that is to actually pair it or that it's the only way to use an I-phone in the car. The dealer told me that U-connect is made for Android. Don't know how true that is though.
__________________

__________________
Reply With Quote
  #3  
Old 02-07-2014, 02:30 PM
Premium Member
 
Join Date: Apr 2013
Posts: 174
Thanks: 0
Thanked 7 Times in 3 Posts
Rep Power: 2036
nikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond repute
Re: 2014 JGC Uconnect 13.48.3 + iPhone 7.0.4 = no Bluetooth pairing

Works fine on my iPhone with 7.0.4 bring it back to the dealer and make them figure it out since it worked before you brought it in.
__________________
14' Grand Cherokee Limited Hemi 4x2
http://s107.photobucket.com/user/nik...and%20Cherokee
Reply With Quote
  #4  
Old 02-07-2014, 11:17 PM
New Member
 
Join Date: Nov 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Otis10 is on a distinguished road
Same thing happened to me.. Bluetooth audio stopped working for me after the software update.. Another annoying glitch with this SUV.. My text messaging doesnt work either with the Uconnect. Dont they know most people have freaking IPhones!
__________________
Reply With Quote
  #5  
Old 02-08-2014, 09:25 AM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Orlando, FL
Posts: 73
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 555
siegs7 has a reputation beyond reputesiegs7 has a reputation beyond repute
I would try holding down power and home buttons to rest your iPhone. I had this happen once, but after I rest the iPhone, I didn't have that problem. It's worth a try, and easier/faster than reloading the Uconnect software.
__________________
Reply With Quote
Reply

Tags
2014, uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 UConnect phone pairing issues? Amylee Audio/Visual/Navigation 162 10-19-2013 02:17 PM
2012 bluetooth not pairing mlarco52 Grand Cherokee SRT - WK2 0 09-30-2013 10:46 AM
iphone pairing to grand cherokee jackballetto Troubleshooting/Problems Discussion 0 04-09-2013 06:28 PM
Uconnect 730N keeps losing the pairing to iPhone 5 SLGF Grand Cherokee - WK2 - 0 04-06-2013 12:47 PM
High Frequency Sound with iPhone/Uconnect bluetooth music playing bgmtnclmbr Trouble Shooting/Problems/Service 1 09-07-2011 10:08 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community