Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-21-2013, 09:08 AM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Posts: 76
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 485
flashbang is on a distinguished road
2014 Overland Quadra-lift not raising issue?

When driving from a park/exit mode the info center will say raising for miles even driving over 15mph. The only way to get it to NRH is to press park/exit button once then up one. This doesn't happen every time I leave and drive from park/exit, but more often than not. Any thoughts?
__________________

__________________
2014 Overland 3.6L Pentastar V6
Reply With Quote
  #2  
Old 09-21-2013, 09:16 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 5,874
Thanks: 297
Thanked 300 Times in 265 Posts
Rep Power: 1801299
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Overland Quadra-lift not raising issue?

Happened to me only once. I pressed the raise button and the vehicle went to OR 1, which tells me that in spite of what the display said, it had already achieved normal road height. I then pressed lower and all was well.


---
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #3  
Old 09-21-2013, 09:32 AM
Bborzell's Avatar
Premium Member
My Jeep: 2014 3.6L
 
Join Date: Aug 2013
Location: Colfax, CA
Posts: 184
Thanks: 17
Thanked 8 Times in 8 Posts
Rep Power: 515
Bborzell is on a distinguished road
Re: 2014 Overland Quadra-lift not raising issue?

Quote:
Originally Posted by bill_de View Post
Happened to me only once. I pressed the raise button and the vehicle went to OR 1, which tells me that in spite of what the display said, it had already achieved normal road height. I then pressed lower and all was well.


---
Same here. One time the readout said "Raising" and didn't stop flashing. I think it had reached normal height. Pulled over and shut done and everything went back to normal. Asked dealer to check it out during a flash update session and they found nothing to indicate that it had happened.

Hasn't recurred.
__________________
Reply With Quote
  #4  
Old 09-21-2013, 09:42 AM
Member
 
Join Date: Apr 2013
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 480
perruz is on a distinguished road
Re: 2014 Overland Quadra-lift not raising issue?

Same thing happens to me some times, I put it into sport mode and took it out and it went away.
__________________
Reply With Quote
  #5  
Old 09-21-2013, 09:46 AM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Posts: 76
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 485
flashbang is on a distinguished road
Re: 2014 Overland Quadra-lift not raising issue?

It actually does not raise to NRH. Indicator light on the buttons still flashing and the "raising" flashing on the info screen continue until I push the buttons.
__________________
2014 Overland 3.6L Pentastar V6
Reply With Quote
  #6  
Old 09-21-2013, 10:33 AM
cnynctry's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: PV Arizona
Posts: 79
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 1934
cnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond repute
Re: 2014 Overland Quadra-lift not raising issue?

Same type issue but going to the Park/Exit mode. Sometimes will flash and flash. It moved the correct height but not telling the computer it did. My bet is it got to NRH. Still annoying though.
__________________
2014 Grand Cherokee 5.7 Overland
2014 Wrangler Rubicon
2010 Challenger R/T Classic
Reply With Quote
  #7  
Old 09-21-2013, 11:12 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,046
Thanks: 206
Thanked 145 Times in 118 Posts
Rep Power: 89261
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: 2014 Overland Quadra-lift not raising issue?

Happens to me occasionally too. I've checked, and it does actually go to NRH, but it doesn't register, and keeps flashing. Almost any selection will stop the glitch.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #8  
Old 09-21-2013, 11:22 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 317
TBLWK2 is on a distinguished road
Re: 2014 Overland Quadra-lift not raising issue?

I have the same issue. I discovered that after backing out of the garage into the driveway (and in entry/exit mode) and then putting into park, pressing the up button and waiting for the raising process to complete, the message goes off and I can put it in drive and drive away. However, If I press the up button when in entry/exit mode and start driving away immediately, the message will keep flashing (raising) unless I take another action such as putting in sport mode, etc. as already mentioned. I've tried it several times and it works every time. Unfortunately, it adds another step.
__________________
Reply With Quote
  #9  
Old 09-21-2013, 11:40 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 5,874
Thanks: 297
Thanked 300 Times in 265 Posts
Rep Power: 1801299
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Overland Quadra-lift not raising issue?

Quote:
Originally Posted by TBLWK2 View Post
I have the same issue. I discovered that after backing out of the garage into the driveway (and in entry/exit mode) and then putting into park, pressing the up button and waiting for the raising process to complete, the message goes off and I can put it in drive and drive away. However, If I press the up button when in entry/exit mode and start driving away immediately, the message will keep flashing (raising) unless I take another action such as putting in sport mode, etc. as already mentioned. I've tried it several times and it works every time. Unfortunately, it adds another step.
Do you realize that you should be able to drive away without pressing any buttons?
Once you hit 15 mph, it should rise to normal height.


___
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #10  
Old 09-21-2013, 11:41 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,046
Thanks: 206
Thanked 145 Times in 118 Posts
Rep Power: 89261
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: 2014 Overland Quadra-lift not raising issue?

It's a glitch that I'm sure, after enough owner complaints, will get attention. It is annoying, but other problems people are having are certainly higher on the to do list.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #11  
Old 09-21-2013, 11:45 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 317
TBLWK2 is on a distinguished road
Re: 2014 Overland Quadra-lift not raising issue?

Yes, I realize I should be able to drive away and the message will stop flashing but unfortunately, it does not. As the first post stated, it continues to flash for miles and at speeds above 15mph. I just discovered a work around until my next dealer visit and will have it looked at then.
__________________
Reply With Quote
  #12  
Old 09-21-2013, 01:10 PM
Bborzell's Avatar
Premium Member
My Jeep: 2014 3.6L
 
Join Date: Aug 2013
Location: Colfax, CA
Posts: 184
Thanks: 17
Thanked 8 Times in 8 Posts
Rep Power: 515
Bborzell is on a distinguished road
Re: 2014 Overland Quadra-lift not raising issue?

Quote:
Originally Posted by TBLWK2 View Post
Yes, I realize I should be able to drive away and the message will stop flashing but unfortunately, it does not. As the first post stated, it continues to flash for miles and at speeds above 15mph. I just discovered a work around until my next dealer visit and will have it looked at then.
I wish you luck on your visit. It appears that this particular glitch leaves no evidence trail. My service tech couldn't find anything to indicate that it had occurred and it apparently had no intention to share our little secret with anyone else.

Then again, it has happened twice in 1,800 miles.
__________________

__________________
Reply With Quote
Reply

Tags
2014

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Quadra-Lift issue bill_de Trouble Shooting/Problems/Service 20 08-13-2013 06:34 PM
Still Concern on Quadra-Lift in 2014? mceb Grand Cherokee - WK2 - 4 03-19-2013 07:00 PM
Potential Quadra-lift Issue? Check yours out justin1569 Trouble Shooting/Problems/Service 7 04-07-2011 10:55 AM
first issue with my WK2 - quadra lift chibianh Trouble Shooting/Problems/Service 9 04-04-2011 05:10 PM
Snow Mode with Quadra Lift Issue Frank G Trouble Shooting/Problems/Service 19 01-12-2011 08:35 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community