Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-25-2013, 05:35 PM
Member
 
Join Date: Dec 2010
Posts: 448
Thanks: 12
Thanked 9 Times in 9 Posts
Rep Power: 3264
Keirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond repute
(2014 Overland) wipers, headlights, one side LEDS dont work

14 here with just over 1500 miles on it. The front wipers wont come on in any position, headlights wont come on at all, and drivers side LED DRL wont come on at all.

No CEL or anything and car seems to run fine. I cant really drive though since it's pouring here in NY all day today. Was all working just fine last night. I disconnected the battery to see if maybe a reset does the trick.
__________________

__________________
Had 09 HEMI Overland (totalled)
Ordered 2014 HEMI Overland max steel/black
Reply With Quote
  #2  
Old 05-25-2013, 06:17 PM
Member
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2013
Location: NY
Posts: 53
Thanks: 1
Thanked 3 Times in 2 Posts
Rep Power: 545
Mikessrt is on a distinguished road
Re: (2014 Overland) wipers, headlights, one side LEDS dont work

If your fuses are all seated properly, it may be a loose wire to the steering column control module.
__________________

__________________
Reply With Quote
  #3  
Old 05-25-2013, 09:06 PM
Member
 
Join Date: Dec 2010
Posts: 448
Thanks: 12
Thanked 9 Times in 9 Posts
Rep Power: 3264
Keirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond repute
Re: (2014 Overland) wipers, headlights, one side LEDS dont work

I dont think a loose wire in the steering column would make the headlights not work or one side LEDs on the headlight not work either though. Can it?
__________________
Had 09 HEMI Overland (totalled)
Ordered 2014 HEMI Overland max steel/black
Reply With Quote
  #4  
Old 05-26-2013, 12:18 PM
Member
 
Join Date: Dec 2010
Posts: 448
Thanks: 12
Thanked 9 Times in 9 Posts
Rep Power: 3264
Keirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond repute
Re: (2014 Overland) wipers, headlights, one side LEDS dont work

EVIC also says Front turn signal isn't working.

Looked to think if i can change it myself but damn, sure looks like it's not as easy as older cars were lol
__________________
Had 09 HEMI Overland (totalled)
Ordered 2014 HEMI Overland max steel/black
Reply With Quote
  #5  
Old 05-28-2013, 10:14 AM
scooterha's Avatar
Premium Member
My Jeep: 2012 3.6L WK2
 
Join Date: Sep 2011
Location: WV
Posts: 1,706
Thanks: 0
Thanked 38 Times in 30 Posts
Rep Power: 220112
scooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond repute
Re: (2014 Overland) wipers, headlights, one side LEDS dont work

I wouldnt even attempt trying to fix that myself.. I think a dealer visit is in your future.
__________________
Current Vehicle: 2015 Chrysler 200 S 2.4 Tigershark.
Granite Crystal Metallic. May not have the Jeep, but I'll still drop in and keep up with the news.
Reply With Quote
  #6  
Old 05-28-2013, 12:11 PM
Member
 
Join Date: Dec 2010
Posts: 448
Thanks: 12
Thanked 9 Times in 9 Posts
Rep Power: 3264
Keirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond repute
Re: (2014 Overland) wipers, headlights, one side LEDS dont work

yeah, car is in the dealer. Worst time for this to happen because they had cars waiting over the two days service was closed on Sunday and for Memorial day so mine hasn't even been looked at yet.
__________________
Had 09 HEMI Overland (totalled)
Ordered 2014 HEMI Overland max steel/black
Reply With Quote
  #7  
Old 05-29-2013, 04:03 PM
Member
 
Join Date: Dec 2010
Posts: 448
Thanks: 12
Thanked 9 Times in 9 Posts
Rep Power: 3264
Keirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond repute
Re: (2014 Overland) wipers, headlights, one side LEDS dont work

Update
Fixed. BCM (not sure if that's the tech or a part) says one connection loose. Reseccured and everything works again.
__________________

__________________
Had 09 HEMI Overland (totalled)
Ordered 2014 HEMI Overland max steel/black
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear fogs dont work, what to check? Chrali Troubleshooting/Problems 4 07-05-2013 04:50 PM
TPMS off JK Rubicon Wheels work sometimes and sometimes dont ccape0328 Suspension/Brakes/Wheels/Tires 11 10-26-2011 10:27 PM
radio and nav dont work when starting jeep jeepgrand04 Audio/Visual/Navigation 2 07-17-2011 12:58 PM
Headlights on with windshield wipers? mcluckie.ian Grand Cherokee - WK 3 05-22-2011 10:04 AM
New key fob starts engine but the buttons dont work msaenger Grand Cherokee - WK 6 05-02-2011 02:55 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community