Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 07-24-2013, 01:53 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 861 Times in 470 Posts
Rep Power: 1927156
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: 2014 Radio Needs Service Question

Quote:
Originally Posted by jacko15 View Post
I've got a question for those that have had a radio replaced, or know the drill. Is this a very intrusive surgery on the dash? What are the chances of damaging the dash or trim? I'm waiting now to see if an update being pushed from Uconnect will solve a registration problem with Uconnect, but since my build date is April 6th, I may be facing a radio replacement. Just curious, and know some of you may be able to answer these questions. By the way, my dealer's service department is very competent, but I don't know if they've replaced a RA4 radio yet.
Three quick notes,

If anyones service department gives them grief about getting a radio replacement, please PM me with the details of the conversation (why they told you they couldn't) and as I have discussed with others it is sometimes a matter of they just don't have the info we do and I can assist with that.

The Radio replacement is no better or worse than past years, they take off the trim plate and it is not a huge deal. If they are idiots (which Jacko it sounds like yours are ok) then they may do something stupid. I would suggest for anyone elses piece of mind, take dated pictures of your dash in case you do have an arguement.

Verify your dealer does know about the STAR Case on the radios. If they don't know why they are replacing the radio, they may put an older unit in and that is not what is supposed to happen but apparently has to one person.
__________________

__________________
Reply With Quote
The Following User Says Thank You to Willx For This Useful Post:
  #26  
Old 07-24-2013, 01:55 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 861 Times in 470 Posts
Rep Power: 1927156
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: 2014 Radio Needs Service Question

Quote:
Originally Posted by Specx View Post
Sucks I just got this on my radio again yesterday. It appeared the first month and hasn't been an issue after I reset the system, but now it appeared again and I'll have to go ahead and have the dealer replace the unit. Is Chrysler aware of what is causing this yet?
Yes, they know and have a Star Case they are following.
__________________

__________________
Reply With Quote
  #27  
Old 07-27-2013, 05:27 AM
Member
 
Join Date: Jul 2013
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 545
lml52169 is on a distinguished road
Re: 2014 Radio Needs Service Question

glad i found this. my new 2014 jeep GCL is at dealer now waiting for new radio. They disconnected it till it comes in and yesterday all the service lights came on. ABS, BRAKE, Check Engine, ETC. I had to drive it like that to dealer. They gave me a loaner. I sure hope after my new radio comes in these problems will be resolved. If anyone out there has had their radio replaced they should post if any problems. thanks.
__________________
Reply With Quote
  #28  
Old 07-27-2013, 06:02 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,401
Thanks: 341
Thanked 371 Times in 322 Posts
Rep Power: 1801987
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Radio Needs Service Question

Quote:
Originally Posted by lml52169 View Post
glad i found this. my new 2014 jeep GCL is at dealer now waiting for new radio. They disconnected it till it comes in and yesterday all the service lights came on. ABS, BRAKE, Check Engine, ETC. I had to drive it like that to dealer. They gave me a loaner. I sure hope after my new radio comes in these problems will be resolved. If anyone out there has had their radio replaced they should post if any problems. thanks.
That's not an uncommon problem. This is the first time I heard of the radio being the problem. If you had turned the car off for awhile it would have temporarily fixed itself. You might suggest to your service department that they check Star Cases, just in case.


---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!
Reply With Quote
  #29  
Old 07-27-2013, 06:17 AM
Member
 
Join Date: Jul 2013
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 545
lml52169 is on a distinguished road
Re: 2014 Radio Needs Service Question

I guess I forgot to mention the beginnng of the problem, Phone needs service, contact your dealer, Navigation says I am in San Antonio Texas when I live in NJ. Bought car to dealer and they tried to upgrade/reinstall, whatever and it failed. So they ordered me a new radio, disconnected the old one. I took the car home and nothing on the dash worked, air, infact the heat was on. then 2 days later still radio not in, I had all these lights come on in the dash, Brake, ABS, Check Engine. So when I took it back to dealer they said don't drive it,leave it here till new radio comes in.
__________________
Reply With Quote
  #30  
Old 07-27-2013, 06:38 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 861 Times in 470 Posts
Rep Power: 1927156
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by lml52169 View Post
I guess I forgot to mention the beginnng of the problem, Phone needs service, contact your dealer, Navigation says I am in San Antonio Texas when I live in NJ. Bought car to dealer and they tried to upgrade/reinstall, whatever and it failed. So they ordered me a new radio, disconnected the old one. I took the car home and nothing on the dash worked, air, infact the heat was on. then 2 days later still radio not in, I had all these lights come on in the dash, Brake, ABS, Check Engine. So when I took it back to dealer they said don't drive it,leave it here till new radio comes in.
The two problems are slightly different. They should never have disconnected the radio??? Even if the update failed they should have left the radio in place, unless you had something really weird happen that I have never heard of?

Hopefully they are on the right track now and dealing with it for you.
__________________
Reply With Quote
  #31  
Old 07-27-2013, 06:47 AM
Member
 
Join Date: Jul 2013
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 545
lml52169 is on a distinguished road
They disconnected the radio because it illuminated all night long and we thought it would drain the battery
__________________
Reply With Quote
  #32  
Old 07-27-2013, 06:50 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 861 Times in 470 Posts
Rep Power: 1927156
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by lml52169 View Post
They disconnected the radio because it illuminated all night long and we thought it would drain the battery
Hmmm... 13.19.0 was supposed to fix that.... Wonder if they tried to load the older version. Regardless, they took it off the road which was a good move. Keep us posted!
__________________
Reply With Quote
  #33  
Old 07-27-2013, 07:07 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,401
Thanks: 341
Thanked 371 Times in 322 Posts
Rep Power: 1801987
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Radio Needs Service Question

Quote:
Originally Posted by lml52169 View Post
They disconnected the radio because it illuminated all night long and we thought it would drain the battery
Anything else you'd like to add?

Hopefully this will be resolved in one visit and you'll be back to enjoying your Jeep!


---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!
Reply With Quote
  #34  
Old 07-27-2013, 10:51 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Utah
Posts: 70
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 673
Jimbo107 is on a distinguished road
Re: 2014 Radio Needs Service Question

Sounds like your issues are a little more involved that what I'm having. Other than the " phone needs service" message everything has been working fine. In fact I was not even going to have the radio replaced but I was advised to in order to avoid future problems.

I'm expecting a call today or Monday to schedule the replacement. If you get yours replaced post back how the install went. Good luck
__________________
Reply With Quote
  #35  
Old 07-29-2013, 06:38 PM
Member
 
Join Date: Jul 2013
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 545
lml52169 is on a distinguished road
Radio installed today. All good keeping fingers crossed it lasts forever
__________________
Reply With Quote
  #36  
Old 07-29-2013, 06:59 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 861 Times in 470 Posts
Rep Power: 1927156
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by lml52169 View Post
Radio installed today. All good keeping fingers crossed it lasts forever
What version from the factory? Possibly 13.19.5?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Service Interval Question akasjl Grand Cherokee - WK2 - 18 11-21-2012 07:10 AM
T-case Service Question lewi3069 Troubleshooting/Problems 15 09-29-2011 09:41 PM
Any Problems With An Aftermarket Radio & Dealer Service Updates? 1stJeepGC Audio/Visual/Navigation 5 07-21-2011 09:01 PM
Service Question nickyj Trouble Shooting/Problems/Service 2 04-15-2011 04:20 PM
Dealership Service Question Mookie10 Trouble Shooting/Problems/Service 5 01-09-2011 09:55 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.