Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #61  
Old 08-05-2013, 10:32 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Utah
Posts: 70
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 515
Jimbo107 is on a distinguished road
Re: 2014 Radio Needs Service Question

At the dealer now. I was told the whole unit is replaced ( LCD screen and all ). Told me it would be a 30 minute wait. We shall see
__________________

__________________
Reply With Quote
  #62  
Old 08-05-2013, 11:50 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Utah
Posts: 70
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 515
Jimbo107 is on a distinguished road
Re: 2014 Radio Needs Service Question

Well, doesn't look like the install is a big deal but..........I drove away and had to turn around and come back. Touch screen totally unresponsive, jumping from screen to screen, what a mess.

They just called me out to the car and look at the radio from the side.....big crack across the screen, damaged in shipping and they didn't know it and installed it anyway. Told me they had to order another and were going to leave me with the cracked radio.

I said wait a minute my old radio was working fine other than the phone needs service message can you put it back in for me ? So that's what they are doing. Wish I would have just left well enough alone.
__________________

__________________
Reply With Quote
  #63  
Old 08-05-2013, 12:04 PM
weck's Avatar
Member
 
Join Date: Nov 2012
Location: Wisco
Posts: 743
Thanks: 14
Thanked 24 Times in 24 Posts
Rep Power: 3595
weck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond repute
Re: 2014 Radio Needs Service Question

Quote:
Originally Posted by Jimbo107 View Post
Well, doesn't look like the install is a big deal but..........I drove away and had to turn around and come back. Touch screen totally unresponsive, jumping from screen to screen, what a mess.

They just called me out to the car and look at the radio from the side.....big crack across the screen, damaged in shipping and they didn't know it and installed it anyway. Told me they had to order another and were going to leave me with the cracked radio.

I said wait a minute my old radio was working fine other than the phone needs service message can you put it back in for me ? So that's what they are doing. Wish I would have just left well enough alone.
Powerball is at what, $400M and rising... your luck has gotta change eventualy...
__________________
The bling wagon: 2014 Grand Cherokee Limited, 5.7, RA4, Lux2, OA2 sporting LTX A/Ts
The mileage slave: 2010 Jetta Sportwagen TDI
Reply With Quote
  #64  
Old 08-05-2013, 01:11 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Utah
Posts: 70
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 515
Jimbo107 is on a distinguished road
Re: 2014 Radio Needs Service Question

Took them literally 5 minutes to put the old radio back in. So anybody needing a replacement that was worried about them tearing out the dashboard, it's apparently not a big job. Cant even tell it was touched
Add making sure the new radio isn't smashed to your checklist before getting a replacement.
__________________
Reply With Quote
  #65  
Old 08-05-2013, 03:05 PM
AZhiCntry's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Prescott, AZ
Posts: 543
Thanks: 280
Thanked 26 Times in 25 Posts
Rep Power: 48836
AZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond repute
Re: 2014 Radio Needs Service Question

Quote:
Originally Posted by Jimbo107 View Post
Well, doesn't look like the install is a big deal but..........I drove away and had to turn around and come back. Touch screen totally unresponsive, jumping from screen to screen, what a mess.

They just called me out to the car and look at the radio from the side.....big crack across the screen, damaged in shipping and they didn't know it and installed it anyway. Told me they had to order another and were going to leave me with the cracked radio.

I said wait a minute my old radio was working fine other than the phone needs service message can you put it back in for me ? So that's what they are doing. Wish I would have just left well enough alone.
Installed it anyway? Makes you wonder about the quality of people in these service depts.
__________________
2014 GC Limited V6 4x4, white w/black & frost beige, LuxII, RA4, ORA II, Cooper Discoverer AT3's. :D:D:D
Reply With Quote
  #66  
Old 08-05-2013, 07:58 PM
Recon ZJ's Avatar
Premium Member
My Jeep: 1997 5.2L ZJ
 
Join Date: May 2013
Location: Surf City, USA
Posts: 87
Thanks: 0
Thanked 12 Times in 8 Posts
Rep Power: 534
Recon ZJ is on a distinguished road
Garage
Re: 2014 Radio Needs Service Question

Quote:
Originally Posted by AZhiCntry View Post
Installed it anyway? Makes you wonder about the quality of people in these service depts.
Installed it anyway and then they apparently didn't check it out to make sure it worked (correctly). Sheesh!
__________________
___________
'14 WK2 Summit 3.0 EcoDiesel - Deep Auburn Pearlcoat/GC Brown
'97 GC Laredo - lifted, locked and loaded
'81 280ZX - p/t dd, weekend cruiser
'72 240Z - parked, needs everything
'02 Chevy S10 Xtreme - former dd - to be sold
Reply With Quote
  #67  
Old 08-05-2013, 08:27 PM
BobsWK2's Avatar
Premium Member
 
Join Date: Aug 2010
Posts: 1,518
Thanks: 3
Thanked 23 Times in 21 Posts
Rep Power: 49504
BobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond repute
Re: 2014 Radio Needs Service Question

Has anyone noticed any dead pixels yet on the 8.4? I know when I had my 2005 Dodge Magnum with the nav it had a dead pixel right in the middle of the screen. Went to have it looked at, dealer first said they will order a new nav system,but then Chrysler came back and said they don't change the system for a dead pixel.

So that's another one of my fears on having the radio changed out.
__________________
2014 Summit 4X4, V8
Reply With Quote
  #68  
Old 08-05-2013, 08:29 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,855
Thanks: 526
Thanked 839 Times in 463 Posts
Rep Power: 1926969
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: 2014 Radio Needs Service Question

Quote:
Originally Posted by BobsWK2 View Post
Has anyone noticed any dead pixels yet on the 8.4? I know when I had my 2005 Dodge Magnum with the nav it had a dead pixel right in the middle of the screen. Went to have it looked at, dealer first said they will order a new nav system,but then Chrysler came back and said they don't change the system for a dead pixel.

So that's another one of my fears on having the radio changed out.
If you have a radio replaced and it has a dead pixel report it immediately. Yes, single dead pixels are usually not covered but on a replacement they will replace it if you report it immediately.

Also dead pixels are far less common now as the process of making the displays has changed significantly.
__________________
Reply With Quote
  #69  
Old 08-12-2013, 10:39 AM
jahlinux's Avatar
Premium Member
 
Join Date: Jul 2013
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 384
jahlinux is on a distinguished road
Re: 2014 Radio Needs Service Question

I had my radio replaced because of the "Vehicle Requires Service" message. Everything was working fine for about a week. Then I started getting the same "Vehicle Requires Service" message every time I started the car. The red light would come on next to the 911 button on the mirror, and the worse thing was the GPS was all screwed up. It had the car out in the Atlantic Ocean. This went on for about three days. I was looking at the settings for the GPS thinking maybe there was a way to calibrate it. Didn't find anything, but I did turn on the option to show traffic on the map. Now ever sense I did that the radio and gps are working fine. I called the dealer last Friday and he has submitted the problem to Detroit. I either did not get a new radio or replacing the radio is not solving the problems Jeep is having with them. Anyone else have problems with their replaced radios?
__________________
Reply With Quote
  #70  
Old 08-12-2013, 02:08 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2010
Location: Inland Empire, CA
Posts: 617
Thanks: 16
Thanked 12 Times in 7 Posts
Rep Power: 1152184
Specx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond repute
Re: 2014 Radio Needs Service Question

I have an appointment to get mine replaced this week. I took it in 2 months ago and the dealer claimed to have placed the order, but never heard from them and the issue went away. Now when I click on the SD card, it starts at the same song regardless if I was listening to another song earlier and randomly the phone service comes on. I'm hoping Chrysler has identified the issue causing these radios to go out and fixes it the right way. I'd hate to have to get a new radio every couple months because they didn't test these things properly.
__________________
Ordered 02/06/2013: 2014 Overland, Brilliant Black Exterior, Black Interior, 5.7 Hemi, Off-Road Adventure II, Advanced Technology Group

Vehicle Delivered to Dealer 03/25/2013 05:00 PM PDT In my garage!
Reply With Quote
  #71  
Old 08-12-2013, 06:57 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Aug 2011
Location: NYC
Posts: 662
Thanks: 49
Thanked 18 Times in 12 Posts
Rep Power: 2122
Roki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond repute
Re: 2014 Radio Needs Service Question

Quote:
Originally Posted by jahlinux View Post
I had my radio replaced because of the "Vehicle Requires Service" message. Everything was working fine for about a week. Then I started getting the same "Vehicle Requires Service" message every time I started the car.
Just picked up my car from dealer this morning. On my way home from work the message came back. I'm just hoping that this is just a blimp as Uconnect was updating itself with YELP and stuff ...

What a mess ... I just don't want to go through this whole spiel again. Chrysler needs to throw everything and everybody at this issue until they find the root cause.

Still love my GC ... except for this issue it has been flawless. I wish I had time to wait instead of buying in April. Unfortunately with my old car in the shop and baby on the way I didn't have that luxury.
__________________
2014 Jeep GC, V6, Black/Indigo with Adv Tech Package and ORAII
Reply With Quote
  #72  
Old 08-12-2013, 07:08 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,855
Thanks: 526
Thanked 839 Times in 463 Posts
Rep Power: 1926969
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: 2014 Radio Needs Service Question

Quote:
Originally Posted by Roki303 View Post
Just picked up my car from dealer this morning. On my way home from work the message came back. I'm just hoping that this is just a blimp as Uconnect was updating itself with YELP and stuff ...

What a mess ... I just don't want to go through this whole spiel again. Chrysler needs to throw everything and everybody at this issue until they find the root cause.

Still love my GC ... except for this issue it has been flawless. I wish I had time to wait instead of buying in April. Unfortunately with my old car in the shop and baby on the way I didn't have that luxury.
There is an issue with a something specific to cell cards. They are working on a fix for it (or I should say they have a fix but it isn't available yet). Most Radios will have it come up VERY rarely on the current software platform. If it comes up all the time there is an issue, but I am hoping that is not the case for you.

As you just got Re-Activated, I would say this is the once in a blue moon, but that is an educated guess based on what I know of your situation.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Service Interval Question akasjl Grand Cherokee - WK2 - 18 11-21-2012 07:10 AM
T-case Service Question lewi3069 Troubleshooting/Problems 15 09-29-2011 09:41 PM
Any Problems With An Aftermarket Radio & Dealer Service Updates? 1stJeepGC Audio/Visual/Navigation 5 07-21-2011 09:01 PM
Service Question nickyj Trouble Shooting/Problems/Service 2 04-15-2011 04:20 PM
Dealership Service Question Mookie10 Trouble Shooting/Problems/Service 5 01-09-2011 09:55 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community