Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 09-17-2013, 11:22 AM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,490
Thanks: 0
Thanked 20 Times in 17 Posts
Rep Power: 80040
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: 2014 Safety Recall - anybody else?

My Buicks register OAT properly as soon as I turn the ignition on. My '12 seems about right.
__________________

__________________
Web home. Notary Sojac Y'all
One of these is a diesel:
Reply With Quote
  #14  
Old 09-17-2013, 05:58 PM
BobsWK2's Avatar
Premium Member
 
Join Date: Aug 2010
Posts: 1,516
Thanks: 3
Thanked 23 Times in 21 Posts
Rep Power: 49490
BobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond repute
Re: 2014 Safety Recall - anybody else?

Every vehicle that I've had that had a OAT display always gave a proper reading, no matter how cold or hot the engine was, or how long the vehicle has been parked or operated. There is just no logic to the reason Chrysler designed it the way it currently is on the 2014 WK2.
__________________

__________________
2014 Summit 4X4, V8
Reply With Quote
  #15  
Old 09-19-2013, 08:35 AM
Member
 
Join Date: Jan 2013
Location: Seattle, WA
Posts: 218
Thanks: 0
Thanked 8 Times in 8 Posts
Rep Power: 754
Copefree is on a distinguished road
Re: 2014 Safety Recall - anybody else?

I wonder if this has to do with this issue I posted about back in April when I took delivery. Here's the YouTube video and a link to the thread:

2014 Jeep Grand Cherokee LED flaw - YouTube

'14 Overland LED running-lamp flaw?
__________________
- Ryan

2014 JGC Overland - V6 / 4x4 / Granite / Black interior / Advance Tech Package

Took delivery 4/10/13
Reply With Quote
  #16  
Old 09-19-2013, 09:23 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 5,788
Thanks: 291
Thanked 285 Times in 252 Posts
Rep Power: 1801199
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Safety Recall - anybody else?

Quote:
Originally Posted by Copefree View Post
I wonder if this has to do with this issue I posted about back in April when I took delivery. Here's the YouTube video and a link to the thread:

2014 Jeep Grand Cherokee LED flaw - YouTube

'14 Overland LED running-lamp flaw?
This has nothing to do with DRLs not working properly. It has to do with parking lights not coming on.


---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #17  
Old 09-19-2013, 09:38 AM
jer630's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: Greer, SC
Posts: 34
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 636
jer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond repute
Re: 2014 Safety Recall - anybody else?

Quote:
Originally Posted by bill_de View Post
This has nothing to do with DRLs not working properly. It has to do with parking lights not coming on.


---
Actually, it's sort of confusing, I think Copefree's issue seems similar based on Chrysler's response to NHTSA in regards to the recall - see 573.6(c)(5) in the document below.

http://www-odi.nhtsa.dot.gov/acms/cs...3V289-5415.pdf
__________________
Reply With Quote
The Following User Says Thank You to jer630 For This Useful Post:
  #18  
Old 09-26-2013, 10:28 AM
Member
 
Join Date: Dec 2012
Posts: 52
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 736
discokachina has a reputation beyond reputediscokachina has a reputation beyond reputediscokachina has a reputation beyond reputediscokachina has a reputation beyond reputediscokachina has a reputation beyond reputediscokachina has a reputation beyond repute
Re: 2014 Safety Recall - anybody else?

I took my Summit in for this recall a few days ago, it took about an hour for them to do it.

When I got into the car in the service drive when I hit the Auto button to turn on the AC I got heat from the floor vents. I also noticed the outside temp was 15 degrees too high. I changed the settings and found I could get cold air only by hitting MaxAc.

I showed this to the service tech and he was befuddled so he took the car to the back.

Another hour goes by and the technician brings the car back to the drive. He said that when they did the flash it made the car forget who it was. The ac was now working correctly and the temp was reading correctly.

When I got home I realized that my phone was not connected. I had to reconnect my blue tooth phone and reset all the other settings on the panel as it seems everything was back to default.

In going through my settings I noticed something a little strange. When I hit the Forward Collision Warning box the check mark stays for about 5 seconds and then dissapears??

And if I hit the Sound + Display in Park Sense the check mark stays for several seconds and then dissapears. After I did this one several times more today the check mark now stays there.

So my question is should the check mark stay in the FCW box.

See for yourself
__________________
Reply With Quote
  #19  
Old 09-26-2013, 11:22 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 5,788
Thanks: 291
Thanked 285 Times in 252 Posts
Rep Power: 1801199
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Safety Recall - anybody else?

Quote:
Originally Posted by jer630 View Post
Actually, it's sort of confusing, I think Copefree's issue seems similar based on Chrysler's response to NHTSA in regards to the recall - see 573.6(c)(5) in the document below.

http://www-odi.nhtsa.dot.gov/acms/cs...3V289-5415.pdf
Silly me. I never paid much attention to the lights as I can't see them while driving. I never realized that the DRL's were the parking lights.

Thanks for the PDF
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #20  
Old 10-25-2013, 05:57 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jul 2013
Location: Amarillo Texas
Posts: 278
Thanks: 0
Thanked 6 Times in 4 Posts
Rep Power: 687
Baalic has a reputation beyond reputeBaalic has a reputation beyond reputeBaalic has a reputation beyond repute
Re: 2014 Safety Recall - anybody else?

Quote:
Originally Posted by discokachina View Post
I took my Summit in for this recall a few days ago, it took about an hour for them to do it.

When I got into the car in the service drive when I hit the Auto button to turn on the AC I got heat from the floor vents. I also noticed the outside temp was 15 degrees too high. I changed the settings and found I could get cold air only by hitting MaxAc.

I showed this to the service tech and he was befuddled so he took the car to the back.

Another hour goes by and the technician brings the car back to the drive. He said that when they did the flash it made the car forget who it was. The ac was now working correctly and the temp was reading correctly.

When I got home I realized that my phone was not connected. I had to reconnect my blue tooth phone and reset all the other settings on the panel as it seems everything was back to default.

In going through my settings I noticed something a little strange. When I hit the Forward Collision Warning box the check mark stays for about 5 seconds and then dissapears??

And if I hit the Sound + Display in Park Sense the check mark stays for several seconds and then dissapears. After I did this one several times more today the check mark now stays there.

So my question is should the check mark stay in the FCW box.

See for yourself

Had similiar problems with my AC actually, my outside temp was reading 115, it was 90 outside, and it was blowing straight hot air on everything and not comming from the proper location, "ie not console but on the floor like you"

They didn't do anything to mine, but let it run for about 20 minutes and the thing slowly started working....

Now my issue is that the box for "fuel saver" mode to be displayed doesn't work, in fact, it wont stay checked at all, taking it in again tuesday for the latest Uconnect we will see if that fixes it...

Glad I'm not the only one who had issues with AC after the parking light fix
__________________
Reply With Quote
  #21  
Old 10-25-2013, 09:19 PM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 785
Thanks: 0
Thanked 26 Times in 21 Posts
Rep Power: 72979
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: 2014 Safety Recall - anybody else?

Quote:
Originally Posted by BobsWK2 View Post
Every vehicle that I've had that had a OAT display always gave a proper reading, no matter how cold or hot the engine was, or how long the vehicle has been parked or operated. There is just no logic to the reason Chrysler designed it the way it currently is on the 2014 WK2.
All my cars had the correct temp cold or hot. Including my old Jeep and the current Jeep.
__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #22  
Old 10-26-2013, 03:48 PM
Member
 
Join Date: Dec 2012
Posts: 52
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 736
discokachina has a reputation beyond reputediscokachina has a reputation beyond reputediscokachina has a reputation beyond reputediscokachina has a reputation beyond reputediscokachina has a reputation beyond reputediscokachina has a reputation beyond repute
Re: 2014 Safety Recall - anybody else?

Quote:
Originally Posted by Baalic View Post
Had similiar problems with my AC actually, my outside temp was reading 115, it was 90 outside, and it was blowing straight hot air on everything and not comming from the proper location, "ie not console but on the floor like you"

They didn't do anything to mine, but let it run for about 20 minutes and the thing slowly started working....

Now my issue is that the box for "fuel saver" mode to be displayed doesn't work, in fact, it wont stay checked at all, taking it in again tuesday for the latest Uconnect we will see if that fixes it...

Glad I'm not the only one who had issues with AC after the parking light fix
Jeep said to replace the head unit for the radio........ They had to order it, it has come in so now I have to make an appt to get it replaced. PITA! But at least they are going to fix it I will post the results!
__________________
Reply With Quote
  #23  
Old 10-26-2013, 04:34 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 5,788
Thanks: 291
Thanked 285 Times in 252 Posts
Rep Power: 1801199
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Safety Recall - anybody else?

Quote:
Originally Posted by Baalic View Post
Had similiar problems with my AC actually, my outside temp was reading 115, it was 90 outside, and it was blowing straight hot air on everything and not comming from the proper location, "ie not console but on the floor like you"

They didn't do anything to mine, but let it run for about 20 minutes and the thing slowly started working....

Now my issue is that the box for "fuel saver" mode to be displayed doesn't work, in fact, it wont stay checked at all, taking it in again tuesday for the latest Uconnect we will see if that fixes it...

Glad I'm not the only one who had issues with AC after the parking light fix
When I left the dealer after the parking light fix everything was blowing hot. While I was pressing all the buttons, I noticed the blue halo was missing around tihe 3G. I turned around and went back to the dealer to ask if they set it back on purpose. It was a mistake, as they didn't even have the newest version. I told them I would update it at home. I forgot to mention the heater problem, but when I got back in the Jeep and started it up, the a/c was working fine, and has been ever since.


---
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
Reply

Tags
2014

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 WK2 Recall (BCM Flash?) libby2cm Trouble Shooting/Problems/Service 2 09-05-2013 06:20 PM
Safety whip/flag StephenE Troubleshooting/Problems 0 05-24-2011 01:55 PM
Government Safety Ratings jrb1 Grand Cherokee - WK2 - 8 10-10-2010 03:07 PM
Safety Recall J33: Instrument Panel Top Cover TheHawk Trouble Shooting/Problems/Service 5 12-29-2009 07:56 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community