Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 09-19-2013, 03:26 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,302
Thanks: 329
Thanked 358 Times in 312 Posts
Rep Power: 1801818
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Uconnect issues and such....

Quote:
Originally Posted by jpurvistx View Post
I'm sure someone has posted this, but where can I get the latest version of the uconnect software to download?

Thanks!

First you need to become a supporting member. Then you will find it in the VIP section.

Or, you can let your dealer install it.


---
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!
Reply With Quote
  #26  
Old 09-19-2013, 03:27 PM
Member
 
Join Date: Aug 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 461
jpurvistx is on a distinguished road
Re: 2014 Uconnect issues and such....

Oh really? I thought we could download it onto a USB and install it ourselves.
__________________

__________________
Reply With Quote
  #27  
Old 09-19-2013, 04:28 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,302
Thanks: 329
Thanked 358 Times in 312 Posts
Rep Power: 1801818
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Uconnect issues and such....

Quote:
Originally Posted by jacko15 View Post
Only available at your dealer.
Jack,

Are the dealers installing something later than 13.19, or is it only if you get a new radio?

The way things are working for me I'm not looking for any upgrade for myself.


---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!
Reply With Quote
  #28  
Old 09-19-2013, 09:48 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,161
Thanks: 214
Thanked 161 Times in 129 Posts
Rep Power: 89628
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: 2014 Uconnect issues and such....

13.19 is the latest available upgrade unless you get a new radio with newer version. jpurvistx isn't a supporting member so he needs to see a dealer. That is, of course, unless he wants to become a supporting member.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
The Following User Says Thank You to jacko15 For This Useful Post:
  #29  
Old 09-20-2013, 09:01 AM
New Member
 
Join Date: Sep 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
nyk1016 is on a distinguished road
Re: 2014 Uconnect issues and such....

This same exact thing happened to me on my 14 limited. I had to go back and forth to the dealer multiple times before the found out what it was. Basically they said there were a series of updates that were never completed, which should have been done by the original dealer before the car was driven off the lot. When my new dealer (I moved from NY to FL shortly after purchasing the car) tried to run the updates it fried the radio. They had to order an entirely new radio which took about a week to come in. Once that was installed I have not had any problems.
__________________
Reply With Quote
  #30  
Old 10-03-2014, 02:24 PM
New Member
 
Join Date: Oct 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
kir911 is on a distinguished road
Re: 2014 Uconnect issues and such....

Great radio until it stops working and you have to deal with Chrysler service. My media hasn't worked in 2 months. After dealing with dealership then I finally got a case # through Chrysler. The are telling me "maybe" in 2.5 months there will be a release update. I'm pursuing the lemon law now over a radio!
__________________
Reply With Quote
  #31  
Old 10-03-2014, 02:34 PM
Member
 
Join Date: Aug 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 461
jpurvistx is on a distinguished road
Re: 2014 Uconnect issues and such....

I applied the latest and greatest update about 3 weeks ago and it still fades out to white and resets many times a day. They finally ordered me a new radio and it's going to be installed next week. I'm still not very confident that will fix all the problems. I hope it helps though. Ugh.
__________________
Reply With Quote
  #32  
Old 10-03-2014, 02:55 PM
macfan's Avatar
Premium Member
My Jeep: 2014 3.2L KL
 
Join Date: Oct 2013
Location: Fenton, Michigan USA
Posts: 371
Thanks: 72
Thanked 45 Times in 37 Posts
Rep Power: 4890
macfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond repute
Re: 2014 Uconnect issues and such....

Quote:
Originally Posted by kir911 View Post
Great radio until it stops working and you have to deal with Chrysler service. My media hasn't worked in 2 months. After dealing with dealership then I finally got a case # through Chrysler. The are telling me "maybe" in 2.5 months there will be a release update. I'm pursuing the lemon law now over a radio!
ROFLOL, I wish you lots of luck with that strategy.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 UConnect phone pairing issues? Amylee Audio/Visual/Navigation 162 10-19-2013 02:17 PM
UConnect 2014 memory issues Roki303 Grand Cherokee - WK2 - 28 04-22-2013 01:27 PM
Uconnect 8.4A issues kohj1978 Audio/Visual/Navigation 18 03-28-2013 09:25 PM
2014 Uconnect in a 11-13??? spinxt Audio/Visual/Navigation 2 03-23-2013 07:32 AM
Uconnect issues Cascade159 Grand Cherokee - WK 2 03-16-2010 11:13 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community