Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-01-2013, 01:24 PM
Premium Member
 
Join Date: Sep 2013
Posts: 532
Thanks: 1
Thanked 58 Times in 44 Posts
Rep Power: 5203
Peter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond repute
2014 V8 Transmission

Quick question to those of you out there with the Hemi (V8) and 8-speed transmission.

I've noticed on the highway (travelling at a fixed speed) that if I slam the accelerator down to WOT, the transmission (or throttle or something) seems to hesitate...a couple of seconds or so before it fully downshifts and takes off. This is in non-ECO mode as well as ECO mode.

Anyone here notice similar? I didn't notice this before...but then again I only have 420 miles on it so I wasn't really doing anything at WOT until today (had to pass someone).

Just wondering if this is normal or something strange going on from others' perspective.
__________________

__________________
Reply With Quote
  #2  
Old 11-01-2013, 01:41 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 2,513
Thanks: 38
Thanked 90 Times in 83 Posts
Rep Power: 43989
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: 2014 V8 Transmission

Quote:
Originally Posted by Peter_K View Post
Quick question to those of you out there with the Hemi (V8) and 8-speed transmission.

I've noticed on the highway (travelling at a fixed speed) that if I slam the accelerator down to WOT, the transmission (or throttle or something) seems to hesitate...a couple of seconds or so before it fully downshifts and takes off. This is in non-ECO mode as well as ECO mode.

Anyone here notice similar? I didn't notice this before...but then again I only have 420 miles on it so I wasn't really doing anything at WOT until today (had to pass someone).

Just wondering if this is normal or something strange going on from others' perspective.
It has been commented on.

I don't know if it is the combination of the engine in MDS 4 banger mode, or if the transmission controls is just trying too hard to protect the drivetrain or what.

It is notably less when you are in Sport mode, but is still there.

It is almost as if the transmission control wants to check in with the nannies at NHTSA before it will allow the downshift.

I would think it could be a characteristic of the Hemi, but if you grab the left paddle to do the downshift, I haven't noticed the "hang on, let me check with mom" type hesitation.

Oddly enough, 3/4 to 7/8 throttle seems not to have so much, but I've sure noticed it and tend to drive in sport mode and manual shift on uphill two lanes so I can pass the sleeping Volvo on the rare passing lanes.
__________________

__________________
Reply With Quote
  #3  
Old 11-01-2013, 02:28 PM
Premium Member
 
Join Date: Sep 2013
Posts: 532
Thanks: 1
Thanked 58 Times in 44 Posts
Rep Power: 5203
Peter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond repute
Tried a couple of experiments. It seems the faster you are already going, the worse the "lag" is. I also noticed in the cluster that when I slam down WOT at speed (transmission is in 8th) the transmission downshifts three times in rapid succession. You can barely feel the first two, then on the third it seems to have found its gear and THEN the throttle kicks in. If others are doing the same thing (and it's not just my crazy vehicle ) that might explain the hesitation--engine torque management until it gets to it's final selected gear.
__________________
Reply With Quote
  #4  
Old 11-01-2013, 02:39 PM
Member
 
Join Date: Jul 2013
Posts: 494
Thanks: 2
Thanked 21 Times in 16 Posts
Rep Power: 17749
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: 2014 V8 Transmission

I have noticed a bit of lag but I dont find it to be any more than in other cars I've had and its better than the other SUVs and trucks I have had (IMHO).

To me, if I give it moderate throttle and it only has to go down a gear it happens pretty quick, exactly as I expect and gives me a nice push into the seat as I go by. Its when I am asking it to skip down 2 or 3 gears there is more noticeable lag. Clearly the transmission isnt programmed for or meant in this vehicle to snap off lightning quick up/down shifts.

I know others have complained, but I think the hemi has a lot of pickup and go. I honestly think it could out run my 2011 TL up to 60ish.
__________________
Reply With Quote
  #5  
Old 11-01-2013, 03:31 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jul 2013
Location: Amarillo Texas
Posts: 279
Thanks: 0
Thanked 6 Times in 4 Posts
Rep Power: 790
Baalic has a reputation beyond reputeBaalic has a reputation beyond reputeBaalic has a reputation beyond repute
i haven't noticed more then a split seconds lag on shifts. I never expected a race truck either though. My previous Jeep was a WJ 4.0 so I am over the moon with the power of the 5.7 and responsiveness. It's not my Corvette, but it gets the job done!
__________________
Reply With Quote
  #6  
Old 11-01-2013, 03:48 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jul 2013
Location: Beech Mountain, NC
Posts: 194
Thanks: 13
Thanked 6 Times in 6 Posts
Rep Power: 677
2014RedHemiGC is on a distinguished road
Re: 2014 V8 Transmission

Every auto equipped vehicle I've ever owned (except for the CTS-V) seemed to have a split second hesitation before fully gearing down to a lower gear, especially when the throttle was mashed all the way down.
__________________
2014 Jeep GC Limited 4X4 V8 QD2
2012 Cadillac CTS-V Coupe
2011 Chevy Corvette Z06/07
Reply With Quote
  #7  
Old 11-01-2013, 04:02 PM
Premium Member
 
Join Date: Sep 2013
Posts: 532
Thanks: 1
Thanked 58 Times in 44 Posts
Rep Power: 5203
Peter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond repute
Re: 2014 V8 Transmission

Hmm...not really talking about a "split second" kind of thing. This is basically a good 2-3 second lag when driving at high speed (60-70) and then mashing WOT. So, I was curious...
__________________

__________________
Reply With Quote
Reply

Tags
2014

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Transmission GoldenBear03 Trouble Shooting/Problems/Service 167 06-27-2014 09:27 PM
2014 transmission CR review DougDurango 2011+ Dodge Durango-WD 7 10-28-2013 09:29 AM
2014 Transmission Issue...maybe? LetMeRide Grand Cherokee - WK2 - 1 06-28-2013 12:02 AM
2014 Transmission not Shifting gottubes Trouble Shooting/Problems/Service 15 04-30-2013 07:46 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:17 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community