Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-25-2013, 03:24 PM
New Member
 
Join Date: Dec 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
ASCAUTO3 is on a distinguished road
3.6 Overheat / Bad Radiator Fan @ 48k mi

New to posting, but a great fan of everyone's informaiton on this site.

Second owner of a 2011 Laredo X 4x4 w/ 3.6 @ 48,000 mi. Halfway home on a 2400 mile road trip, was parked running with AC on for 20 minutes (family in car). Came back to find the temperature gauge nearly pegged. After the car cooled, examinatin determined that the radiator fan isn't coming on at all, high or low. Fues is good, relay is good (swapped them both to check). Fan is getting power when engine warms and/or AC on, but no spinning...

Have a new fan on order, will be here Wednesday. Maybe a fluke, but keep an eye out of these. I pulled the fan earlier today, very easy removal.
__________________

__________________
Reply With Quote
  #2  
Old 02-26-2013, 07:54 AM
AAAA's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jan 2011
Location: Upstate NY
Posts: 2,633
Thanks: 27
Thanked 44 Times in 40 Posts
Rep Power: 1543417
AAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond repute
Re: 3.6 Overheat / Bad Radiator Fan @ 48k mi

Welcome to the site and thanks for the heads up.
__________________

__________________
Limited- Michelin LTX M/S 2's, chrome fog bezels, front and t. c. skid plates, Bosch Icon blades, Husky X-Act Contour slush mats, MOPAR cargo mat. 2015 Overland on order.
(Avatar- http://www.ussslater.org/)
Reply With Quote
  #3  
Old 03-03-2013, 05:57 AM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2012
Posts: 305
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1267
tnjeep has disabled reputation
Re: 3.6 Overheat / Bad Radiator Fan @ 48k mi

Welcome and thanks.
__________________
Reply With Quote
  #4  
Old 03-03-2013, 05:34 PM
weck's Avatar
Member
 
Join Date: Nov 2012
Location: Wisco
Posts: 747
Thanks: 14
Thanked 24 Times in 24 Posts
Rep Power: 3657
weck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond repute
Re: 3.6 Overheat / Bad Radiator Fan @ 48k mi

If it isn't the fan, it's probably the coolant temp sensor... Good luck
__________________
Reply With Quote
  #5  
Old 03-04-2013, 12:12 AM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,537
Thanks: 0
Thanked 24 Times in 21 Posts
Rep Power: 80157
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: 3.6 Overheat / Bad Radiator Fan @ 48k mi

If the a/c was on and the fan wasn't I doubt that it was the sensor. Can check temp with EVIC anyway.
Reply With Quote
  #6  
Old 03-04-2013, 02:18 PM
weck's Avatar
Member
 
Join Date: Nov 2012
Location: Wisco
Posts: 747
Thanks: 14
Thanked 24 Times in 24 Posts
Rep Power: 3657
weck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond repute
Re: 3.6 Overheat / Bad Radiator Fan @ 48k mi

Quote:
Originally Posted by padgett View Post
If the a/c was on and the fan wasn't I doubt that it was the sensor. Can check temp with EVIC anyway.
Yeah, realized after I posted that he checked the potential at the fan connection, so it's gotta be the fan.

I'm not sure how the Jeep is, but I've had cars that have a sensor and a switch in the coolant circuit, the temp gauge can work while the temp switch is faulty. Sometimes it's also a switched ground rather than positive to complete the circuit, which makes troubleshooting fun!!
__________________
Reply With Quote
  #7  
Old 03-06-2013, 09:24 AM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,537
Thanks: 0
Thanked 24 Times in 21 Posts
Rep Power: 80157
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: 3.6 Overheat / Bad Radiator Fan @ 48k mi

However the Heep fan is handled by the computer so the EVIC temp is the same as the computer uses for turn on. That said there is a relay (K11) for the LO fan, 60a fuse for both (J19) both on the TIPM.

That said if there is power at the fan connector and it isn't turning, there you are.

Normal warmed up temp seems to be 197-204F which to me is a touch warm but OK. I suspect I may add a sensor/relay to turn the fan on at 200F though. 210 is higher than I like and have seen at stoplights.
__________________

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radiator Fan Not Working JeepWK07 Troubleshooting/Problems 9 07-09-2012 09:28 PM
radiator fan yev_martin Troubleshooting/Problems 2 02-21-2012 11:39 PM
Radiator Fan mbriddle Grand Cherokee - WK2 - 5 10-10-2011 04:57 PM
2003 Radiator Fan JeepMe Troubleshooting/Problems 3 04-28-2011 12:35 PM
Problem with Radiator Fan???????? Please HELP Jdpur816 Troubleshooting/Problems 18 07-25-2010 07:41 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community