36k miles. Total transmission failure! - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-13-2015, 03:07 AM
New Member
 
Join Date: Jan 2015
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
tunernewb92 is on a distinguished road
36k miles. Total transmission failure!

So I haven't seen this problem posted anywhere and figured I would post my experience in case anybody else down the road has similar.

We purchased a 2011 WK2 Hemi/tow package/Laredo. At the time of purchase the Jeep had 32k miles and was owned bought in Florida. No issues with the vehicle for 4k miles. Just drive around town and a few longer road trips.

In December my wife used remote start to crank up the Jeep to warm it to go to work. She got in, put it in reverse, and had to rev it very high to get it to move anywhere. Also had a CEL on. Checked the fluid and it was fine. So had it towed to a local Dealership. Three days later I call and they are doing three recalls on it and the Service Writer said that they would have a diagnosis the next day. Well they called and said it was a front pump failure and they would be replacing the transmission components .

Three weeks later I receive the car back. They replaced:

Front Pump Kit
Torque Converter
All Seals
All clutches
All plates
Vbody
Filter
12 QTS Fluid


As well as under recall

Brake Booster
Sun Visor Wiring
Fuel Pump Relay


So that was kind of disappointing. I expected more out of the 6spd Mercedes transmission. I guess I'm just unlucky. Anybody else had similar problems?

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 02-13-2015, 09:43 AM
Member
 
Join Date: Aug 2014
Posts: 106
Thanks: 3
Thanked 7 Times in 3 Posts
Rep Power: 1009
airgas1998 is on a distinguished road
Re: 36k miles. Total transmission failure!

well don't feel bad, lots of issues with the new current 8spd tied to the v6
Reply With Quote
  #3  
Old 02-13-2015, 01:02 PM
AAAA's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jan 2011
Location: Upstate NY
Posts: 3,491
Thanks: 202
Thanked 164 Times in 144 Posts
Rep Power: 1545131
AAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond repute
Re: 36k miles. Total transmission failure!

Quote:
Originally Posted by airgas1998 View Post
well don't feel bad, lots of issues with the new current 8spd tied to the v6
I do not agree with that statement. Anyway, he has the 5 speed.
__________________
Overland: Nokian WR G3 SUV tires, front and t. c. skid plates, Bosch Icon blades, Husky X-Act Contour slush mats, MOPAR cargo mat. Successor to trouble-free 2011 Limited.
(Avatar- http://www.ussslater.org/)
Reply With Quote
  #4  
Old 02-13-2015, 01:13 PM
New Member
 
Join Date: Jan 2015
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
tunernewb92 is on a distinguished road
Re: 36k miles. Total transmission failure!

It goes to six on the dash. Is it just a 5spd with OD?
Reply With Quote
  #5  
Old 02-13-2015, 02:00 PM
antsjeep's Avatar
Senior Member
My Jeep: 2015 WK2
 
Join Date: Feb 2010
Posts: 2,248
Thanks: 209
Thanked 229 Times in 198 Posts
Rep Power: 18350
antsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond repute
36k miles. Total transmission failure!

I had the 5 speed Benz transmission in my previous WK and had zero problems with it (put 65k on it from brand new). It really was pretty much perfect.

I wonder if the 2011's used the same tranny as the '05-'10 WK's ?


Sent from my iPhone using JeepGarage
__________________
2015 Altitude - Billet Silver
SRT Springs, Taillight Bezels, Red Start Button, Pedals & Grille Mesh, Black Lugs,
Mopar 4" Chrome exhaust tips, 1.25" Bora Wheel Spacers,
DDM 5500k HID,
Red LED 3157 Bulbs, 15% Tint, Polk DB Center Channel, Mopar All Weather Mats

Reply With Quote
  #6  
Old 02-13-2015, 03:02 PM
New Member
 
Join Date: Jan 2015
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
tunernewb92 is on a distinguished road
Re: 36k miles. Total transmission failure!

Quote:
Originally Posted by antsjeep View Post
I had the 5 speed Benz transmission in my previous WK and had zero problems with it (put 65k on it from brand new). It really was pretty much perfect.

I wonder if the 2011's used the same tranny as the '05-'10 WK's ?


Sent from my iPhone using JeepGarage

My stepdad had a 2008 with 190k on it when it was sold. It had that goofy flutter/shutter but it still ran strong.
Reply With Quote
  #7  
Old 02-13-2015, 03:11 PM
ssgunner's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2014
Location: So Cal
Posts: 962
Thanks: 19
Thanked 56 Times in 52 Posts
Rep Power: 1999
ssgunner has a reputation beyond reputessgunner has a reputation beyond reputessgunner has a reputation beyond reputessgunner has a reputation beyond reputessgunner has a reputation beyond repute
Re: 36k miles. Total transmission failure!

That sux. Maybe its time for an upgrade.

Its interesting to me that 2011 offered the hemi in the Laredo. Wonder why they dont now.
__________________
2014 Jeep Grand Cherokee Overland 4x2 5.7 HEMI MAX Steel>Build Date:Oct/13-Mods: Billet CC Blue, Searching for best exhaust option...
Reply With Quote
  #8  
Old 02-13-2015, 03:34 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 4,001
Thanks: 73
Thanked 277 Times in 244 Posts
Rep Power: 46300
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: 36k miles. Total transmission failure!

Quote:
Originally Posted by tunernewb92 View Post
It goes to six on the dash. Is it just a 5spd with OD?
Either that or it is a transmission from Spinal Tap...
Reply With Quote
  #9  
Old 02-13-2015, 05:15 PM
New Member
 
Join Date: Jan 2015
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
tunernewb92 is on a distinguished road
Re: 36k miles. Total transmission failure!

Quote:
Originally Posted by ssgunner View Post
That sux. Maybe its time for an upgrade.

Its interesting to me that 2011 offered the hemi in the Laredo. Wonder why they dont now.

Yes I checked. My book says you could buy the Laredo with a hemi if you ordered it.

---------- Post added at 10:15 PM ---------- Previous post was at 10:14 PM ----------

Quote:
Originally Posted by lstowell View Post
Either that or it is a transmission from Spinal Tap...

No you guys are right it's 5spd. My fault.
Reply With Quote
  #10  
Old 02-13-2015, 06:16 PM
Senior Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2010
Posts: 1,337
Thanks: 1
Thanked 46 Times in 41 Posts
Rep Power: 4126
jp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond repute
Re: 36k miles. Total transmission failure!

Quote:
Originally Posted by tunernewb92 View Post
So I haven't seen this problem posted anywhere and figured I would post my experience in case anybody else down the road has similar.

We purchased a 2011 WK2 Hemi/tow package/Laredo. At the time of purchase the Jeep had 32k miles and was owned bought in Florida. No issues with the vehicle for 4k miles. Just drive around town and a few longer road trips.

In December my wife used remote start to crank up the Jeep to warm it to go to work. She got in, put it in reverse, and had to rev it very high to get it to move anywhere. Also had a CEL on. Checked the fluid and it was fine. So had it towed to a local Dealership. Three days later I call and they are doing three recalls on it and the Service Writer said that they would have a diagnosis the next day. Well they called and said it was a front pump failure and they would be replacing the transmission components .

Three weeks later I receive the car back. They replaced:

Front Pump Kit
Torque Converter
All Seals
All clutches
All plates
Vbody
Filter
12 QTS Fluid


As well as under recall

Brake Booster
Sun Visor Wiring
Fuel Pump Relay


So that was kind of disappointing. I expected more out of the 6spd Mercedes transmission. I guess I'm just unlucky. Anybody else had similar problems?

Well if its a 2011 Hemi its a 5 speed and its not the Mercedes transmission. The Mercedes transmission was only on the 6 cylinder units. In any event this is not the norm for the 545REF which is what you have and its normally a reliable and durable transmission.
Reply With Quote
  #11  
Old 08-04-2015, 03:12 PM
millarduck's Avatar
Member
My Jeep: 2016 3.6L WK2
 
Join Date: Apr 2012
Location: Delaware
Posts: 83
Thanks: 6
Thanked 12 Times in 6 Posts
Rep Power: 1825
millarduck is on a distinguished road
Re: 36k miles. Total transmission failure!

I am having my second transmission replaced at 72,000 miles, my first was at 33,00 miles. I won't even go into the valve head replacement, or 730N failures Oops I just did.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
First big road trip in the Jeep. 3435 miles total. Aiyer Grand Cherokee - WK2 - 12 07-15-2013 10:01 AM
2002 Jeep Grand Cherokee total electrical failure armtom Troubleshooting/Problems 1 02-20-2013 04:33 PM
Reached the 36k mile mark ;) 4th Cherokee Grand Cherokee - WK2 - 4 07-09-2012 06:12 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:19 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.