A/C issue ... frustrating dealer response - Page 2 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 09-02-2014, 06:31 PM
Member
 
Join Date: Nov 2013
Posts: 55
Thanks: 0
Thanked 7 Times in 3 Posts
Rep Power: 1228
Bolimitzr1 is on a distinguished road
Re: A/C issue ... frustrating dealer response

Having similar issue. After an hour in manual mode with sync on. Ac anywhere between low and 68 usually with recirc on. I experience a loss of flow, tried mode doors they divert air properly and its cold, I can notice the recirc and fresh air modes changing as well. So all my actuator doors seem to work. The moment my flow is greatly reduced I crank up the temp and my flow increases and gets warm obviously, I'll get a little vapor cloud for a minute from all vents then I can go back to AC on full blast. Thinking the evap is freezing. Anyone know if air from heater core passes over evaporator then to the vent? If so this explains how I fix issue temporarily. That means I need to clean evaporator and swap new cab filter and worse case new pressure switch or faulty evap probe thermistor.

Reply With Quote
Sponsored Links
Advertisement
 
  #14  
Old 09-02-2014, 11:12 PM
SRTNinja's Avatar
Premium Member
My Jeep: 2014 6.4L WK2
 
Join Date: Aug 2012
Location: DC
Posts: 769
Thanks: 36
Thanked 188 Times in 124 Posts
Rep Power: 16955
SRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond repute
Garage
Re: A/C issue ... frustrating dealer response

Just came back from vacation to Myrtle Beach, 7.5hrs each way. My A/C freezes us out with the fan on low and set around 68 synced on manual mode. After an hour I usually put it at 74 and never noticed any loss of performance yet. It works really well and I have 33,987 on it now. I bought it with 26,218k in March while it was still cool out and never used the A/C. I took in in for service for the console tray being broke. When I picked it up I noticed on the paperwork they did a flash. I asked them why and they said it would improve the performance. I'm not sure if it helped or not bc I never used the A/C prior to the flash, but my A/C is stellar either way. Here's the flash they did hope it helps. It says "Tech flashed, HVAC#18-19-62-01. Maybe you can ask the dealer what that means bc I don't see it as a TSB#.
__________________
Instagram @srtninja
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The uConnect radio is frustrating... 2014falcon Audio/Visual/Navigation 3 01-26-2014 10:11 PM
FRUSTRATING. Uconnect won't play folders correctly Hazemonster Audio, Video, Navigation & Electronic Modifications 5 01-18-2014 05:16 PM
So frustrating five.7 Hemi Grand Cherokee - WK2 - 0 06-03-2012 09:41 PM
Battery Discharge Issue? (Frustrating) JGC_DelSiggy Trouble Shooting/Problems/Service 5 06-13-2011 06:25 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:26 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.