Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-25-2014, 08:32 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Mar 2012
Location: Colorado
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 995
newtoncd8 is on a distinguished road
A/C issue ... frustrating dealer response

I took my 2012 Jeep Grand Cherokee (23,100 miles) in to get two A/C issues looked at.

1) When using remote start, the A/C did not kick on.
2) When driving for extended periods, the unit has reduced airflow and is not blowing cold air

They fixed #1 with no problem at all. The invoice says "23069 TSB - 24-002-12 0.20 Flashed HVAC controller with new software for remote start issue".

For problem #2, they said it was likely freezing up and not to run the unit on high. After disagreeing with him, I mentioned the TSB (24-003-12) that specifically addresses the problem I am having with having the A/C on for extended periods and reduced airflow. After I showed him the TSB, he stated the TSB only applied to vehicles with "manual temperature control" and mine has "automatic temperature control". I mentioned I could override and switch to manual mode.

<TSB 24-002-12 is dated 25 Oct 2012 and TSB24-003-12 is dated 30 Oct 2012>

I will admit I was getting a bit frustrated as I am getting ready to go on a long trip and don't want to experience this problem again.

My question that the service adviser was unable to answer is ... When the tech "flashed HVAC controller with new software for remote issue" did that encompass all updates as of the latest software load or did it only address the remote start issue? In other words, will it also fix problem #2?

Can anyone help? Thank you.
__________________

__________________
-
--
2012 JGC V6 Limited AWD
2004 Lexus RX330 AWD
1977 MG-B
Reply With Quote
  #2  
Old 07-25-2014, 08:46 PM
MDBones's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2014
Location: Wisconsin's West Coast
Posts: 865
Thanks: 35
Thanked 74 Times in 66 Posts
Rep Power: 1536
MDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond repute
Garage
Re: A/C issue ... frustrating dealer response

These are 2 separate TSB's. The one you had performed doesn't address the second issue.
__________________

__________________

Garage: The Ghost
Reply With Quote
  #3  
Old 07-25-2014, 09:01 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Mar 2012
Location: Colorado
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 995
newtoncd8 is on a distinguished road
Re: A/C issue ... frustrating dealer response

Quote:
Originally Posted by MDBones View Post
These are 2 separate TSB's. The one you had performed doesn't address the second issue.
Thank you ... that is what I was afraid of .... will call the lead service manager and see how things go.
__________________
-
--
2012 JGC V6 Limited AWD
2004 Lexus RX330 AWD
1977 MG-B
Reply With Quote
  #4  
Old 07-25-2014, 09:08 PM
MDBones's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2014
Location: Wisconsin's West Coast
Posts: 865
Thanks: 35
Thanked 74 Times in 66 Posts
Rep Power: 1536
MDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond repute
Garage
Re: A/C issue ... frustrating dealer response

Good luck to you... I have issue #2 myself. Just waiting until the next oil change.
__________________

Garage: The Ghost
Reply With Quote
  #5  
Old 07-30-2014, 03:47 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Mar 2012
Location: Colorado
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 995
newtoncd8 is on a distinguished road
Re: A/C issue ... frustrating dealer response

Just in case others wanted to know, I took the Jeep back in this morning to get the "poor performance with A/C" TSB applied and the tech advised that the TSB update for the remote (TSB-002-12) also encompassed all other updates (including TSB-003-12); in other words, it was not just a single update for that TSB to the HVAC system.

I guess we will see if that is true in a few days as I drive it on an extended trip.
__________________
-
--
2012 JGC V6 Limited AWD
2004 Lexus RX330 AWD
1977 MG-B
Reply With Quote
  #6  
Old 07-31-2014, 09:23 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2014
Posts: 154
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 425
TypeRod has a reputation beyond reputeTypeRod has a reputation beyond reputeTypeRod has a reputation beyond reputeTypeRod has a reputation beyond reputeTypeRod has a reputation beyond repute
Re: A/C issue ... frustrating dealer response

Not trying to hi-jack the thread, but does the a/c on 2014 JGC's come on with remote start? IIRC, I remoted started mine a few weeks ago, and the a/c never came on.
__________________
Reply With Quote
  #7  
Old 07-31-2014, 10:51 PM
BuckeyeSRT's Avatar
Senior Member
My Jeep: 2012 5.7L WK2
 
Join Date: Mar 2011
Location: Home of the Buckeyes
Posts: 1,591
Thanks: 28
Thanked 27 Times in 27 Posts
Rep Power: 102308
BuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond repute
Re: A/C issue ... frustrating dealer response

Does the airflow decrease but air out of the vent stays cold?
__________________
2012 BB Overland Summit
Like my company on Facebook ...please
https://www.facebook.com/TheSimmondsGroup
Twitter @simmondsgroup
Reply With Quote
  #8  
Old 07-31-2014, 11:35 PM
Rewind23's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2012
Location: Colorado
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 697
Rewind23 is on a distinguished road
I have 2014 and when you use remote start it automatically goes to 72*. Once you open the door it then goes to whatever the last setting in the car was. Mine wasn't changing when I opened the door and had to get an update and now it works perfectly.
__________________
Reply With Quote
  #9  
Old 08-01-2014, 04:56 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2014
Posts: 154
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 425
TypeRod has a reputation beyond reputeTypeRod has a reputation beyond reputeTypeRod has a reputation beyond reputeTypeRod has a reputation beyond reputeTypeRod has a reputation beyond repute
Re: A/C issue ... frustrating dealer response

Quote:
Originally Posted by BuckeyeSRT View Post
Does the airflow decrease but air out of the vent stays cold?
Not sure if you were asking me but no air flow at all, the a/c never turned on.

Quote:
Originally Posted by Rewind23 View Post
I have 2014 and when you use remote start it automatically goes to 72*. Once you open the door it then goes to whatever the last setting in the car was. Mine wasn't changing when I opened the door and had to get an update and now it works perfectly.
I also read somewhere it has to be in "auto" mode, is that true for yours as well? I never use the auto mode in a/c in any of my vehicles. I like have the cold air blow on my face in auto mode I feel like I don't feel any air movement. lol.
__________________
Reply With Quote
  #10  
Old 08-01-2014, 05:22 PM
BuckeyeSRT's Avatar
Senior Member
My Jeep: 2012 5.7L WK2
 
Join Date: Mar 2011
Location: Home of the Buckeyes
Posts: 1,591
Thanks: 28
Thanked 27 Times in 27 Posts
Rep Power: 102308
BuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond repute
Re: A/C issue ... frustrating dealer response

Quote:
Originally Posted by TypeRod View Post
Not sure if you were asking me but no air flow at all, the a/c never turned on.



I also read somewhere it has to be in "auto" mode, is that true for yours as well? I never use the auto mode in a/c in any of my vehicles. I like have the cold air blow on my face in auto mode I feel like I don't feel any air movement. lol.
No, I was asking the OP. I am having a similar issue as he is...I think
__________________
2012 BB Overland Summit
Like my company on Facebook ...please
https://www.facebook.com/TheSimmondsGroup
Twitter @simmondsgroup
Reply With Quote
  #11  
Old 08-02-2014, 08:31 AM
Rewind23's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2012
Location: Colorado
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 697
Rewind23 is on a distinguished road
Quote:
Originally Posted by TypeRod View Post

Not sure if you were asking me but no air flow at all, the a/c never turned on.

I also read somewhere it has to be in "auto" mode, is that true for yours as well? I never use the auto mode in a/c in any of my vehicles. I like have the cold air blow on my face in auto mode I feel like I don't feel any air movement. lol.
I can't remember if it works on manual mode. I usually just leave it on auto. There is an update though for it. You can find it online if you Google it. There's a Chrysler web page with all the updates for our Jeep's. If you want me to try it in manual mode just let me know.
__________________
Reply With Quote
  #12  
Old 08-03-2014, 11:34 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2014
Posts: 154
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 425
TypeRod has a reputation beyond reputeTypeRod has a reputation beyond reputeTypeRod has a reputation beyond reputeTypeRod has a reputation beyond reputeTypeRod has a reputation beyond repute
Re: A/C issue ... frustrating dealer response

Quote:
Originally Posted by Rewind23 View Post
I can't remember if it works on manual mode. I usually just leave it on auto. There is an update though for it. You can find it online if you Google it. There's a Chrysler web page with all the updates for our Jeep's. If you want me to try it in manual mode just let me know.
If its no trouble, could you please try in manual mode? I'm out of town and didn't drive my JGC. No rush though. Thanks for your time!
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The uConnect radio is frustrating... 2014falcon Audio/Visual/Navigation 3 01-26-2014 10:11 PM
FRUSTRATING. Uconnect won't play folders correctly Hazemonster Audio, Video, Navigation & Electronic Modifications 5 01-18-2014 05:16 PM
So frustrating five.7 Hemi Grand Cherokee - WK2 - 0 06-03-2012 08:41 PM
Battery Discharge Issue? (Frustrating) JGC_DelSiggy Trouble Shooting/Problems/Service 5 06-13-2011 05:25 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:06 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community