Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #133  
Old 11-01-2010, 07:32 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Aug 2010
Location: Pittsburgh
Posts: 188
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1631
jpsmith is on a distinguished road
Re: Any glitches after weeks of driving?

Quote:
Originally Posted by jpsmith View Post

Quote:
Originally Posted by jpsmith
New Problem this morning: one of the rear window defroster grid lines doesn't work. It's one right in the middle of the window, so it's right in the line of sight. On a chilly morning like today it took about 5 minutes for the other grid lines' heat to get to this area, but in the winter when the windows are frosty I know it will take longer. I'll be digging out my multimeter tonight to test for sure if the grid line is bad and if so will be setting up another appointment with the service department.
Had the Jeep in the shop yesterday for this and to have the shudder fixed via the front axle isolator replacement. They fixed this, but said the grid line wasn't working because it had been scratched, as if by a dog. This is quite plausible. My dogs always ride in the cargo area and I never had a problem with them scratching the defroster grid in my XJ or KJ, but then again, those cars had vertically oriented rear glass, whereas the WK2 has glass that angles in over the dogs' heads.

Yeah, so, they didn't fix this. Went to use the defroster again and it is just as broken as it was before taking it in to the shop.

I've had this Jeep for three months and here's a list of the problems:

- Driveline shudder. "Fixed" via TSB 21-004-10a. The fix reduced it but didn't fix it. Last week, dealer said they couldn't reproduce it and refused to apply star case #S1021000002.

- Fog lamp bulb burned out a few weeks after purchase.

- Rear defroster grid line never worked from day one. Dealer blamed it on my having a dog and "did me a favor" by fixing it for free. They didn't fix it.

- Track skip forward button on steering wheel frequently ignores button presses. Dealer "couldn't reproduce." It's happened at least 20 times since getting it back from them last week.

- This morning an annoying rattle developed somewhere inside the driver's side dash area.

- Two days ago, after backing out of a parking space and beginning to go forward, there was a loud thud from the drive train and the vehicle jerked as if i'd hit something. My wife though I'd run something over. I ran nothing over.

- Picture dividing the EVIC screen into three equal-sized vertical stripes. The right-most one is beginning to fade. The black isn't as black as the other two thirds, and the white isn't as white.


All of these issues add up to the beginnings of a case of buyer's remorse. This car is turning out to be just another shoddy Chrysler.
__________________

__________________
Reply With Quote
  #134  
Old 11-01-2010, 08:40 AM
Senior Member
 
Join Date: Oct 2010
Posts: 1,169
Thanks: 1
Thanked 11 Times in 11 Posts
Rep Power: 2587
jeep2011 has a reputation beyond reputejeep2011 has a reputation beyond reputejeep2011 has a reputation beyond repute
Re: Any glitches after weeks of driving?

That is awful.....I would keep bringing it back to the dealer. If they can't fix these issues after the 3rd try maybe you can get it replaced under a lemon law (if your state has one)
__________________

__________________
Reply With Quote
  #135  
Old 11-01-2010, 10:17 AM
whatevrworks's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jul 2010
Location: Northern Virginia
Posts: 527
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2581
whatevrworks has a reputation beyond reputewhatevrworks has a reputation beyond reputewhatevrworks has a reputation beyond reputewhatevrworks has a reputation beyond reputewhatevrworks has a reputation beyond reputewhatevrworks has a reputation beyond reputewhatevrworks has a reputation beyond reputewhatevrworks has a reputation beyond reputewhatevrworks has a reputation beyond reputewhatevrworks has a reputation beyond reputewhatevrworks has a reputation beyond repute
Re: Any glitches after weeks of driving?

Quote:
Originally Posted by jpsmith View Post
Yeah, so, they didn't fix this. Went to use the defroster again and it is just as broken as it was before taking it in to the shop.

I've had this Jeep for three months and here's a list of the problems:

- Driveline shudder. "Fixed" via TSB 21-004-10a. The fix reduced it but didn't fix it. Last week, dealer said they couldn't reproduce it and refused to apply star case #S1021000002.

- Fog lamp bulb burned out a few weeks after purchase.

- Rear defroster grid line never worked from day one. Dealer blamed it on my having a dog and "did me a favor" by fixing it for free. They didn't fix it.

- Track skip forward button on steering wheel frequently ignores button presses. Dealer "couldn't reproduce." It's happened at least 20 times since getting it back from them last week.

- This morning an annoying rattle developed somewhere inside the driver's side dash area.

- Two days ago, after backing out of a parking space and beginning to go forward, there was a loud thud from the drive train and the vehicle jerked as if i'd hit something. My wife though I'd run something over. I ran nothing over.

- Picture dividing the EVIC screen into three equal-sized vertical stripes. The right-most one is beginning to fade. The black isn't as black as the other two thirds, and the white isn't as white.


All of these issues add up to the beginnings of a case of buyer's remorse. This car is turning out to be just another shoddy Chrysler.

see my post on "more water problems" thats probably the route you need to go. also are you familiar with twitter? pm me I have a way that worked well for me
__________________
Reply With Quote
  #136  
Old 11-01-2010, 10:30 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Aug 2010
Location: Pittsburgh
Posts: 188
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1631
jpsmith is on a distinguished road
Re: Any glitches after weeks of driving?

Unfortunately I don't think I can be invoking lemon law for any of these problems. None of these issues have been "fixed" multiple times yet continue to recur. They're all minor issues (except for the shudder, which Chrysler is working on). It's just that all of them combined make for an unpleasant experience, especially when you throw in the same old same-old from their service departments.
__________________
Reply With Quote
  #137  
Old 11-01-2010, 11:39 AM
Senior Member
 
Join Date: Oct 2010
Posts: 1,169
Thanks: 1
Thanked 11 Times in 11 Posts
Rep Power: 2587
jeep2011 has a reputation beyond reputejeep2011 has a reputation beyond reputejeep2011 has a reputation beyond repute
Re: Any glitches after weeks of driving?

I know it is aggravating getting the old can't replicate or reproduce. That is the one advantage of the foreign manufactures they normally always will replace the part in question rather than send the person on their way with nothing done.

I have had nothing but this from GM and Chrysler.
__________________
Reply With Quote
  #138  
Old 11-01-2010, 01:20 PM
Lingohocken's Avatar
Premium Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2010
Location: Bucks County, Pennsylvania
Posts: 1,185
Thanks: 15
Thanked 9 Times in 6 Posts
Rep Power: 3236
Lingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond repute
Re: Any glitches after weeks of driving?

Quote:
Originally Posted by Canyon Dancer View Post
No joy yet....today when starting from the stop sign near my house, I couldn't get any response from the throttle, so I floored it and nothing.....nadda, almost like there is not connection between the pedal and the motor, finally after holding the pedal to the floor for a good 300 yards, it finally started to pull enough to get me out of the way of the car that was coming up behind me but "just barely". Love the car but I'm extremely disappointed with this problem. This is bad and I am very unhappy with my 7th Jeep purchase.
So you keep telling us. Have you considered the various suggestions from folks here to your original query? If so, it might be helpful to know the results instead of reading your original complaint over and again.
__________________
Reply With Quote
  #139  
Old 11-02-2010, 05:57 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Oct 2010
Location: Loveland, Colorado
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1405
Canyon Dancer is on a distinguished road
Re: Any glitches after weeks of driving?

Please direct me to the answer that you want me to try.

I have been to the dealer to see if there are any TSB's, and they tell me there are none that apply and they have no idea what to do to help me.

I guess I haven't seen any other ideas that apply to this particular stalling issue.
__________________
Reply With Quote
  #140  
Old 11-02-2010, 06:34 PM
Senior Member
 
Join Date: Oct 2010
Posts: 1,169
Thanks: 1
Thanked 11 Times in 11 Posts
Rep Power: 2587
jeep2011 has a reputation beyond reputejeep2011 has a reputation beyond reputejeep2011 has a reputation beyond repute
Re: Any glitches after weeks of driving?

Quote:
Originally Posted by Canyon Dancer View Post
Please direct me to the answer that you want me to try.

I have been to the dealer to see if there are any TSB's, and they tell me there are none that apply and they have no idea what to do to help me.

I guess I haven't seen any other ideas that apply to this particular stalling issue.
Have you tried going to a different dealer?
__________________
Reply With Quote
  #141  
Old 11-04-2010, 10:48 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Sep 2010
Posts: 74
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1697
Remleym has a reputation beyond reputeRemleym has a reputation beyond reputeRemleym has a reputation beyond reputeRemleym has a reputation beyond reputeRemleym has a reputation beyond reputeRemleym has a reputation beyond reputeRemleym has a reputation beyond reputeRemleym has a reputation beyond reputeRemleym has a reputation beyond repute
Re: Any glitches after weeks of driving?

Quote:
Originally Posted by Bmwister View Post
That's kind of funny/strange as I found two different Xpackage Laredos on dealer lots (diff dealers) where that plastic panel on the back of the driver's seat was not popped in. Both times I just pushed it and they snapped into place but wonder what is causing yours to pop back out again?
I have the Limited and the back of my driver's seat popped out a couple of times too. I shoved it back into place the first time and it popped out a couple of days later. The last time it happened I tried to look around a bit inside the back of the seat to see what was going wrong. There are a couple of "prongs" with upward/outward facing hooks molded into the plastic panel and the one on the right side of the panel was what was not grabbing or was popping loose. The last time I reinstalled the panel I wiggled/shoved it more to the right before pushing it back into the seat back. This time it seems that the prong on the right side did grab onto something in the seat back and it has held ever since. Been a couple of weeks now and the panel is still in place. Fingers crossed!
__________________
[SIGPIC][/SIGPIC]
2011 Jeep Grand Cherokee Limited, charcoal grey, 3.6L engine, 20" wheels
Reply With Quote
  #142  
Old 11-04-2010, 02:07 PM
Lingohocken's Avatar
Premium Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2010
Location: Bucks County, Pennsylvania
Posts: 1,185
Thanks: 15
Thanked 9 Times in 6 Posts
Rep Power: 3236
Lingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond repute
Re: Any glitches after weeks of driving?

Quote:
Originally Posted by Canyon Dancer View Post
Please direct me to the answer that you want me to try.

I have been to the dealer to see if there are any TSB's, and they tell me there are none that apply and they have no idea what to do to help me.

I guess I haven't seen any other ideas that apply to this particular stalling issue.
Various gasoline-related points shown in the posting that you replied to, underlined. To make it unambiguous: http://jeepgarage.org/showthread.php?t=13549
__________________
Reply With Quote
  #143  
Old 11-04-2010, 06:13 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Oct 2010
Location: Loveland, Colorado
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1405
Canyon Dancer is on a distinguished road
Re: Any glitches after weeks of driving?

Thanks, will try premium for the next tank and see if that makes a difference.
__________________
Reply With Quote
  #144  
Old 11-05-2010, 02:22 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2010
Location: Canada
Posts: 44
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1406
enjoylife is on a distinguished road
Re: Any glitches after weeks of driving?

300km on my new limited and the horn seems like something went on it. It was honking normal at first and now when i lock doors or honk the horn the sound whent low and weak.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
6+ weeks - still not fixed, '07 5.7 just dies 07GrandCherokee Troubleshooting/Problems 83 01-09-2013 05:23 PM
new mods within 2 weeks. pkang21 Visual Modifications 23 09-24-2009 10:47 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community