Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-11-2014, 01:39 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2013
Location: United States
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 582
MICHIWK2 is on a distinguished road
Garage
Any one else have issues with their water pump?

About 35K to 40K miles i had a faulty water pump. Replaced under warranty and have been fine until now. i have 73K miles on my GC and have not heard back from the dealership as to the extent of the issue but i know i have a blown coolant hose. (5.7L) The one right on top by the fan.

Is anyone else having issues like this???
__________________

__________________
Reply With Quote
  #2  
Old 04-11-2014, 03:04 PM
BuckeyeSRT's Avatar
Senior Member
My Jeep: 2012 5.7L WK2
 
Join Date: Mar 2011
Location: Home of the Buckeyes
Posts: 1,573
Thanks: 28
Thanked 26 Times in 26 Posts
Rep Power: 102259
BuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond repute
Re: Any one else have issues with their water pump?

I had mine replaced lots of discussions about 5.7 water pumps on here
__________________

__________________
2012 BB Overland Summit
Like my company on Facebook ...please
https://www.facebook.com/TheSimmondsGroup
Twitter @simmondsgroup
Reply With Quote
  #3  
Old 04-13-2014, 03:09 PM
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Feb 2013
Location: MA
Posts: 150
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 719
JoeD is a glorious beacon of light
Re: Any one else have issues with their water pump?

Quote:
Originally Posted by MICHIWK2 View Post
About 35K to 40K miles i had a faulty water pump. Replaced under warranty and have been fine until now. i have 73K miles on my GC and have not heard back from the dealership as to the extent of the issue but i know i have a blown coolant hose. (5.7L) The one right on top by the fan.

Is anyone else having issues like this???
If the upper hose is bad, that has nothing to do with the water pump itself. I wouldn't panic about it, its possible it was damaged during the water pump job but odd it waited this long to show up.
See what the shop says
__________________
2013 WK2 Limited 5.7
Reply With Quote
  #4  
Old 04-15-2014, 06:46 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2013
Location: United States
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 582
MICHIWK2 is on a distinguished road
Garage
Re: Any one else have issues with their water pump?

talked to dealership, they ordered me another water pump. Looks like i will be replacing water pumps every 35-40K miles????? lol. I am going to have to ask them about this when i go in to pick up my jeep.
__________________
Reply With Quote
  #5  
Old 04-26-2014, 07:28 PM
xj31's Avatar
Member
 
Join Date: Dec 2010
Posts: 118
Thanks: 0
Thanked 5 Times in 4 Posts
Rep Power: 1490
xj31 has a reputation beyond reputexj31 has a reputation beyond repute
Re: Any one else have issues with their water pump?

Those water pumps have been a real problem. They are almost always on back order
__________________
Fiber makes me sad.
Reply With Quote
  #6  
Old 04-30-2014, 11:22 AM
New Member
My Jeep: 2011 5.7L WK2
 
Join Date: Aug 2011
Location: Ma
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
SB739 is on a distinguished road
Re: Any one else have issues with their water pump?

Just hit 21k on my 2011/ 5.7 and water pump went. Thankfully still under warranty but has been stuck at the dealer for 3 days.
__________________
Reply With Quote
  #7  
Old 05-02-2014, 08:48 AM
Member
My Jeep: 2012
 
Join Date: Jun 2011
Location: AZ
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1308
drwaldo69 has a reputation beyond reputedrwaldo69 has a reputation beyond reputedrwaldo69 has a reputation beyond reputedrwaldo69 has a reputation beyond reputedrwaldo69 has a reputation beyond repute
Re: Any one else have issues with their water pump?

2012 5.7 and on my 3rd pump. First at 18K. Second at 41K. Was told they had a bad bunch with bad bearings. Now at 53K. We will see. They found mine at oil changes. Just keep an eye on your coolant level since I never saw a leak on the floor or elsewhere.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PS Pump, Water pump,or something else? jmc2004 Troubleshooting/Problems 1 03-26-2013 08:08 PM
Vehicle shut down at 110km/h, any one else have similar experience? Gribbs Trouble Shooting/Problems/Service 23 07-27-2012 03:10 AM
Anybody else have tranny issues? Panak Troubleshooting/Problems 5 09-14-2011 06:37 AM
Anybody have any issues with their parking sensors? CougarCruiser Grand Cherokee - WK 10 12-21-2009 09:34 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community