Back up camera problem - Page 2 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 09-08-2015, 04:18 PM
NetworkTV's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Apr 2015
Posts: 810
Thanks: 3
Thanked 182 Times in 138 Posts
Rep Power: 6909
NetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond repute
Re: Back up camera problem

I had mine get stuck on a blue screen once until I shifted out of reverse and back in one day early on when it was raining and foggy.

I wonder if the waterproofing is a bit dicey on these things.

I haven't had it happen since, so I have no clue what happened. At the time, I chalked it up to a single glitch.

__________________
2015 Jeep Grand Cherokee Limited
Deep Cherry Red Crystal Pearl Coat

Reply With Quote
Sponsored Links
Advertisement
 
  #14  
Old 09-08-2015, 04:38 PM
jaybo41's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jul 2015
Location: Pittsburgh, PA
Posts: 183
Thanks: 129
Thanked 25 Times in 20 Posts
Rep Power: 2078
jaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond repute
Re: Back up camera problem

Quote:
Originally Posted by NetworkTV View Post
I had mine get stuck on a blue screen once until I shifted out of reverse and back in one day early on when it was raining and foggy.

I wonder if the waterproofing is a bit dicey on these things.

I haven't had it happen since, so I have no clue what happened. At the time, I chalked it up to a single glitch.
That's an interesting observation, you could be on to something there. I paid the tailgate some extra attention when I washed it. I removed the plate and washed everything twice just to make sure I didn't miss anything. It had quite a bit of dirt on it. I guess I'll know more when we get some precipitation.
Reply With Quote
  #15  
Old 09-08-2015, 04:47 PM
NetworkTV's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Apr 2015
Posts: 810
Thanks: 3
Thanked 182 Times in 138 Posts
Rep Power: 6909
NetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond repute
Re: Back up camera problem

Quote:
Originally Posted by jaybo41 View Post
That's an interesting observation, you could be on to something there. I paid the tailgate some extra attention when I washed it. I removed the plate and washed everything twice just to make sure I didn't miss anything. It had quite a bit of dirt on it. I guess I'll know more when we get some precipitation.
If you have a power washer, it can't hurt to spray it down while someone sits in the Jeep with it idling in reverse (with their foot on the brake, of course). This requires the assistance of a patient spouse who may have better things to do than yell to you if the camera blips off.

If anything will get water to penetrate, that will - and if it does, you'll know there's an issue with the camera housing failing.

I'd try it myself, but:

1) I lack a power washer.

2) I lack the spouse, patient or impatient.
__________________
2015 Jeep Grand Cherokee Limited
Deep Cherry Red Crystal Pearl Coat

Reply With Quote
  #16  
Old 09-08-2015, 08:11 PM
jaybo41's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jul 2015
Location: Pittsburgh, PA
Posts: 183
Thanks: 129
Thanked 25 Times in 20 Posts
Rep Power: 2078
jaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond repute
Re: Back up camera problem

That would be a great way to test it, but I too lack both key ingredients.
Reply With Quote
  #17  
Old 09-09-2015, 02:50 PM
Member
 
Join Date: Mar 2015
Posts: 40
Thanks: 1
Thanked 4 Times in 2 Posts
Rep Power: 671
dlo5 is on a distinguished road
Re: Back up camera problem

https://vid.me/5Too
https://vid.me/qWQy
https://vid.me/96P2


Had rear camera replaced, problem still persists. Here are some videos.
Reply With Quote
  #18  
Old 09-14-2015, 07:29 PM
Member
 
Join Date: Mar 2015
Posts: 40
Thanks: 1
Thanked 4 Times in 2 Posts
Rep Power: 671
dlo5 is on a distinguished road
Re: Back up camera problem

Removed aftermarket sub/amp problem still there
Reply With Quote
  #19  
Old 09-14-2015, 08:09 PM
Keysplayr's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Apr 2015
Posts: 115
Thanks: 6
Thanked 18 Times in 16 Posts
Rep Power: 795
Keysplayr has a reputation beyond reputeKeysplayr has a reputation beyond reputeKeysplayr has a reputation beyond reputeKeysplayr has a reputation beyond reputeKeysplayr has a reputation beyond repute
Garage
Re: Back up camera problem

That looks to me like it could be a wiring harness problem. A broken wire leading anywhere from the camera all the way to the head unit is a nightmare to trace, but it could be the reason it is intermittent. Poor contact. I'm no jeep technician, so i'd trouble shoot the hard way by running my own temp wires from the camera to the head unit and see if that clears it up or makes no difference. If it makes no difference, then it could be the reverse switch is the problem. The rear cam is only engaged in reverse so that is another potential problem source. Lastly, the head unit itself or maybe a bad connection on the wiring block. Sheesh I don't envy you troubleshooting this problem. Anyway, just thinking out loud. Not like Ed Sheeran.
__________________
-Anthony
'15 Laredo Custom
Reply With Quote
  #20  
Old 09-14-2015, 10:07 PM
Member
 
Join Date: Mar 2015
Posts: 40
Thanks: 1
Thanked 4 Times in 2 Posts
Rep Power: 671
dlo5 is on a distinguished road
Re: Back up camera problem

Quote:
Originally Posted by Keysplayr View Post
That looks to me like it could be a wiring harness problem. A broken wire leading anywhere from the camera all the way to the head unit is a nightmare to trace, but it could be the reason it is intermittent. Poor contact. I'm no jeep technician, so i'd trouble shoot the hard way by running my own temp wires from the camera to the head unit and see if that clears it up or makes no difference. If it makes no difference, then it could be the reverse switch is the problem. The rear cam is only engaged in reverse so that is another potential problem source. Lastly, the head unit itself or maybe a bad connection on the wiring block. Sheesh I don't envy you troubleshooting this problem. Anyway, just thinking out loud. Not like Ed Sheeran.

Haha all good ideas I appreciate it. Car is back at the dealer once again for the 5th time i believe. Only has 3000 miles and i been back at the dealer more times then any car i purchased in the past.. combined
Reply With Quote
  #21  
Old 09-15-2015, 06:07 AM
Keysplayr's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Apr 2015
Posts: 115
Thanks: 6
Thanked 18 Times in 16 Posts
Rep Power: 795
Keysplayr has a reputation beyond reputeKeysplayr has a reputation beyond reputeKeysplayr has a reputation beyond reputeKeysplayr has a reputation beyond reputeKeysplayr has a reputation beyond repute
Garage
Re: Back up camera problem

That is annoying for certain. I hope they actually find the problem and get you what you paid for.
__________________
-Anthony
'15 Laredo Custom
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Back Up camera installation problem Tony-562 Audio/Visual/Navigation 2 01-21-2014 11:29 AM
Parkview Camera (reverse camera) Alignment joebuf1 Trouble Shooting/Problems/Service 6 01-11-2012 03:28 PM
Back-up camera with base radio!? Djeazie Audio/Visual/Navigation 3 09-10-2010 09:26 PM
Back-up Camera install Puppetmaster_sr Audio, Video, Navigation & Electronic Modifications 10 07-14-2009 10:17 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.