broke an ABS rear sensor, now stock with an issue. Help me please - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-25-2015, 05:43 PM
simonvez's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Sep 2014
Posts: 248
Thanks: 59
Thanked 55 Times in 38 Posts
Rep Power: 1375
simonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond repute
broke an ABS rear sensor, now stock with an issue. Help me please

Hi guys,

I accidently broke the passenger rear ABS sensor while I a suspension upgrade.. yeah stupid me. So the ECU gave me 3 codes:



It is expected since the ABS/wheel speed sensor is broken.
So I bought a new one, and replaced it. Then I used my ODB2 tool to clear the fault codes. shut down the ignition, and start the engine and go for a ride. No luck, codes are still there. Transmision wont shift into 2nd too.

I have verifed and cleaned the sensor, checked everything. I cleared the codes a couple times, but never was able to see the check engine light go away when clearing.

So I called the dealer, and the guy told me that only a dealer odb2 scanner can do it on these Chrysler ECU. ?!?!?! what ?

Is it true ? I would hate to pay 45$ (half an hour he said)just to clear a stupid code !!

__________________

-Atltiude front grille + rear brow + side badge // Custom retrofit lights // Front Leveling //- 0.75" rear spacers lift // 1.5" wheel spacers // 275-55-20 KO2 // Plasti dip wheels, window moldings, mirrors // Front Chrome bumper guard
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 12-01-2015, 06:13 PM
simonvez's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Sep 2014
Posts: 248
Thanks: 59
Thanked 55 Times in 38 Posts
Rep Power: 1375
simonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond repute
Re: broke an ABS rear sensor, now stock with an issue. Help me please

It was not true at all. you can reset that by your own. The reason why it didnt clear was because it was an active code, and there ware still a problem with the other wheel sensor. So it looks like I broke the 2 rear abs sensor... by mistake.

I have replaced both ABS sensor myself in the rear.. but Im still stuck with those U140C and U140B which are : improbable wheel speed.

Sensors are brand new. I took the jeep to the dealer and they cant find anything. I am freakin mad at this stupid issue..

I dont know what to do anymore
__________________

-Atltiude front grille + rear brow + side badge // Custom retrofit lights // Front Leveling //- 0.75" rear spacers lift // 1.5" wheel spacers // 275-55-20 KO2 // Plasti dip wheels, window moldings, mirrors // Front Chrome bumper guard
Reply With Quote
  #3  
Old 12-01-2015, 09:06 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 52,773
Thanks: 1,939
Thanked 2,266 Times in 1,410 Posts
Rep Power: 7789773
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: broke an ABS rear sensor, now stock with an issue. Help me please

remove the negative off the battery and press the brake pedal several times. Leave off for about 15 minutes.
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
The Following User Says Thank You to Scottina06 For This Useful Post:
  #4  
Old 12-01-2015, 10:37 PM
simonvez's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Sep 2014
Posts: 248
Thanks: 59
Thanked 55 Times in 38 Posts
Rep Power: 1375
simonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond repute
Re: broke an ABS rear sensor, now stock with an issue. Help me please

I tried to diconnect the batterie already for about 3min... i will try longer
__________________

-Atltiude front grille + rear brow + side badge // Custom retrofit lights // Front Leveling //- 0.75" rear spacers lift // 1.5" wheel spacers // 275-55-20 KO2 // Plasti dip wheels, window moldings, mirrors // Front Chrome bumper guard
Reply With Quote
  #5  
Old 12-02-2015, 11:08 AM
simonvez's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Sep 2014
Posts: 248
Thanks: 59
Thanked 55 Times in 38 Posts
Rep Power: 1375
simonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond repute
Re: broke an ABS rear sensor, now stock with an issue. Help me please

no luck. What I find weird is that i will clear the fault code, turn off ignition, and code will re-appear even if the jeep is stationary. So how can it know that the speed is implausible, if the vehicle doesnt even move?
__________________

-Atltiude front grille + rear brow + side badge // Custom retrofit lights // Front Leveling //- 0.75" rear spacers lift // 1.5" wheel spacers // 275-55-20 KO2 // Plasti dip wheels, window moldings, mirrors // Front Chrome bumper guard
Reply With Quote
  #6  
Old 12-02-2015, 11:44 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 52,773
Thanks: 1,939
Thanked 2,266 Times in 1,410 Posts
Rep Power: 7789773
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: broke an ABS rear sensor, now stock with an issue. Help me please

something isn't right with one of the sensors. did you put dielectric grease in the connection? Check all the connections again...maybe unplug and replug? Sounds like you've been thorough. maybe a bad new sensor wire?
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #7  
Old 12-02-2015, 11:55 AM
simonvez's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Sep 2014
Posts: 248
Thanks: 59
Thanked 55 Times in 38 Posts
Rep Power: 1375
simonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond repute
Re: broke an ABS rear sensor, now stock with an issue. Help me please

brand new sensor. If I unplug one of the sensors, I get that P0501 code back, and the transmission wont shift. That tells me that the connection is good somehow. The 2 U140C and B are for each side. I highly doubt that both of the brand new sensors are bad. I could be very unlucky though. I am very desperate because now dealer will charge me 100$/h to undo the harness all the way up to the ABS module. I am 1000% sure that it is not the issue. There is no way I could have broken that far. What i did to break it was pushed down on the wheel hub to lower it, so I could remove the coil spring, while the 3 upper control arms were off, so I forgot to unhook the ABS sensor... so I ended up pulling on the ABS sensor harness and it broke right at the sensor. There is NO possible way that the force could have been transfered to the rest of the harness under the jeep. The ABS sensor is hooked up to the subframe by 3-4 plastic clips. Worst case would have been the first plastic clip that would have broken, but it didnt happen. It broke right at the abs sensor.

__________________

-Atltiude front grille + rear brow + side badge // Custom retrofit lights // Front Leveling //- 0.75" rear spacers lift // 1.5" wheel spacers // 275-55-20 KO2 // Plasti dip wheels, window moldings, mirrors // Front Chrome bumper guard
Reply With Quote
  #8  
Old 12-03-2015, 12:08 PM
simonvez's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Sep 2014
Posts: 248
Thanks: 59
Thanked 55 Times in 38 Posts
Rep Power: 1375
simonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond repute
Re: broke an ABS rear sensor, now stock with an issue. Help me please

after a bit of playing. I was able to fix the driver side somehow. Little bit of plug/unplug and battery disconnect and code clearing. But the right side still has the U140C...

A good question im trying to understand here: What do ABS and Parking assist have comon together ?

Since the ABS issue, the parking assist light is always on, and the is a message on the EVIC display about Parking assis needs maintenance. It HAS to be related somehow since it happened at the same time.
__________________

-Atltiude front grille + rear brow + side badge // Custom retrofit lights // Front Leveling //- 0.75" rear spacers lift // 1.5" wheel spacers // 275-55-20 KO2 // Plasti dip wheels, window moldings, mirrors // Front Chrome bumper guard
Reply With Quote
  #9  
Old 12-04-2015, 10:50 AM
NetworkTV's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Apr 2015
Posts: 833
Thanks: 3
Thanked 191 Times in 144 Posts
Rep Power: 6977
NetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond reputeNetworkTV has a reputation beyond repute
Re: broke an ABS rear sensor, now stock with an issue. Help me please

Quote:
Originally Posted by simonvez View Post
A good question im trying to understand here: What do ABS and Parking assist have comon together ?

Since the ABS issue, the parking assist light is always on, and the is a message on the EVIC display about Parking assis needs maintenance. It HAS to be related somehow since it happened at the same time.
My guess, it's about wheel rotation sensing and the ability to engage braking to control speed when using park assist.

Things like traction control come into play, too, since it often uses braking in combination with acceleration to control wheel slip.
__________________
2015 Jeep Grand Cherokee Limited
Deep Cherry Red Crystal Pearl Coat

Reply With Quote
  #10  
Old 12-07-2015, 09:36 PM
simonvez's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Sep 2014
Posts: 248
Thanks: 59
Thanked 55 Times in 38 Posts
Rep Power: 1375
simonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond repute
Re: broke an ABS rear sensor, now stock with an issue. Help me please

Thanks a lot guys for the help. I apreciate it.. taking the time to read and trying to help me. really nice forum

So..
I figured the issue. when I broke the ABS sensor, it kinda broke in a bad position where I couldnt remove it from the bub, was stuck inside.. I had to drill a hole on the abs sensor part that was still stuck in the hub, and put a screw to be able to pull on the screw, and remove the ABD sensor from the hole. Doing so, I probably dropped a litle piece of broken plastic from the rest of the ABS sensor that was still in the hub. so it ended up damaging the tone ring. I have learned something new while doing it. Our WK2 abs sensors have the ringtone embedded in the wheel bearing. Its not a metal ring with teeth. It is a magnetic ring in the bearing. Dealer told me 4-5h @ 100$/h + 178$ for the bearing. WHAT ?? I decided to try myself. Not knowing in what I was putting myself into haha. It is quite a bit of work.. I got the entire hub out of there in 1h... Im no where near an experienced mechanic, and dont have the super tools dealer may have... but they charge 4-5h to do it !! bunch of stealer !! Im sure they can do this in 2h easy. Anyways. Im glad I found the issue, and glad that I didnt have to pay for the time spent on it. I cant finish the job tonight, beccause I dont have the replacement part, and dont have access to press for now. But my father in law has a bearing press smile emoticon so I will do it there.

__________________

-Atltiude front grille + rear brow + side badge // Custom retrofit lights // Front Leveling //- 0.75" rear spacers lift // 1.5" wheel spacers // 275-55-20 KO2 // Plasti dip wheels, window moldings, mirrors // Front Chrome bumper guard
Reply With Quote
The Following User Says Thank You to simonvez For This Useful Post:
  #11  
Old 12-07-2015, 11:49 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 52,773
Thanks: 1,939
Thanked 2,266 Times in 1,410 Posts
Rep Power: 7789773
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: broke an ABS rear sensor, now stock with an issue. Help me please

Good deal
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #12  
Old 12-08-2015, 10:37 PM
simonvez's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Sep 2014
Posts: 248
Thanks: 59
Thanked 55 Times in 38 Posts
Rep Power: 1375
simonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond reputesimonvez has a reputation beyond repute
Re: broke an ABS rear sensor, now stock with an issue. Help me please

I replaced the bearing with a brand new one, and put everything back together. It went really well. A lot more than I expected. Took about 30-40min to put everything back together Did a road test and HALLEYLUYA !! ABS light turned off !!
__________________

-Atltiude front grille + rear brow + side badge // Custom retrofit lights // Front Leveling //- 0.75" rear spacers lift // 1.5" wheel spacers // 275-55-20 KO2 // Plasti dip wheels, window moldings, mirrors // Front Chrome bumper guard
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updated FW to 2.1 Now A/C and Auto = BROKE morty346 Trouble Shooting/Problems/Service 4 01-16-2013 10:14 AM
Troubles starting with ABS, please help! H2rescue Troubleshooting/Problems Discussion 7 10-20-2011 01:17 PM
ABS Brake module/ABS lamp on GreggyBear Grand Cherokee - ZJ 1 04-03-2011 11:09 AM
Shorty bolt broke off, So what now??? *PICS* White WK Swagga Grand Cherokee - WK 50 10-07-2010 07:54 AM
Broke off a tiny piece of my sensor? big problem or no? SRTILL8 Troubleshooting/Problems Discussion 6 07-15-2010 01:55 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:11 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.