Compass on dash stopped working, location of sensor? - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-02-2014, 05:49 PM
eugene3524's Avatar
Member
 
Join Date: Sep 2013
Posts: 92
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1321
eugene3524 is on a distinguished road
Exclamation Compass on dash stopped working, location of sensor?

Drove through some mud recently so today when washing the car I decided to spray out some of the dried up mud that was sitting under the hood on the cross member and plastic shield, stuck the hose really low and with light spray hosed it off, an hour after that went to drive and the direction on dash is just double dashes. Looked through fuses but didn't find anything for compass. Any ideas?


Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-03-2014, 11:38 AM
eugene3524's Avatar
Member
 
Join Date: Sep 2013
Posts: 92
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1321
eugene3524 is on a distinguished road
Re: Compass on dash stopped working, location of sensor?

really nothing..?
Reply With Quote
  #3  
Old 10-14-2014, 12:23 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 3,995
Thanks: 73
Thanked 277 Times in 244 Posts
Rep Power: 46288
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Compass on dash stopped working, location of sensor?

Quote:
Originally Posted by eugene3524 View Post
really nothing..?
Helps to note year, model, as it could be different.
e.g. on the older ones it was out behind the front bumper.
Might want to try any of the online Mopar parts places, pretty much all are dealers and several have help lines.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Signal lights stopped working..... Jeff_Jeske Troubleshooting/Problems 4 07-19-2016 03:25 PM
uConnect/VR Stopped Working - 430N granto3k Audio/Visual/Navigation 19 02-16-2014 11:53 PM
remote keyless entry have stopped working ithinkfit914 Troubleshooting/Problems 9 01-09-2011 06:38 AM
Blue Tooth stopped working NHWK05 Audio, Video, Navigation & Electronic Modifications 2 02-05-2010 06:27 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.