Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-05-2014, 05:00 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 928
Thanks: 0
Thanked 42 Times in 33 Posts
Rep Power: 3541
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Damn it...Now My 2014 Overland Has A Transmission Issue!

First it was my early build (4/13) 2014 GC Limited 4x4 with the V6 (traded), now it's my later build (12/13) 2014 GC Overland 4x4 with the V6...WTF Chrysler!



A very hard downshift into 1st at low speed...just before coming to a full stop. Seems worse while transmission is not fully warmed up, then after driving a couple miles the hard downshifts into 1st seem to dissipate. All other aspects of the transmission work fine. Now when I say a hard downshift into 1st, I'm talking as if someone just bumped me from behind...like a late lurching stop, and it only happens in the first couple miles from start up while crawling to a full stop.

Now my question is why now after about 5,000 miles? The Jeep prior had been shifting perfectly up until then. The only things that have changed are two radio updates (I'm now running the latest version), and just recently I've started using the "AUTO" function of the climate system (up until then I always ran the A/C in manual). Another weird condition I just remembered is after downloading my first radio update (prior to 14.25.05), the transmission would hang in first gear a bit right after a morning or end of the day start, then right away things went back to normal.

Last night I performed my famous "battery disconnect" thinking maybe the system just needs a full reboot after those radio updates. I've also went though all the 2014 GC TSBs and didn't find any tranny related fixes for my later build (21-007-13 REV. C. is for Nov 12, 2013 or before). I'll keep everyone posted though.
__________________

__________________
My V6 Overland transmission shifts like crap!
Reply With Quote
  #2  
Old 08-05-2014, 05:14 PM
MDBones's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2014
Location: Wisconsin's West Coast
Posts: 978
Thanks: 42
Thanked 83 Times in 74 Posts
Rep Power: 1672
MDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond repute
Garage
Re: Damn it...Now My 2014 Overland Has A Transmission Issue!

Mine started doing that about a month ago. Very hard downshift into 1st coming to a stop. Also have a very hard upshift from 2nd to 3rd. Like you said, it seems to ease off after driving it for a while.

Haven't had any TSB's or software updates applied. Not sure how or why this all of a sudden developed. It may be a learning transmission but it certainly didn't learn this BS from me.

I'll be pointing this out to the service department when I run it in for an oil change shortly.
__________________

__________________

Garage: The Ghost
Reply With Quote
  #3  
Old 08-05-2014, 05:24 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2010
Location: CLT
Posts: 299
Thanks: 6
Thanked 11 Times in 10 Posts
Rep Power: 310386
jeepinAl has a reputation beyond reputejeepinAl has a reputation beyond reputejeepinAl has a reputation beyond reputejeepinAl has a reputation beyond reputejeepinAl has a reputation beyond reputejeepinAl has a reputation beyond reputejeepinAl has a reputation beyond reputejeepinAl has a reputation beyond reputejeepinAl has a reputation beyond reputejeepinAl has a reputation beyond reputejeepinAl has a reputation beyond repute
Re: Damn it...Now My 2014 Overland Has A Transmission Issue!

Great. I was going to get my recall done in a couple of weeks and get the latest updates on the radio, but now you have me thinking about NOT updating it.

Tranny is acceptable and I don't want it to change until I don't see any threads on "shifting" for a year.

We need a sticky titled, " I just TSB'd/ Updated and now..."

Good luck.
__________________
Reply With Quote
  #4  
Old 08-05-2014, 06:34 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2011
Posts: 240
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1330
My1stJGC is on a distinguished road
Re: Damn it...Now My 2014 Overland Has A Transmission Issue!

The only time I have that issue is going a small distance like not even getting to 10mph. Is that what you are talking about. Any other time coming to a stop I never get down to 3rd before I come to a stop. Mine is only the 1 to 2 and 2 to 3 studder shift problem. 8700 miles at the moment. Been told its performing right at the moment. Dealership agrees there's a software problem but nothing they can do. They have even replaced a trans in another customers jeep and still had same problem.
__________________
Reply With Quote
  #5  
Old 08-06-2014, 03:34 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 2,514
Thanks: 38
Thanked 90 Times in 83 Posts
Rep Power: 43992
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Damn it...Now My 2014 Overland Has A Transmission Issue!

Quote:
Originally Posted by jeepinAl View Post
Great. I was going to get my recall done in a couple of weeks and get the latest updates on the radio, but now you have me thinking about NOT updating it.

Tranny is acceptable and I don't want it to change until I don't see any threads on "shifting" for a year.

We need a sticky titled, " I just TSB'd/ Updated and now..."

Good luck.
That's sorta like not visiting the dentist because you bought new shoes.
The transmission isn't controlled by the radio.

Doing a battery reset would get rid of all learned behavior, where it might need to relearn driving preferences, but presuming the transmission flash has been done, it could be the !@#$ thing just decided to act up now.
__________________
Reply With Quote
  #6  
Old 08-07-2014, 08:57 AM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 735
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1247
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: Damn it...Now My 2014 Overland Has A Transmission Issue!

mine has done this forever.. I have had the trans flash and now its only when cold (actually the whole truck runs like crap and wont really go unless it floor it.. before its warmed up) but, after its warm its great.

I love that Chrysler will be adding the start/stop to the next model jeep.. lol.. they cant even get this one working right!! Should be interesting to watch the flood of complaints "Stopped at a light... and it wont move"

1 year down, 2 to go...
__________________
Reply With Quote
  #7  
Old 08-07-2014, 12:51 PM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 928
Thanks: 0
Thanked 42 Times in 33 Posts
Rep Power: 3541
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: Damn it...Now My 2014 Overland Has A Transmission Issue!

After performing a battery reset...didn't do a damn thing.

Transmission still downshifts HARD into first coming to a full stop when not fully warmed up.

__________________
My V6 Overland transmission shifts like crap!
Reply With Quote
  #8  
Old 08-11-2014, 11:57 PM
Member
 
Join Date: Feb 2014
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 260
LB2014JGC is on a distinguished road
Re: Damn it...Now My 2014 Overland Has A Transmission Issue!

Same here, just broke 6k miles and it started with the harsh down shifting and horrible 2nd to 3rd shift when cold. Very awkward when passengers are in the car as it is a brand new vehicle and shouldn't feel like a teenager learning to drive a standard... This is the second Chrysler purchase with problems in less than a year. So torqued about my 2013 Ram issues I unloaded it for this. Now issues this early. Jeep I am very frustrated and tempted to swap my personal cars over to GM again, along with the dozen plus I run at my shop.
__________________
Reply With Quote
  #9  
Old 08-12-2014, 08:57 AM
wraab's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2013
Location: Houston, Tx
Posts: 185
Thanks: 14
Thanked 4 Times in 4 Posts
Rep Power: 499
wraab is on a distinguished road
Re: Damn it...Now My 2014 Overland Has A Transmission Issue!

I've had this issue for about 5000 miles, off and on. I'm at 7200 miles now.

The "service adviser/tech" said they couldn't replicate the issue so they did no re-flash. But they also said the HVAC was working properly, it's not. And they also didn't bother to do the RRT's that were in their system. I have little faith in jeep service.
__________________
Reply With Quote
  #10  
Old 08-13-2014, 08:49 PM
Member
 
Join Date: Feb 2014
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 260
LB2014JGC is on a distinguished road
I also have had a Ram 5500 flatbed in the dealership that Chrysler has not been able to fix for over a month. It is a 2013 that I use to tow machinery for work. It being down is costing me thousands and corporate Chrysler doesn't know customer service or how to fix the products they produce.
__________________
Reply With Quote
  #11  
Old 08-13-2014, 10:13 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Sep 2013
Posts: 226
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 5417
WATacoRider has a reputation beyond reputeWATacoRider has a reputation beyond reputeWATacoRider has a reputation beyond reputeWATacoRider has a reputation beyond reputeWATacoRider has a reputation beyond reputeWATacoRider has a reputation beyond reputeWATacoRider has a reputation beyond reputeWATacoRider has a reputation beyond reputeWATacoRider has a reputation beyond reputeWATacoRider has a reputation beyond reputeWATacoRider has a reputation beyond repute
Re: Damn it...Now My 2014 Overland Has A Transmission Issue!

Mine has started to do this too recently. I actually started noticing it after my last oil change at the dealership. They didn't do anything besides changing the oil.

Bought in Oct 2013. If I remember correctly, has an August 2013 build date.

I've never had any sort of flashing or updates done to my vehicle, except for the radio updates, that I do myself.

It's just one of those things I've adjusted myself to. Car has 5800 miles now.

Still goes and stops fine. Just has that jerky stopping motion. If I didn't know any better, almost feels like ABS kicking in.
__________________
Reply With Quote
  #12  
Old 08-26-2014, 09:50 PM
DSYLEXC's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2014
Location: CA, USA
Posts: 46
Thanks: 2
Thanked 2 Times in 2 Posts
Rep Power: 277
DSYLEXC is on a distinguished road
Garage
Re: Damn it...Now My 2014 Overland Has A Transmission Issue!

Just noticed mine doing the harsh downshift into first when cold a few days ago...3400 miles...bullshit


Sent from my iPhone using JeepGarage
__________________

__________________
2014 Jeep Grand Cherokee (Bright White) Limited 4x4 3.6L V6 ORA2 8.4AN Sunroof Body-Colored Mirrors Fold Flat Front Passenger Seat
Built 3/25/14 @ Midnight


Reply With Quote
Reply

Tags
2014, overland

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are the stock tow hooks on 2014 worth a damn? TurboRush Interior/Exterior/Visual 6 08-22-2013 06:32 AM
Damn!!! Who has these? anyone? jasonjsl Visual Modifications 4 05-23-2011 09:15 AM
Damn!!Dodge considering Challenger SRT10 production. SoCalMoparWK Other Rides 13 04-23-2010 11:09 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.