Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-09-2013, 02:17 PM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 841
Thanks: 0
Thanked 33 Times in 26 Posts
Rep Power: 73138
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Do any folks with 2014 Larado's have ECO Mode complaints

One or two folks with Larado's here have said they have no issues with Eco Mode.

I'm being careful to not say "Transmission" problem. But that's the topic I'm talking about. You'll see why in a second.

I'm wondering if the problem is somehow related to the Dual Exhaust.

The Dual Exhaust sounds completely different and the engine might be tuned different for it.

The ECO Mode problem feels more like how the Engine is poorly "Tuned" in some scenarios way more than poor "Shift Points" which people keep pointing at.

So I'm curious first, are there statistically as many complaints about the ECO mode performance on the Larado exhaust vs the Dual Exhaust of the Limited and up.

One other thing that could be happening is the car feels likes it's "Racing" (i.e. kicking down too far) more with a louder dual exhaust. It literally sounds like a drag racer when it does this over downshift thing. Where it might not feel so eventful on a much quieter exhaust.

Just a thought.
__________________

__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #2  
Old 10-10-2013, 01:09 PM
SoulStealer's Avatar
Member
 
Join Date: Jan 2013
Location: CT
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 672
SoulStealer is on a distinguished road
I have a rough shifting 14 laredo with the v6
__________________

__________________
Reply With Quote
  #3  
Old 10-10-2013, 02:34 PM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 841
Thanks: 0
Thanked 33 Times in 26 Posts
Rep Power: 73138
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: Do any folks with 2014 Larado's have ECO Mode complaints

Quote:
Originally Posted by SoulStealer View Post
I have a rough shifting 14 laredo with the v6
Thanks for your input.

Can you describe what rough shifting means to you? I think there is more than one issue going on.

Some people describe a problem where you accelerate briskly, let up on the gas and perhaps it sees it can skip a gear. And when it goes in, you get a Clunk. Some people get that clunk as it downshifts when your rolling to a stop. This sounds like a mechanical (e.g. syncing gears) issue and sometimes confused with other undesirable behaviors. And for folks with this issue taking it out of Eco mode does not help. Still could be a software issue though. I suspect later build models don't have the "Clunk" issue. Not sure if that is due to mechanical change or intermediate better firmware from the factory. And I don't think it's trim level dependent. I personally have never seen this problem on my later build limited.

The issue I'm referring to in the first post strictly the ECO Mode behavior. Where it will Lag, sometimes quite a lot as you gently accelerate from a stop. If you ask for more power, it lags further. Then you ask for more and it downshifts A LOT and suddenly your head whips back and you're on someone's butt. Some might call this "rough shifting". I don't. Because the transmission it self does this thing with grace. Taking it out of ECO mode reduces this problem 95%. When it goes into this aggressive downshift it tends to want to stay there after you let off the gas much longer than feels right. Eventually it will. Pressing the gas modestly will bring the gear back up faster than just waiting with no pedal. This really feels like a software issue. It can vary a lot because what your transmission has "adapted" I think greatly effects it. I'm suspecting might be trim level dependent (i.e. Dual Exhaust or not). Like perhaps the Larado single exhaust tuning is being using on the dual exhaust models. With such major exhaust different I can't imaging the tuning with be identical. It might be handled through "Adaptive" process. But the Larado adapts better. I do have this problem on my limited even after the recent TSB.
__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #4  
Old 10-10-2013, 03:34 PM
Member
 
Join Date: Sep 2013
Posts: 74
Thanks: 2
Thanked 5 Times in 4 Posts
Rep Power: 491
argue4u is on a distinguished road
Re: Do any folks with 2014 Larado's have ECO Mode complaints

I have a V6 limited, but I had all the problems you mention intermittently. Took it to the dealer and there is a flash update that is supposed to fix the problem. It was substantially better after they flashed it but seems to be getting worse again a few months later (now). I've heard others have fixed the problem by removing the battery terminals for a period of time and then reconnecting. Many Jeep dealers like to tell you that it is just the characteristic of a Jeep, I disagree.

My favorite response of theirs to fix it: "just deactivate the ECO mode every time you start the vehicle."
__________________
Reply With Quote
  #5  
Old 10-10-2013, 06:48 PM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 841
Thanks: 0
Thanked 33 Times in 26 Posts
Rep Power: 73138
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: Do any folks with 2014 Larado's have ECO Mode complaints

Quote:
Originally Posted by argue4u View Post
I have a V6 limited, but I had all the problems you mention intermittently. Took it to the dealer and there is a flash update that is supposed to fix the problem. It was substantially better after they flashed it but seems to be getting worse again a few months later (now). I've heard others have fixed the problem by removing the battery terminals for a period of time and then reconnecting. Many Jeep dealers like to tell you that it is just the characteristic of a Jeep, I disagree.

My favorite response of theirs to fix it: "just deactivate the ECO mode every time you start the vehicle."
I know what Limited's do. I have one. I'm curious if Larado's have the same Eco Mode only issue.
__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #6  
Old 10-10-2013, 07:27 PM
LaberoC's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Location: WA
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 516
LaberoC is on a distinguished road
I hate eco mode always turn it off unless im cruising on the freeway...dont really know what the problem is but it just really feels like its struggling too much probably cuz of all the hills
__________________
Reply With Quote
  #7  
Old 10-10-2013, 07:28 PM
LaberoC's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Location: WA
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 516
LaberoC is on a distinguished road
That and the shifting is really rough sometimes...still havent done the flash but from what I read its not really helping much
__________________
Reply With Quote
  #8  
Old 10-10-2013, 08:58 PM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 841
Thanks: 0
Thanked 33 Times in 26 Posts
Rep Power: 73138
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: Do any folks with 2014 Larado's have ECO Mode complaints

Quote:
Originally Posted by LaberoC View Post
That and the shifting is really rough sometimes...still havent done the flash but from what I read its not really helping much
And you're driving a Larado?

You should set your Model Year and Trim Level in your profile.
__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #9  
Old 10-10-2013, 09:00 PM
1quick1's Avatar
Member
My Jeep: 2014 3.6L JK
 
Join Date: Oct 2013
Location: Denver, CO
Posts: 109
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 490
1quick1 is on a distinguished road
Re: Do any folks with 2014 Larado's have ECO Mode complaints

ECO seems to shift hard sometimes because it's always trying to keep it under 2k rpm's so you need to speed up a bit but you're going 36mph in 7th gear at 1300rpm so it violently downshifts. ECO mode off is much better. Even better is sport mode but it really holds those gears long so it's not too practical for day to day.
__________________
Reply With Quote
  #10  
Old 10-10-2013, 10:03 PM
LaberoC's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Location: WA
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 516
LaberoC is on a distinguished road
Quote:
Originally Posted by mswlogo View Post

And you're driving a Larado?

You should set your Model Year and Trim Level in your profile.
Yeah laredo...will do
__________________
Reply With Quote
  #11  
Old 10-10-2013, 11:27 PM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 841
Thanks: 0
Thanked 33 Times in 26 Posts
Rep Power: 73138
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: Do any folks with 2014 Larado's have ECO Mode complaints

Ok, thanks. It sounds like Lorado's are no different.
__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #12  
Old 10-13-2013, 09:12 AM
f1anatic's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2013
Location: Illinoize
Posts: 996
Thanks: 12
Thanked 70 Times in 52 Posts
Rep Power: 158259
f1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond repute
Re: Do any folks with 2014 Larado's have ECO Mode complaints

Well, I do not have a Larado but I am thinking you should ensure that your Lorado gets all the applicable reflashes to transmission and engine. I can't speak for the Laredo, but on the Limited, there have been at least 2 engine and 2 transmission control module reflashes which transformed the car.
__________________

__________________
Reply With Quote
Reply

Tags
2014

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Eco Mode - 5.7 Hemi a990dna Grand Cherokee - WK2 - 26 07-01-2014 10:22 AM
V8 eco mode vs V6 sport mode dtrvm Engine Performance/Intakes/Exhausts 8 08-13-2013 12:50 AM
Eco mode JonBed Grand Cherokee - WK2 - 1 05-21-2013 09:15 AM
2014 V6 Eco Mode - How to default to off?!? kirk1233 Grand Cherokee - WK2 - 63 03-28-2013 01:42 AM
ECO mode jeepinusa Engine Performance/Intakes/Exhausts 2 03-19-2012 11:46 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.