Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-12-2013, 09:47 PM
New Member
 
Join Date: Apr 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
charcoalblack is on a distinguished road
do i have an engine problem?

hello,

not sure if it's my imagination or if I do have an issue. I have a 2011 V8 model. Owned it closed to 2 years come April. When the engine goes into ECO mode, if I want to accelate, sometimes the power won't come immediately when I hit the gas and will take a little bit longer than immediately (happens when i'm driving around 50mph or higher). It doesn't happen all the time but on some occasions. Not sure if this is normal or not.
__________________

__________________
Reply With Quote
  #2  
Old 02-13-2013, 07:30 AM
Member
 
Join Date: Apr 2012
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 874
Sobrut911 is on a distinguished road
Re: do i have an engine problem?

Same with my 2012 v8. I think it's normal. If you stomp on the accelerator it'll kick down to lower gear and you'll get better acceleration.
__________________

__________________
Reply With Quote
  #3  
Old 02-13-2013, 04:26 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,497
Thanks: 0
Thanked 20 Times in 17 Posts
Rep Power: 80067
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: do i have an engine problem?

Slapping the gearstick is faster than stomping if you want a downshift.
Reply With Quote
  #4  
Old 02-13-2013, 05:32 PM
Ricko's Avatar
Member
My Jeep: 2013 3.6L WK2
 
Join Date: Jul 2011
Location: Long Island, NY
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1204
Ricko is on a distinguished road
Re: do i have an engine problem?

i know this isn't on topic with OP but at high speeds 60-65mph how is everyone engine breaking.. I drive to school everyday and I notice if i let off the gas the truck starts to slow down pretty fast with out me hitting the brake anyone else feel this?
__________________
Reply With Quote
  #5  
Old 02-13-2013, 06:10 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,497
Thanks: 0
Thanked 20 Times in 17 Posts
Rep Power: 80067
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: do i have an engine problem?

With the aerodymanics of a brick wall, at speed you do not need to do much, just reduce power and hope the DFCO is fast.
Reply With Quote
  #6  
Old 02-13-2013, 07:51 PM
ColdCase's Avatar
Senior Member
 
Join Date: Apr 2011
Posts: 1,445
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 26417
ColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond repute
Re: do i have an engine problem?

Do you have the adaptive cruise/cross path detection.. etc package? Not sure if all WK2s or just the ones with this package but a bit of brake is applied when you suddenly lift the throttle. Its a safety feature that gives a head start braking on panic stops.
__________________
2011 WK2 Overland Mineral Gray/Black, Advanced warning, V8; 2009 KK Rocky Mtn V6; 2000 WJ Laredo I6; 1979 CJ7 I6... green... miles of smiles :)
Reply With Quote
  #7  
Old 02-13-2013, 08:15 PM
New Member
 
Join Date: Apr 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
charcoalblack is on a distinguished road
Re: do i have an engine problem?

Quote:
Originally Posted by ColdCase View Post
Do you have the adaptive cruise/cross path detection.. etc package? Not sure if all WK2s or just the ones with this package but a bit of brake is applied when you suddenly lift the throttle. Its a safety feature that gives a head start braking on panic stops.
no, i don't have that. So i'm not sure if it's my imagination or fuel pump or what. it doesn't appear to happen all the time so i'm not sure.
__________________
Reply With Quote
  #8  
Old 02-19-2013, 03:42 PM
wjs81866's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Oct 2010
Location: Round Lake, IL
Posts: 427
Thanks: 0
Thanked 8 Times in 5 Posts
Rep Power: 16294
wjs81866 has a reputation beyond reputewjs81866 has a reputation beyond reputewjs81866 has a reputation beyond reputewjs81866 has a reputation beyond reputewjs81866 has a reputation beyond reputewjs81866 has a reputation beyond reputewjs81866 has a reputation beyond reputewjs81866 has a reputation beyond reputewjs81866 has a reputation beyond reputewjs81866 has a reputation beyond reputewjs81866 has a reputation beyond repute
Re: do i have an engine problem?

Both of mine do this; I will say that mine is better than my wife's. I have a Volant air intake and a catch can. While I don't think these are the fix all it's apparent that it's helped. Probably the catch can more than anything. Sounds like some of the new tuners that are out will help but none seem to deal with the transmission kick-down which is what you are really talking about. Mine is sometimes very sensitive and other times it's like WTF?
__________________
1) 2011 Grand Cherokee Limited Blackberry
5.7L Quadra Trac 2 - IV Towing package
Lux Group 2
20" tires and rims

2) 2011 Grand Cherokee Laredo X Blackberry
5.7L QD-2 - QL- Off-Road II - IV Towing package - Tekonsha P3 Brake Control
P265/60R18 Michelin LTX M/S 2's :D -Volant 161576 Air Intake, Billet Technology catch can
Reply With Quote
  #9  
Old 03-02-2013, 01:39 AM
New Member
 
Join Date: Apr 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
charcoalblack is on a distinguished road
Re: do i have an engine problem?

Quote:
Originally Posted by wjs81866 View Post
Both of mine do this; I will say that mine is better than my wife's. I have a Volant air intake and a catch can. While I don't think these are the fix all it's apparent that it's helped. Probably the catch can more than anything. Sounds like some of the new tuners that are out will help but none seem to deal with the transmission kick-down which is what you are really talking about. Mine is sometimes very sensitive and other times it's like WTF?
so in your opinion, you feel this is "normal" operation for the V8 engine?

thanks
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine problem? zar787 Trouble Shooting/Problems/Service 0 10-18-2012 10:26 AM
Problem staring engine kazak Trouble Shooting/Problems/Service 2 11-30-2011 09:46 PM
Engine cooling problem CPT2010 Troubleshooting/Problems Discussion 7 06-09-2011 12:24 PM
Help!!!!!!! Engine problem fml ItsAJeepThing Troubleshooting/Problems Discussion 9 09-17-2010 04:33 PM
Valve Problem with the HO engine scout Engine Performance/Intake/Exhaust 3 06-14-2010 03:47 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community