Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-03-2012, 07:35 PM
Member
 
Join Date: Jun 2011
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1186
Troy Cruise is on a distinguished road
Engine died while going 40mph

So while driving during rush hour my engine just died and I came to a halt in the middle of the road and narrowly escaped being rear-ended. I had to put the truck into park and restart it. The jeep ran really rough for a few seconds after and it hasn't happened since. There was no CEL on after or since this happened. Anyone heard of this happening? I am having a few other issues with this jeep and this was just the icing on the cake.
__________________

__________________
Reply With Quote
  #2  
Old 04-03-2012, 10:18 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Sep 2010
Location: Ottawa, Ontario
Posts: 962
Thanks: 32
Thanked 9 Times in 8 Posts
Rep Power: 2874
Cherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond repute
Re: Engine died while going 40mph

What engine?
__________________

__________________
2011 GC OL, Natural Green/Frost, QL, ORGII, 430N, Pano, GY WSA
Reply With Quote
  #3  
Old 04-03-2012, 11:32 PM
Lingohocken's Avatar
Premium Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2010
Location: Bucks County, Pennsylvania
Posts: 1,185
Thanks: 15
Thanked 9 Times in 6 Posts
Rep Power: 3235
Lingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond repute
Re: Engine died while going 40mph

Could have been crud, moisture or an improper ethanol or additive mix in the gasoline. If so, emptying or replacing the gas filter would be a first step. (No idea where it is on the WK2.) Did your engine light go on at all?

We had what a Jeep service manager speculated was a bad tank of gas that caused our Overland's engine light to go on and some brief roughness. The light was reset and all's been well since.

Stations are under enormous competitive pressure to shave every last penny off prices. So you can never tell what some gasoline is like, what with debris in station tanks and delivery trucks. One station near us that we had used was caught pouring water into its tanks, for example. It was shut down by authorities, but after I read about it I found our pickup's gas filter full of water although it hadn't yet impacted operation.
__________________
2012 Cherry Overland V6, ADG
Reply With Quote
  #4  
Old 04-04-2012, 06:50 AM
markp99's Avatar
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jul 2011
Location: Nashua, New Hampshire
Posts: 313
Thanks: 0
Thanked 6 Times in 6 Posts
Rep Power: 22591
markp99 has a reputation beyond reputemarkp99 has a reputation beyond reputemarkp99 has a reputation beyond reputemarkp99 has a reputation beyond reputemarkp99 has a reputation beyond reputemarkp99 has a reputation beyond reputemarkp99 has a reputation beyond reputemarkp99 has a reputation beyond reputemarkp99 has a reputation beyond reputemarkp99 has a reputation beyond reputemarkp99 has a reputation beyond repute
Re: Engine died while going 40mph

My wife's Jeep did that three times last week (2004 JGC).

After first occurrence (on the highway), repair shop inspected and replaced alternator & battery. 2 days later, did it again (busy street).

Third time failure happened while their techie was driving - thankfully.

Turned out to be a faulty crankshaft sensor.

- I am guessing you've probably got some other issue in your WK2, but thought it might be worth throwing this out there. Never heard of the crankshaft sensor issue.

Good luck!
__________________
| 1995 ZJ | 2000 WJ | 2004 WJ | 2011 WK2 |
Reply With Quote
  #5  
Old 04-04-2012, 09:07 AM
Antonio186's Avatar
Premium Member
My Jeep: 2002 4.7L WJ
 
Join Date: Feb 2012
Location: East Bridgewater, ma
Posts: 554
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 346987
Antonio186 has a reputation beyond reputeAntonio186 has a reputation beyond reputeAntonio186 has a reputation beyond reputeAntonio186 has a reputation beyond reputeAntonio186 has a reputation beyond reputeAntonio186 has a reputation beyond reputeAntonio186 has a reputation beyond reputeAntonio186 has a reputation beyond reputeAntonio186 has a reputation beyond reputeAntonio186 has a reputation beyond reputeAntonio186 has a reputation beyond repute
Re: Engine died while going 40mph

Quote:
Originally Posted by markp99 View Post
My wife's Jeep did that three times last week (2004 JGC).

After first occurrence (on the highway), repair shop inspected and replaced alternator & battery. 2 days later, did it again (busy street).

Third time failure happened while their techie was driving - thankfully.

Turned out to be a faulty crankshaft sensor.

- I am guessing you've probably got some other issue in your WK2, but thought it might be worth throwing this out there. Never heard of the crankshaft sensor issue.

Good luck!

this would make sense, since there are no distributors in these vehicles they use the crankshaft position sensor instead and this tells the computer to deliver spark to each coil. if this sensor fails, no spark will be delivered to the coils and the engine shuts down.
__________________

|14 Billet Silver 5.7 WK2 Limited QTII|
|02 4.7 WJ Limited QuadraDrive|
|5000K HIDS Lows/Fogs|6K V-Leds 7w reverse lights|
|Build Thread|
Reply With Quote
  #6  
Old 04-04-2012, 08:12 PM
Lingohocken's Avatar
Premium Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2010
Location: Bucks County, Pennsylvania
Posts: 1,185
Thanks: 15
Thanked 9 Times in 6 Posts
Rep Power: 3235
Lingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond repute
Re: Engine died while going 40mph

You're right that crankshaft sensors do go -- I've had it happen, too. But although I'm not all that close to this subject and could well be wrong, from what little I've seen this normally happens after many miles, not with relatively new vehicles.

Too, it would seem that the check engine light would have gone on. His didn't go on and stay on, and possibly didn't even go on briefly.
__________________

__________________
2012 Cherry Overland V6, ADG
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shuttering at 40mph and up WilsonJ Troubleshooting/Problems 6 10-11-2012 12:42 PM
Battery died... bluethunderjeep Grand Cherokee - WK 4 12-17-2010 09:51 AM
Battery Died Megatron Grand Cherokee - WK 7 09-14-2010 07:07 PM
Engine Died Fast JeepWK05 Troubleshooting/Problems Discussion 11 07-15-2009 08:16 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community