Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-14-2012, 03:22 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Oct 2011
Location: Kentucky
Posts: 96
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1030
americanbulldog is on a distinguished road
EVIC control buttons not working

Has anyone else had a problem with the EVIC control buttons not working everytime when pressed? Sometimes I have to press them 2, 3, or 4 times to get the display to change or scroll. The cruise control buttons on the other side work perfectly. Should I bring this up with the dealer? Any input would be appreciated, thanks.
__________________

__________________
Reply With Quote
  #2  
Old 05-14-2012, 03:42 PM
SW03ES's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jun 2011
Location: Gaithersburg, MD
Posts: 1,556
Thanks: 11
Thanked 24 Times in 21 Posts
Rep Power: 1302827
SW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond repute
Re: EVIC control buttons not working

I too have started having this problem recently. I'm thinking its similar button issue as I had with the cruise control switch when the Jeep was new. They replaced the switch assembly for the cruise side and that fixed the issue.

I assume that the same will be the case for the EVIC side and I plan to address it next week when I take it in.
__________________

__________________
2011 Jeep Grand Cherokee Laredo X. Natural Green Pearl w/ Black interior. QT1, moonroof, 430N, trailer tow.
2013 Lexus GS350
Reply With Quote
  #3  
Old 05-14-2012, 03:58 PM
JTS97Z28's Avatar
Premium Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jan 2011
Location: Plainfield, IL
Posts: 1,431
Thanks: 0
Thanked 29 Times in 19 Posts
Rep Power: 25005
JTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond repute
Send a message via AIM to JTS97Z28
Re: EVIC control buttons not working

Every now and then I find myself having to hit a button more than once to get it to scroll on the evic. Its something I have noticed so must be somewhat of an issue. My car is a 2012 Overland with 2,000 miles. Unfortunately I hate bringing my vehicles to dealers so the last thing I want is the dealership to touch my car and probably screw something else up worse than when it went in. So unless it gets real bad im not letting them touch my car.

James
__________________
Reply With Quote
  #4  
Old 05-14-2012, 07:18 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Mar 2012
Location: North Carolina
Posts: 293
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2776
Schweibs has a reputation beyond reputeSchweibs has a reputation beyond reputeSchweibs has a reputation beyond reputeSchweibs has a reputation beyond reputeSchweibs has a reputation beyond reputeSchweibs has a reputation beyond reputeSchweibs has a reputation beyond reputeSchweibs has a reputation beyond reputeSchweibs has a reputation beyond reputeSchweibs has a reputation beyond reputeSchweibs has a reputation beyond repute
Garage
Re: EVIC control buttons not working

I have the same problem, I have found that if you hold the button for about .5 second instead of just a quick click it will work more often.
__________________
Reply With Quote
  #5  
Old 05-14-2012, 08:34 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Sep 2010
Location: Ottawa, Ontario
Posts: 961
Thanks: 32
Thanked 9 Times in 8 Posts
Rep Power: 2535
Cherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond repute
Re: EVIC control buttons not working

Quote:
Originally Posted by Schweibs View Post
I have the same problem, I have found that if you hold the button for about .5 second instead of just a quick click it will work more often.
+1 to this. I find all the steering wheel buttons work best with a slight hold on the press, rather than a quick click. Maybe has to do with the CANBUS speed, rather than the switch itself?
__________________
2011 GC OL, Natural Green/Frost, QL, ORGII, 430N, Pano, GY WSA
Reply With Quote
  #6  
Old 05-14-2012, 08:43 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2011
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1183
oldjeeper is on a distinguished road
Re: EVIC control buttons not working

I have had this happen also seems to help if you hold button a little longer.
__________________
Reply With Quote
  #7  
Old 05-15-2012, 12:25 PM
Hollywood's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Dec 2010
Location: CT
Posts: 673
Thanks: 0
Thanked 5 Times in 3 Posts
Rep Power: 2005
Hollywood has a reputation beyond reputeHollywood has a reputation beyond reputeHollywood has a reputation beyond reputeHollywood has a reputation beyond reputeHollywood has a reputation beyond reputeHollywood has a reputation beyond repute
Re: EVIC control buttons not working

Quote:
Originally Posted by JTS97Z28 View Post
Every now and then I find myself having to hit a button more than once to get it to scroll on the evic. Its something I have noticed so must be somewhat of an issue. My car is a 2012 Overland with 2,000 miles. Unfortunately I hate bringing my vehicles to dealers so the last thing I want is the dealership to touch my car and probably screw something else up worse than when it went in. So unless it gets real bad im not letting them touch my car.

James
x2
__________________
[SIGPIC][/SIGPIC]

2011 WK2 Grand Cherokee Overland 4x4 Edition 5.7L V8
Mineral Grey / Light-Dark Frost Beige Interior
Every option available except Rear Entertainment, (No kids - Panoroof Instead!) ;)

"OVERLAND"; The American Range Rover!,
and a 1998 Grand Cherokee Limited with 210K that's still goin' Strong!!
:thumbsup:
Reply With Quote
  #8  
Old 05-15-2012, 12:53 PM
Ratchet's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Wilson, NC
Posts: 398
Thanks: 5
Thanked 6 Times in 6 Posts
Rep Power: 5326
Ratchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond repute
Re: EVIC control buttons not working

Scrolling down, the menu bar goes pretty quick. Scrolling up is the only time multiple presses are sometimes required.
__________________
Reply With Quote
  #9  
Old 05-16-2012, 02:12 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Oct 2011
Location: Kentucky
Posts: 96
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1030
americanbulldog is on a distinguished road
Re: EVIC control buttons not working

Quote:
Originally Posted by Ratchet View Post
Scrolling down, the menu bar goes pretty quick. Scrolling up is the only time multiple presses are sometimes required.
Mine hangs up going both ways, there doesn't seem to be a pattern to it, sometimes it works, sometimes it doesn't - going to bring the issue up to the dealer today while they're changing my oil, I'll let y'all know what they say.
__________________
Reply With Quote
  #10  
Old 05-16-2012, 01:08 PM
Darby Crash's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Oct 2011
Location: LOS ANGELES
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1010
Darby Crash is on a distinguished road
Re: EVIC control buttons not working

I reset the trip every time I get gas and it takes forever to get the buttons to work. Seems like there's a lag now.....this just started happening about a month ago. Blah......
__________________
~2011-BRLBLK-LMTD-4X-5.7~
Reply With Quote
  #11  
Old 05-18-2012, 02:16 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Apr 2011
Location: Rivergrove, OR
Posts: 576
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10447
Andrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond repute
Re: EVIC control buttons not working

These are all signs of defective switches. In a properly functioning system, a light quick touch on any of these is all that's required.

In some cases, this problem will get worse over time; every time you punch the button and squeeze the contact points, they can get bent a little more out of position. Don't let your warranty expire without having the dealer attend to this.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed LEDs in Heater Control/Buttons TimmyB Audio, Video, Navigation & Electronic Modifications 89 10-03-2013 06:07 AM
HELP!! cluster/evic display not working kmitch80 Trouble Shooting/Problems/Service 2 05-07-2012 06:03 PM
Cruise control stopped working WK2JGC Trouble Shooting/Problems/Service 4 02-09-2012 12:35 PM
Cruise Control not working! What do you think? JacRen Grand Cherokee - WK 0 04-11-2010 03:21 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community