Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-15-2014, 09:04 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 920
Thanks: 0
Thanked 41 Times in 32 Posts
Rep Power: 3511
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
FINALLY Got My TSBs Done On My 2014 GC!

...and it only only took 4 months, multiple calls to Chrysler Customer Care, and three trips to three different dealerships. Grava in Medford, MA was the dealership that finally did the work...WARNING: they do not provide loaners unless you bought an extended Chrysler service plan, so it's either Enterprise down the street...or you're on your own. I ended up renting a car from Enteprise (with hope Chrysler keeps their word on reimbursing me), and guess what vehicle I received...another crappy Chrysler 200! At least this one was clean inside, on the newer side, and didn't have warped front rotors. Total of $57 for one day (including taxes & insurance).

What's funny is at first I though this wasn't going to happen...I was first told by all three dealerships that my vehicle did not show that it needed any updates after adding my VIN number into their computer. I very nicely handed the woman the safety recall notice & the three TSBs, and kindly stated that Chrysler had contacted the Service manger about my vehicle. I'm thoughly convinced that if Chrysler did not get involved the TSBs would not have been done. In my experience, dealerships at least in my area just don't like performing software updates either because Chrysler does not reimburse them enough for labor...or they lack experience in this area.

The tranny seems to shift smoother now, I'm running v. 13.38 on my 8.4A (I even have a new "Mirror" button now), and the climate system doesn't turn off after a remote start when I open the drivers door. One problem though I noticed is that the rear window defroster did not turn on after a remote start this morning...I'll keep an eye open for this condition in the future.
__________________

__________________
Still waiting for the next V6 transmission update from Chrysler!
Reply With Quote
  #2  
Old 01-15-2014, 09:28 AM
Premium Member
 
Join Date: Jul 2013
Posts: 491
Thanks: 1
Thanked 21 Times in 16 Posts
Rep Power: 17726
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: FINALLY Got My TSBs Done On My 2014 GC!

Quote:
Originally Posted by GCLimited View Post
...and it only only took 4 months, multiple calls to Chrysler Customer Care, and three trips to three different dealerships. Grava in Medford, MA was the dealership that finally did the work...WARNING: they do not provide loaners unless you bought an extended Chrysler service plan, so it's either Enterprise down the street...or you're on your own. I ended up renting a car from Enteprise (with hope Chrysler keeps their word on reimbursing me), and guess what vehicle I received...another crappy Chrysler 200! At least this one was clean inside, on the newer side, and didn't have warped front rotors. Total of $57 for one day (including taxes & insurance).

What's funny is at first I though this wasn't going to happen...I was first told by all three dealerships that my vehicle did not show that it needed any updates after adding my VIN number into their computer. I very nicely handed the woman the safety recall notice & the three TSBs, and kindly stated that Chrysler had contacted the Service manger about my vehicle. I'm thoughly convinced that if Chrysler did not get involved the TSBs would not have been done. In my experience, dealerships at least in my area just don't like performing software updates either because Chrysler does not reimburse them enough for labor...or they lack experience in this area.

The tranny seems to shift smoother now, I'm running v. 13.38 on my 8.4A (I even have a new "Mirror" button now), and the climate system doesn't turn off after a remote start when I open the drivers door. One problem though I noticed is that the rear window defroster did not turn on after a remote start this morning...I'll keep an eye open for this condition in the future.
Nice, fingers crossed things continue to work as expected. I have seen some posts about the rear defroster, you might not like this but I think this something that is not working as expected at this point. Although I haven't paid much attention to it because its not something I care about at this point, others will be able to tell you if its really an issue or not.
__________________

__________________
2014 Overland - Granite, Hemi
Reply With Quote
  #3  
Old 01-16-2014, 09:27 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 920
Thanks: 0
Thanked 41 Times in 32 Posts
Rep Power: 3511
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: FINALLY Got My TSBs Done On My 2014 GC!

So I remote started my 2014 GC this morning when the outside temp was 28 degrees...and the rear window defroster did not activate automatically like it did with version 13.19.



Now I've read that an even newer version is out now...version 13.48. Does this newest version address the rear window defroster when remote starting? If so, is this newest version for both the 8.4A and the 8.4AN...and I wonder why the dealership reflashed my radio with an old version?



If this is the case, and the newest version that's out will address this issue, looks like this time I will take matters into my own hands, and reflash myself. I'll also mention this to Chrysler Customer Care at the follow-up when they call.
__________________
Still waiting for the next V6 transmission update from Chrysler!
Reply With Quote
  #4  
Old 01-16-2014, 09:58 AM
Premium Member
 
Join Date: Jul 2013
Posts: 491
Thanks: 1
Thanked 21 Times in 16 Posts
Rep Power: 17726
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: FINALLY Got My TSBs Done On My 2014 GC!

Quote:
Originally Posted by GCLimited View Post
So I remote started my 2014 GC this morning when the outside temp was 28 degrees...and the rear window defroster did not activate automatically like it did with version 13.19.



Now I've read that an even newer version is out now...version 13.48. Does this newest version address the rear window defroster when remote starting? If so, is this newest version for both the 8.4A and the 8.4AN...and I wonder why the dealership reflashed my radio with an old version?



If this is the case, and the newest version that's out will address this issue, looks like this time I will take matters into my own hands, and reflash myself. I'll also mention this to Chrysler Customer Care at the follow-up when they call.
I believe 13.48 mainly just adds the uConnect apps. Although I am sure there are some minor bug fixes/updates behind the scenes. I also think it might address the rear defrost, I seem to remember Bill_de saying he went back to 13.38 because 13.48 would turn on the rear defrost with remote start and he didn't need/want that?
__________________
2014 Overland - Granite, Hemi
Reply With Quote
  #5  
Old 01-16-2014, 10:16 AM
Member
 
Join Date: Jun 2011
Location: greasy cardboard box
Posts: 156
Thanks: 0
Thanked 21 Times in 17 Posts
Rep Power: 1899
fnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond repute
Re: FINALLY Got My TSBs Done On My 2014 GC!

glad you finally got your concerns addressed. too bad they used an outdated radio version. although the rear defogger symptom is not specifically mentioned in TSB 08-049-13G, i wouldn't hesitate in updating to the latest version (13.48.3). not sure but is rear defogger programmable?
__________________
I'd give my right arm to be ambidextrous.
Reply With Quote
  #6  
Old 01-16-2014, 10:17 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,228
Thanks: 321
Thanked 350 Times in 306 Posts
Rep Power: 1801725
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: FINALLY Got My TSBs Done On My 2014 GC!

Quote:
Originally Posted by TurboRush View Post
I believe 13.48 mainly just adds the uConnect apps. Although I am sure there are some minor bug fixes/updates behind the scenes. I also think it might address the rear defrost, I seem to remember Bill_de saying he went back to 13.38 because 13.48 would turn on the rear defrost with remote start and he didn't need/want that?
Actually I went back to 13.38 because the rear camera got jittery. I did mention at the time that I did notice the rear defroster coming on. It still does on occasion even on 13.38.

What had surprised me about it coming on is that I don't remember ever reading that it was supposed to. It came on a couple of times when I remote started in a 40 degree garage. Just to see, I remote started when the Jeep was outside in 28 degree temperature and it didn't come on. One way or the other makes no difference to me. I seldom remote start, except to verify something I read here.

I do not have comfort settings on, so seats and wheel do not come on.


Edit - I just did a search for "Defroster" in the online owner's manual and "User's Guide". I could not find any mention of the defroster coming on with remote start. I did see that when turned on it shuts off in 10 minutes, and if turned on again it will turn off in 5.

Maybe the issue to be addressed is that it is turning on in some cases.

---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #7  
Old 01-16-2014, 10:36 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 363
rnabors is on a distinguished road
Re: FINALLY Got My TSBs Done On My 2014 GC!

Glad you got them done!
__________________
Reply With Quote
  #8  
Old 01-16-2014, 12:14 PM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 920
Thanks: 0
Thanked 41 Times in 32 Posts
Rep Power: 3511
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: FINALLY Got My TSBs Done On My 2014 GC!

So I decided finally I was going to learn this reflash process on my own, and give updating my radio a try myself.

Got on the Uconnect site (thanks to Will and this web site)...punched in my VIN number, and found the only update my 2014 GC qualified for was the radio update to 13.48 (good for the 8.4A or 8.4AN...I have the 8.4A w/NAV added later). I then went through the tutorial (and printed out the directions for downloading the file into the vehicle), downloaded the software to my computer, and "Extracted" the file to a 4GB thumb drive...30 minutes. For the record I did this on my work computer (XP believe it or not), and through regular old Internet Explorer.

I then walked out to my SUV, stuck the thumb drive into the USB port under the radio, and followed the very clear & concise directions I printed out earlier. All done...no issues, 25 minutes. I did not have to clear my cell phone from my radio first, nor did I lose any of my pre-sets on anything.

Tomorrow when I remote start the vehicle again, we'll see if the rear window defroster/mirrors come on automatically as well...like they did with version 13.19. Fingers crossed!

__________________
Still waiting for the next V6 transmission update from Chrysler!
Reply With Quote
  #9  
Old 01-16-2014, 12:24 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,228
Thanks: 321
Thanked 350 Times in 306 Posts
Rep Power: 1801725
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: FINALLY Got My TSBs Done On My 2014 GC!

Good for you GC!

Just don't panic if something else seems amiss for a day or two. Sometimes these updates trigger other events that typically clear themselves within 48 hours.
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #10  
Old 01-16-2014, 01:04 PM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 920
Thanks: 0
Thanked 41 Times in 32 Posts
Rep Power: 3511
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: FINALLY Got My TSBs Done On My 2014 GC!

Thanks for the tip Bill, and thank you for clearing up the whole Uconnect thing with me.

__________________
Still waiting for the next V6 transmission update from Chrysler!
Reply With Quote
  #11  
Old 01-16-2014, 01:17 PM
weck's Avatar
Member
 
Join Date: Nov 2012
Location: Wisco
Posts: 747
Thanks: 14
Thanked 24 Times in 24 Posts
Rep Power: 3669
weck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond repute
Re: FINALLY Got My TSBs Done On My 2014 GC!

Best to delete and re-pair your phone after an update. Also, because .48 adds all the via mobile apps, so you'll need to update the uconnect app on your phone as well as register your accounts (pandora, etc.) in your profile on ownerconnect for all of that to work.

For what it's worth.
__________________
The bling wagon: 2014 Grand Cherokee Limited, 5.7, RA4, Lux2, OA2 sporting LTX A/Ts
The mileage slave: 2010 Jetta Sportwagen TDI
Reply With Quote
  #12  
Old 01-16-2014, 01:21 PM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 920
Thanks: 0
Thanked 41 Times in 32 Posts
Rep Power: 3511
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: FINALLY Got My TSBs Done On My 2014 GC!

Quote:
Originally Posted by weck View Post

Best to delete and re-pair your phone after an update. Also, because .48 adds all the via mobile apps, so you'll need to update the uconnect app on your phone as well as register your accounts (pandora, etc.) in your profile on ownerconnect for all of that to work.

For what it's worth.
Thanks for your tips as well sir!

__________________

__________________
Still waiting for the next V6 transmission update from Chrysler!
Reply With Quote
Reply

Tags
2014

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Finally got my 2014 JeepEnvy Grand Cherokee SRT - WK2 14 01-10-2014 10:14 PM
2014 Overland Finally Here! Marcodame Grand Cherokee - WK2 - 25 06-17-2013 10:53 AM
Load Your Own TSBs BobT Tech Tips/DIY/How To 0 05-08-2013 11:41 PM
Advice on TSBs smkelly73 Trouble Shooting/Problems/Service 17 05-03-2012 08:22 AM
New TSBs 12167jeep Trouble Shooting/Problems/Service 1 11-11-2011 08:04 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community