Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #109  
Old 04-19-2014, 11:05 AM
Premium Member
 
Join Date: Jul 2013
Posts: 486
Thanks: 0
Thanked 21 Times in 16 Posts
Rep Power: 17680
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"




Sent from my iPad using JeepGarage
__________________

__________________
2014 Overland - Granite, Hemi
Reply With Quote
  #110  
Old 04-19-2014, 03:14 PM
beechjetdriver's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2013
Location: Tampa
Posts: 100
Thanks: 43
Thanked 9 Times in 8 Posts
Rep Power: 590
beechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

I am still seeing that error, even after upgrading the firmware to 14.05.


Sent from my iPad using JeepGarage
__________________

__________________
Reply With Quote
  #111  
Old 04-19-2014, 03:57 PM
Brainstormer's Avatar
Premium Member
My Jeep: 2014 WK2
 
Join Date: May 2013
Location: Cypress, TX
Posts: 204
Thanks: 3
Thanked 67 Times in 34 Posts
Rep Power: 807
Brainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by beechjetdriver View Post
I am still seeing that error, even after upgrading the firmware to 14.05.


If none of the software upgrades helped, you need a new radio head unit.





Sent from my iPhone using JeepGarage
__________________
2014.5 Limited 4x4, CRD, Lux II, ORA II, ATG, RA4, Granite with black interior
Reply With Quote
  #112  
Old 04-24-2014, 08:45 AM
Brainstormer's Avatar
Premium Member
My Jeep: 2014 WK2
 
Join Date: May 2013
Location: Cypress, TX
Posts: 204
Thanks: 3
Thanked 67 Times in 34 Posts
Rep Power: 807
Brainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

The dreaded message came back today.


Sent from my iPhone using JeepGarage
__________________
2014.5 Limited 4x4, CRD, Lux II, ORA II, ATG, RA4, Granite with black interior
Reply With Quote
  #113  
Old 04-24-2014, 03:46 PM
beechjetdriver's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2013
Location: Tampa
Posts: 100
Thanks: 43
Thanked 9 Times in 8 Posts
Rep Power: 590
beechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond reputebeechjetdriver has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Wow. So it may not be the head unit.


Sent from my iPad using JeepGarage
__________________
Reply With Quote
  #114  
Old 05-01-2014, 07:51 AM
netboy's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: CT
Posts: 243
Thanks: 29
Thanked 53 Times in 27 Posts
Rep Power: 806
netboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

just became a member of the "Vehicle phone requires service message" club. Never had a problem with 6500 miles on my SFU. Since 3 days ago, radio is consistently showing the message on startup. It disappears after about 20 seconds and vehicle 3G data is working fine afterwards. Taking her to the dealer next week
__________________
Summit 4x4 Diesel, Black / Jeep Brown.
Reply With Quote
  #115  
Old 05-01-2014, 08:11 AM
SnoFire's Avatar
The Negotiator
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 4,867
Thanks: 55
Thanked 135 Times in 114 Posts
Rep Power: 390004
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by netboy View Post
just became a member of the "Vehicle phone requires service message" club. Never had a problem with 6500 miles on my SFU. Since 3 days ago, radio is consistently showing the message on startup. It disappears after about 20 seconds and vehicle 3G data is working fine afterwards. Taking her to the dealer next week
Have you tried updating the UConnect software?
__________________
2014 GC Limited V6 LuxII/Tow/RA4 Max Steel/Blk Michelin LTX M/S2

Reply With Quote
  #116  
Old 05-01-2014, 09:11 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Dec 2013
Posts: 22
Thanks: 0
Thanked 2 Times in 1 Post
Rep Power: 272
macsesso is on a distinguished road
Re: Getting "Vehicle phone requires service message"

2014 Limited

I've had the dreaded message appear and disappear randomly after about three months. The car has been to the dealer twice. The software has been upgraded to the current version.

I have registered and unregistered and registered again for uconnect. Yesterday my radio decided on its own to unregister from uconnect and reboot. Lost all of the apps and couldn't even find the app store. Called uconnect last night and was told that I am not unregistered. They even extended my free trial by one month. This morning all the apps reappeared. I'm thinking they did something at their end. On top of all this my Sirius subscription decided to delete itself. A brief call reinstated it. All my presets were there.

My dealer has a new radio waiting for me and will be installed next Tuesday. After following the posts I don't know what to expect any more.
__________________
Reply With Quote
  #117  
Old 05-01-2014, 09:57 AM
netboy's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: CT
Posts: 243
Thanks: 29
Thanked 53 Times in 27 Posts
Rep Power: 806
netboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by SnoFire View Post
Have you tried updating the UConnect software?
I'm on 14.05.03. Usually get Uconnect updates flashed on the day they come out.
__________________
Summit 4x4 Diesel, Black / Jeep Brown.
Reply With Quote
  #118  
Old 05-01-2014, 12:03 PM
SRTWIL's Avatar
Premium Member
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: Oct 2013
Location: "Somewhere in America, Miley Cyrus is still twerkin"
Posts: 373
Thanks: 71
Thanked 32 Times in 31 Posts
Rep Power: 692
SRTWIL is on a distinguished road
Re: Getting "Vehicle phone requires service message"

Just got this two weeks ago.. Smh.. 5k miles


Sent from my iPhone using JeepGarage
__________________


SRTWIL 2014 REDLINE
#thatnewjeepthatsrt


Reply With Quote
  #119  
Old 05-01-2014, 12:11 PM
SRTWIL's Avatar
Premium Member
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: Oct 2013
Location: "Somewhere in America, Miley Cyrus is still twerkin"
Posts: 373
Thanks: 71
Thanked 32 Times in 31 Posts
Rep Power: 692
SRTWIL is on a distinguished road
Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by SnoFire View Post
Have you tried updating the UConnect software?
How do we do an update?


Sent from my iPhone using JeepGarage
__________________


SRTWIL 2014 REDLINE
#thatnewjeepthatsrt


Reply With Quote
  #120  
Old 05-01-2014, 01:04 PM
netboy's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: CT
Posts: 243
Thanks: 29
Thanked 53 Times in 27 Posts
Rep Power: 806
netboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by SRTWIL View Post
How do we do an update?


Sent from my iPhone using JeepGarage
1. Download the latest firmware update for your vehicle @:

https://rsur.extra.chrysler.com/rsur/Uconnect.do

2. Follow the instructions: JEEP GRAND CHEROKEE Software Update Process to flash the radio with the new update.

Look at THIS THREAD for everything you ever wanted to know about experiences with the procedure and the new version.
__________________

__________________
Summit 4x4 Diesel, Black / Jeep Brown.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Vehicle phone needs service" gwnewman1 Trouble Shooting/Problems/Service 8 04-03-2013 03:15 PM
" service electric break system " and " service 4WD system " Rexie1983 Troubleshooting/Problems 0 03-18-2013 06:48 AM
"Service 4wd system" message Kayak83 Troubleshooting/Problems 5 01-03-2013 05:50 PM
Strange-MIL is constant and now ETC light comes on with message "Check Gauges" oldgeezer Troubleshooting/Problems 4 01-18-2012 07:10 PM
Dreaded "Service 4WD System" Message DaBigBone Troubleshooting/Problems 10 01-09-2012 09:31 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community