Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #145  
Old 07-01-2014, 08:35 PM
Premium Member
 
Join Date: Oct 2013
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 340
Bman is on a distinguished road
Re: Getting "Vehicle phone requires service message"

My wife's 2014 GC started getting this message right after I upgraded the uconnect software to the latest version out in June. In two weeks, the message has popped up three times. I guess a new radio is needed.
__________________

__________________
Reply With Quote
  #146  
Old 07-02-2014, 06:48 AM
SnoFire's Avatar
The Negotiator
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 4,873
Thanks: 55
Thanked 135 Times in 114 Posts
Rep Power: 390038
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by Bman View Post
My wife's 2014 GC started getting this message right after I upgraded the uconnect software to the latest version out in June. In two weeks, the message has popped up three times. I guess a new radio is needed.

What version do you have it updated to? Also, give it a little bit of time before making the appointment to have dealer look at. People have been known to get this and then it go away about a week later.


Sent from my iPad using JeepGarage
__________________

__________________
2014 GC Limited V6 LuxII/Tow/RA4 Max Steel/Blk Michelin LTX M/S2

Reply With Quote
  #147  
Old 07-02-2014, 09:50 AM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 719
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1196
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by Bman View Post
My wife's 2014 GC started getting this message right after I upgraded the uconnect software to the latest version out in June. In two weeks, the message has popped up three times. I guess a new radio is needed.
Quote:
Originally Posted by SnoFire View Post
What version do you have it updated to? Also, give it a little bit of time before making the appointment to have dealer look at. People have been known to get this and then it go away about a week later.


Sent from my iPad using JeepGarage
Im pretty sure that if you have updated, and still receive the message, then you need to have it replaced. The updates were supposed to fix this.
__________________
Reply With Quote
  #148  
Old 07-02-2014, 10:34 AM
Brainstormer's Avatar
Premium Member
My Jeep: 2014 WK2
 
Join Date: May 2013
Location: Cypress, TX
Posts: 204
Thanks: 3
Thanked 67 Times in 34 Posts
Rep Power: 835
Brainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Radio replacement is not a guarantee. I have all updates and a new radio but still get the message. My next step is to push at checking the antenna connection or replacing the antenna.

This issue has been with my GC since delivery in Nov 2013. It does not appear to affect anything else, but is a very obvious nuisance.
__________________
2014.5 Limited 4x4, CRD, Lux II, ORA II, ATG, RA4, Granite with black interior
Reply With Quote
  #149  
Old 07-02-2014, 11:30 AM
SRTWIL's Avatar
Premium Member
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: Oct 2013
Location: "Somewhere in America, Miley Cyrus is still twerkin"
Posts: 403
Thanks: 87
Thanked 36 Times in 34 Posts
Rep Power: 749
SRTWIL is on a distinguished road
Getting "Vehicle phone requires service message"

They did an update for me about 3 weeks ago.. And I haven't had that message anymore. B4 that it was on everyday.. So hopefully that worked


Sent from my iPhone using JeepGarage
__________________


SRTWIL 2014 REDLINE
#thatnewjeepthatsrt


Reply With Quote
  #150  
Old 07-02-2014, 04:26 PM
Brainstormer's Avatar
Premium Member
My Jeep: 2014 WK2
 
Join Date: May 2013
Location: Cypress, TX
Posts: 204
Thanks: 3
Thanked 67 Times in 34 Posts
Rep Power: 835
Brainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond reputeBrainstormer has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by SRTWIL View Post
They did an update for me about 3 weeks ago.. And I haven't had that message anymore. B4 that it was on everyday.. So hopefully that worked

It took about 3 weeks before my error message returned. After 12 weeks, it is fairly regular now.

Good luck, I hope yours holds.
__________________

__________________
2014.5 Limited 4x4, CRD, Lux II, ORA II, ATG, RA4, Granite with black interior
Reply With Quote
The Following User Says Thank You to Brainstormer For This Useful Post:
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Vehicle phone needs service" gwnewman1 Trouble Shooting/Problems/Service 8 04-03-2013 03:15 PM
" service electric break system " and " service 4WD system " Rexie1983 Troubleshooting/Problems 0 03-18-2013 06:48 AM
"Service 4wd system" message Kayak83 Troubleshooting/Problems 5 01-03-2013 05:50 PM
Strange-MIL is constant and now ETC light comes on with message "Check Gauges" oldgeezer Troubleshooting/Problems 4 01-18-2012 07:10 PM
Dreaded "Service 4WD System" Message DaBigBone Troubleshooting/Problems 10 01-09-2012 09:31 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community