Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #37  
Old 09-12-2013, 10:57 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Utah
Posts: 70
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 604
Jimbo107 is on a distinguished road
Re: Getting "Vehicle phone requires service message"

At the time just getting the message alone would mean you got a new radio. I do beleive that has changed though
__________________

__________________
Reply With Quote
  #38  
Old 09-12-2013, 11:04 PM
Member
 
Join Date: Aug 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 461
jpurvistx is on a distinguished road
Re: Getting "Vehicle phone requires service message"

Just drove back from South Carolina to Texas and UConnect rebooted or acted up no less than probably 25x. I've owned this vehicle about 3 weeks now. WHAT A PAIN IN THE BUTT.
__________________

__________________
Reply With Quote
  #39  
Old 10-15-2013, 02:13 PM
New Member
My Jeep: 2014 3.6L
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
rb332001 is on a distinguished road
Re: Getting "Vehicle phone requires service message"

I got my Overland in the middle of April, I'm pushing 11,000 miles and I have been getting the same message since late June. Took it in for an oil change at 8,000 miles and they couldn't find anything wrong. Then took it back again for a steering wheel swap (the stitching was unraveling) and they were able to recognize the issue then. Had a new radio put in 2 weeks ago which seemed to fix everything until this past week when everything in the dash went blank and then lit up like a Christmas tree (Service air suspension, parking brake light, traction control light, check engine light, abs light, air bag light, and to top it off no speedometer - they're telling me I need a new instrument cluster now) and now the phantom phone message is back again.

I really love this Jeep so hopefully they can come up with a solution because as much as I love going to the dealership every week I'm sure they are just about as tired of seeing me as I am them! Other than that it's been perfect!
__________________
Reply With Quote
  #40  
Old 10-15-2013, 05:35 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 517
jrein is on a distinguished road
Re: Getting "Vehicle phone requires service message"

rb332001- interesting that your dealer's approach to the christmas tree is a new instrument cluster. I had the same thing a couple weeks ago. After 13 days in the shop, they gave me the car back with a replaced ABS module. Also, when I first got the phone message, they did a software update. It went away for a while, only to return on my way home from the dealer after they replaced the ABS module. Odd such differnt approaches to what seems to be the same problems.
__________________
Reply With Quote
  #41  
Old 10-16-2013, 08:29 AM
Member
 
Join Date: Jul 2013
Posts: 494
Thanks: 2
Thanked 21 Times in 16 Posts
Rep Power: 17748
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by rb332001 View Post
I got my Overland in the middle of April, I'm pushing 11,000 miles and I have been getting the same message since late June. Took it in for an oil change at 8,000 miles and they couldn't find anything wrong. Then took it back again for a steering wheel swap (the stitching was unraveling) and they were able to recognize the issue then. Had a new radio put in 2 weeks ago which seemed to fix everything until this past week when everything in the dash went blank and then lit up like a Christmas tree (Service air suspension, parking brake light, traction control light, check engine light, abs light, air bag light, and to top it off no speedometer - they're telling me I need a new instrument cluster now) and now the phantom phone message is back again.

I really love this Jeep so hopefully they can come up with a solution because as much as I love going to the dealership every week I'm sure they are just about as tired of seeing me as I am them! Other than that it's been perfect!
I might push them a little on that since there is a recall for dash going blank, etc coming out and most people seem to have had the issue resolved to this point with an ABS module replacement...

Just a thought, I wouldnt want them tearing into my dash if it was a software/recall thing.
__________________
Reply With Quote
  #42  
Old 10-17-2013, 11:08 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: St. Louis, MO
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1231
rfarb is on a distinguished road
Re: Getting "Vehicle phone requires service message"

Had the same issue with my 2014 Overland. Took it to the dealer today and they found a software update just released in the past few days. Also had an issue with the vr voice button on the steering wheel not always working. Will be picking it up tomorrow. Hopefully it's fixed.
__________________
Reply With Quote
  #43  
Old 10-18-2013, 08:40 AM
Member
 
Join Date: Jul 2013
Posts: 494
Thanks: 2
Thanked 21 Times in 16 Posts
Rep Power: 17748
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Yes, the latest uConnect software update is supposed to help with the "Vehicle Phone Needs Service"
__________________
Reply With Quote
  #44  
Old 10-18-2013, 08:15 PM
Member
 
Join Date: Jul 2012
Location: NJ
Posts: 63
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 883
emsrescue is on a distinguished road
Re: Getting "Vehicle phone requires service message"

This phone issue seems to be happing to a lot of people and I saw it three times, the dealer said they have to check the antenna but since I am having so many issues failing on the uconnect I bet its that going bad. I can't believe all these issues these cars are having....
__________________
Reply With Quote
  #45  
Old 10-18-2013, 11:10 PM
Member
 
Join Date: Sep 2013
Posts: 73
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 47788
PhatAssWJ has a reputation beyond reputePhatAssWJ has a reputation beyond reputePhatAssWJ has a reputation beyond reputePhatAssWJ has a reputation beyond reputePhatAssWJ has a reputation beyond reputePhatAssWJ has a reputation beyond reputePhatAssWJ has a reputation beyond reputePhatAssWJ has a reputation beyond reputePhatAssWJ has a reputation beyond reputePhatAssWJ has a reputation beyond reputePhatAssWJ has a reputation beyond repute
If you're experiencing the notorious 'Vehicle phone requires service' error message, you need the new radio... Total replacement of the hardware, with the latest firmware. This is the ONLY way to fix the issue.
__________________
Reply With Quote
  #46  
Old 10-24-2013, 06:52 AM
New Member
 
Join Date: Oct 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
nikki1821 is on a distinguished road
Re: Getting "Vehicle phone requires service message"

I am on my third radio and have three different download "updates" installed by my dealer due to the message. The last download was on Monday, took 1.5 hours, and the message came back on the next day. I am very frustrated, called the dealership today and they are going to contact Chrysler again!
__________________
Reply With Quote
  #47  
Old 10-24-2013, 07:40 AM
Member
 
Join Date: Aug 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 461
jpurvistx is on a distinguished road
Re: Getting "Vehicle phone requires service message"

I applied the newest software update about 3 weeks ago and my radio has been spotless so far. No more phone requires service etc. It has rebooted only 1-2 times since then, but I thought maybe/hopefully it was them doing some kind of update. But in general the update has fixed everything for me.
__________________
Reply With Quote
  #48  
Old 11-05-2013, 12:00 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2013
Location: Greenwich, CT
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 357
Bstock_v2 is on a distinguished road
Question Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by jpurvistx View Post
I applied the newest software update about 3 weeks ago and my radio has been spotless so far. No more phone requires service etc. It has rebooted only 1-2 times since then, but I thought maybe/hopefully it was them doing some kind of update. But in general the update has fixed everything for me.

Can you please post what version software you are running? I'm running 13.29.8 and just started noticing the "Phone Requires Service" notification on my 14' Limited.

*** Can everyone please post their software version, and if the problem is solved *** Maybe we can download and flash the software ourselves ???

Thanks.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Vehicle phone needs service" gwnewman1 Trouble Shooting/Problems/Service 8 04-03-2013 03:15 PM
" service electric break system " and " service 4WD system " Rexie1983 Troubleshooting/Problems 0 03-18-2013 06:48 AM
"Service 4wd system" message Kayak83 Troubleshooting/Problems 5 01-03-2013 05:50 PM
Strange-MIL is constant and now ETC light comes on with message "Check Gauges" oldgeezer Troubleshooting/Problems 4 01-18-2012 07:10 PM
Dreaded "Service 4WD System" Message DaBigBone Troubleshooting/Problems 10 01-09-2012 09:31 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community