Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-03-2013, 07:16 PM
Premium Member
 
Join Date: Apr 2013
Posts: 31
Thanks: 2
Thanked 2 Times in 1 Post
Rep Power: 533
ebang is on a distinguished road
Getting "Vehicle phone requires service message"

I have a one month old 2014 Grand Cherokee Overland. Starting two days ago, I get "Vehicle phone requires service. Please contact your dealer" when I start the car. Has anyone else got this message? Is there a quick fix? Thank you.
__________________

__________________
2014 White Jeep Grand Cherokee Overland V6 4X4 Black Interior
Reply With Quote
  #2  
Old 05-04-2013, 01:37 AM
BobsWK2's Avatar
Premium Member
 
Join Date: Aug 2010
Posts: 1,527
Thanks: 3
Thanked 23 Times in 21 Posts
Rep Power: 49541
BobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Try a search.
Attached Images
File Type: jpg Nav Screen 001.jpg (527.0 KB, 123 views)
__________________

__________________
2014 Summit 4X4, V8
Reply With Quote
  #3  
Old 05-04-2013, 01:00 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2010
Location: Inland Empire, CA
Posts: 647
Thanks: 16
Thanked 15 Times in 10 Posts
Rep Power: 1152243
Specx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Resetting the system from the engineer menu fixed this issue with mine, but some have had to have the radio replaced or supporting components to the radio. My dealer wanted to replace the entire radio as well, but I haven't had the issue since the reset and plan to wait and see how it holds up.
__________________
Ordered 02/06/2013: 2014 Overland, Brilliant Black Exterior, Black Interior, 5.7 Hemi, Off-Road Adventure II, Advanced Technology Group

Vehicle Delivered to Dealer 03/25/2013 05:00 PM PDT In my garage!
Reply With Quote
  #4  
Old 05-11-2013, 03:28 PM
New Member
 
Join Date: May 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Mike1522 is on a distinguished road
I have the same problem with my 2014 jeep. I brought it to the dealer yesterday and waited 2 hours only for the tech to tell me that they have no idea why its doing that and they have no fix for it. He said they called Chrysler engineering and are waiting to hear from them for a fix. My navigation is totally off since I got this message, anyone else's? Mine thinks I'm in PA.
__________________
Reply With Quote
  #5  
Old 05-31-2013, 08:53 PM
Member
 
Join Date: Apr 2013
Posts: 60
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 550
magiaone is on a distinguished road
Re: Getting "Vehicle phone requires service message"

yup just had the same issue in mine - 1 month old. Got the service phone message and nav thinks i am in San Antonio...............
__________________
2014 Grand Cherokee Overland
Maximum Steel Blue
Indigo/ Jeep Brown
3.6L V6
Jeep Slush Mats
Reply With Quote
  #6  
Old 06-03-2013, 08:31 AM
New Member
 
Join Date: May 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Mike1522 is on a distinguished road
Quote:
Originally Posted by magiaone View Post
yup just had the same issue in mine - 1 month old. Got the service phone message and nav thinks i am in San Antonio...............
I had mine fixed last week. They had to replace the radio. Took about an hour and everything works fine now.
__________________
Reply With Quote
  #7  
Old 06-03-2013, 08:42 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,097
Thanks: 209
Thanked 151 Times in 123 Posts
Rep Power: 89504
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

I'm wondering if a bad batch of radios hit the line, and this "vehicle phone requires service" is a known issue. I know you can't really trace by vin a group of vehicles that were produced together, but it seems Jeep knows something is up, because in the software update instructions, it says to take it in for service if this message pops up. Have the service people been replacing all units with this message? Or are there other fixes being applied? I haven't had this problem, but it would be interesting to know how dealers are treating these vehicles. Anyone else with this problem experience solutions other than unit replacement?
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #8  
Old 06-03-2013, 04:38 PM
Member
 
Join Date: Jan 2011
Posts: 64
Thanks: 0
Thanked 5 Times in 3 Posts
Rep Power: 1388
Rockraines is on a distinguished road
Re: Getting "Vehicle phone requires service message"

Just got it, day 3
__________________
Reply With Quote
  #9  
Old 06-03-2013, 04:45 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 853 Times in 468 Posts
Rep Power: 1927026
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by jacko15 View Post
I'm wondering if a bad batch of radios hit the line, and this "vehicle phone requires service" is a known issue. I know you can't really trace by vin a group of vehicles that were produced together, but it seems Jeep knows something is up, because in the software update instructions, it says to take it in for service if this message pops up. Have the service people been replacing all units with this message? Or are there other fixes being applied? I haven't had this problem, but it would be interesting to know how dealers are treating these vehicles. Anyone else with this problem experience solutions other than unit replacement?

Going to go check the Service Stuff Right now.
__________________
Reply With Quote
  #10  
Old 06-03-2013, 05:16 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 853 Times in 468 Posts
Rep Power: 1927026
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: Getting "Vehicle phone requires service message"

There is no specific STAR Case or TSB on any of these issues. I do believe there is a batch of "problem" radios but they do seem to be in the middle somewhere. The unit I have been testing with (Not Activated) works very well and it is very early production. Or there is some issue with the radio installation that is being corrected by the swap out and once that is identified there will be a STAR Case / TSB.
__________________
Reply With Quote
The Following User Says Thank You to Willx For This Useful Post:
  #11  
Old 06-08-2013, 02:02 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Aug 2011
Location: NYC
Posts: 672
Thanks: 49
Thanked 18 Times in 12 Posts
Rep Power: 2160
Roki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Quote:
Originally Posted by Specx View Post
Resetting the system from the engineer menu fixed this issue with mine, but some have had to have the radio replaced or supporting components to the radio. My dealer wanted to replace the entire radio as well, but I haven't had the issue since the reset and plan to wait and see how it holds up.
How do you perform this reset. I've seen instructions somewhere but can't find it.

EDIT: Found the info here: 2014 Uconnect RA3 - RA4 / Engineering Menu
__________________
2014 Jeep GC, V6, Black/Indigo with Adv Tech Package and ORAII
Reply With Quote
  #12  
Old 06-08-2013, 04:18 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Aug 2011
Location: NYC
Posts: 672
Thanks: 49
Thanked 18 Times in 12 Posts
Rep Power: 2160
Roki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond repute
Re: Getting "Vehicle phone requires service message"

Actually wondering if the actual message above actually means that there is something wrong with the phone. Everything works as far as I can tell. Not sure why is the system thinking that there is an issue with the internal phone (which I believe is used by UConnect store, ASSIST and 911). I tried everything (except 911) and it works fine.

The actual message that pops seems like it is referring to 911 system. I think 911 system is a little bit more than just a phone. It sends location and vehicle info to the emergency dispatcher. I think it might be something off with that. Maybe some permissions to send that data or something like that getting out of whack.

One thing (in addition to the reset) I tried is to UNREGISTER and REGISTER my Jeep for UConnect access - just like you would do when selling your car. This operation wipes all the data.

Will see if that helps... if not than visit to the dealer might be in store for me. This MAX care warranty looks better and better every day.
__________________

__________________
2014 Jeep GC, V6, Black/Indigo with Adv Tech Package and ORAII
Reply With Quote
The Following User Says Thank You to Roki303 For This Useful Post:
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Vehicle phone needs service" gwnewman1 Trouble Shooting/Problems/Service 8 04-03-2013 03:15 PM
" service electric break system " and " service 4WD system " Rexie1983 Troubleshooting/Problems 0 03-18-2013 06:48 AM
"Service 4wd system" message Kayak83 Troubleshooting/Problems 5 01-03-2013 05:50 PM
Strange-MIL is constant and now ETC light comes on with message "Check Gauges" oldgeezer Troubleshooting/Problems 4 01-18-2012 07:10 PM
Dreaded "Service 4WD System" Message DaBigBone Troubleshooting/Problems 10 01-09-2012 09:31 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community