Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-15-2014, 01:08 AM
acilate's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Silicon Valley, CA
Posts: 534
Thanks: 176
Thanked 29 Times in 23 Posts
Rep Power: 1227
acilate has a reputation beyond reputeacilate has a reputation beyond reputeacilate has a reputation beyond reputeacilate has a reputation beyond reputeacilate has a reputation beyond repute
Hands-Free System Loading ... Forever!

That pretty much says it all. Most times I cannot use voice recognition. Sometimes if I turn it off and wait for all the lights to go out then turn it back on it will work after a few minutes, but most times it just doesn't work.

I did some searching and didn't find anything on here. I haven't updated to the latest uConnect update yet, so maybe that will fix it. Anyone else seeing this issue?
Attached Images
File Type: jpg gc.vr.error.jpg (102.0 KB, 14 views)
__________________

__________________
Commuter: 2006 Subaru Legacy 2.5 GT Spec. B #345 of 500 made
Weekender: 2014 Grand Cherokee Overland 4x4 EcoDiesel: Granite Crystal Metallic, Morocco Black, Off-Road Adventure II, Adv Tech Group
Reply With Quote
  #2  
Old 01-15-2014, 03:11 AM
SNUKE's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2013
Location: Sydney, Aus
Posts: 3,181
Thanks: 85
Thanked 327 Times in 267 Posts
Rep Power: 5962
SNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond repute
Garage
Re: Hands-Free System Loading ... Forever!

You haven't said what your phone and phones OS is.
I am gathering from the details shown in the picture it is a Galaxy S3 on AT&T, but it doesn't say what version of OS.

Yoi can see what should be possible with your phone here if Uconnect is up to date - http://chrysler.servigistics.com/que...=en&brand=Jeep

First things first, quickest steps then from there.
Delete the phone from Uconnect, and Uconnect from the Phone.
Reboot Uconnect: Hold Mute and Tune buttons for reboot. You wont lose any settings.
Repair phone and Uconnect.
If not working, make sure you update phone to latest OS, and same for Uconnect.

Before updating Uconnect, Delete the phone from Uconnect, and Uconnect from the Phone.

You're level 4, so there is no reason you can't do this easily yourself with help from the VIP http://www.jeepgarage.org/f219/uconn...vip-69170.html thread - http://www.jeepgarage.org/f219/uconn...vip-69170.html

Once all systems are up to date, and paired up, then you have a good base to work from and know all that can be done from the firmware side is already done as well as possible.
__________________

__________________
I'm just want it for the "shorter headlamps".

MY14 GC Limited, 3.0 CRD, Lux II, Granite Crystal, 18" Wheels, Tubular Side Steps.
Could I get my avatar much larger?
Ordered: July 7 2013 Delivered Nov 25th
Reply With Quote
  #3  
Old 01-15-2014, 06:45 AM
not_too_shabby's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: Portland, OR
Posts: 429
Thanks: 1
Thanked 11 Times in 11 Posts
Rep Power: 1091
not_too_shabby has a brilliant future
I have had this problem too. It will say it's loaded but then when I hit the button to make a call it says it's loading. Very frustrating. A soft reboot usually fixes it but it's a hassle.

I have an iPhone 5 with the latest iOS and the latest radio software in my overland.
__________________
2014 Grand Cherokee Overland 4x4 V6
Maximum Steel
Download my App - iLeaseMyCar Pro Auto Loan and Lease Calculator for iPhone or iPad
Reply With Quote
  #4  
Old 01-15-2014, 08:20 AM
Member
 
Join Date: Jul 2013
Posts: 498
Thanks: 3
Thanked 21 Times in 16 Posts
Rep Power: 17818
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: Hands-Free System Loading ... Forever!

Quote:
Originally Posted by not_too_shabby View Post
I have had this problem too. It will say it's loaded but then when I hit the button to make a call it says it's loading. Very frustrating. A soft reboot usually fixes it but it's a hassle.

I have an iPhone 5 with the latest iOS and the latest radio software in my overland.
If you haven't already I'd follow on some of the advice Snuke gave. Delete pairing from uConnect and the Phone, reboot uConnect and repair. If that doesn't improve results delete pairing on both, re-install uConnect and repair.

If that fails and its worth it to you, dealer.
__________________
2014 Overland - Granite, Hemi
Reply With Quote
  #5  
Old 01-16-2014, 03:14 PM
acilate's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Silicon Valley, CA
Posts: 534
Thanks: 176
Thanked 29 Times in 23 Posts
Rep Power: 1227
acilate has a reputation beyond reputeacilate has a reputation beyond reputeacilate has a reputation beyond reputeacilate has a reputation beyond reputeacilate has a reputation beyond repute
Re: Hands-Free System Loading ... Forever!

Quote:
Originally Posted by SNUKE View Post
You haven't said what your phone and phones OS is.
I am gathering from the details shown in the picture it is a Galaxy S3 on AT&T, but it doesn't say what version of OS.

Yoi can see what should be possible with your phone here if Uconnect is up to date - Jeep - Uconnect

First things first, quickest steps then from there.
Delete the phone from Uconnect, and Uconnect from the Phone.
Reboot Uconnect: Hold Mute and Tune buttons for reboot. You wont lose any settings.
Repair phone and Uconnect.
If not working, make sure you update phone to latest OS, and same for Uconnect.

Before updating Uconnect, Delete the phone from Uconnect, and Uconnect from the Phone.

You're level 4, so there is no reason you can't do this easily yourself with help from the VIP http://www.jeepgarage.org/f219/uconn...vip-69170.html thread - http://www.jeepgarage.org/f219/uconn...vip-69170.html

Once all systems are up to date, and paired up, then you have a good base to work from and know all that can be done from the firmware side is already done as well as possible.
Thanks! I'll take a look at this when I have some time tonight, but the issue is not limited to phone features - nothing works for voice recognition, including things like "Set driver temperature to 65" - even with no phone paired.

I haven't had a whole lot of time to run through the uconnect update again, but this seems like it will be a good driver for updating uconnect sooner rather than later.
__________________
Commuter: 2006 Subaru Legacy 2.5 GT Spec. B #345 of 500 made
Weekender: 2014 Grand Cherokee Overland 4x4 EcoDiesel: Granite Crystal Metallic, Morocco Black, Off-Road Adventure II, Adv Tech Group
Reply With Quote
  #6  
Old 01-19-2014, 02:11 PM
acilate's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Silicon Valley, CA
Posts: 534
Thanks: 176
Thanked 29 Times in 23 Posts
Rep Power: 1227
acilate has a reputation beyond reputeacilate has a reputation beyond reputeacilate has a reputation beyond reputeacilate has a reputation beyond reputeacilate has a reputation beyond repute
Re: Hands-Free System Loading ... Forever!

Newest Uconnect update fixed the problem. Seems it was indeed a bug in the UConnect software.
__________________

__________________
Commuter: 2006 Subaru Legacy 2.5 GT Spec. B #345 of 500 made
Weekender: 2014 Grand Cherokee Overland 4x4 EcoDiesel: Granite Crystal Metallic, Morocco Black, Off-Road Adventure II, Adv Tech Group
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hands Free Phone Issue tryan77 Audio/Visual/Navigation 1 08-10-2013 08:24 PM
New TSB for Hands Free Module (HFM) PRBear571 Audio/Visual/Navigation 2 08-19-2012 11:43 PM
Hands Free Texting With 430N? boarderman23 Audio/Visual/Navigation 24 09-07-2011 09:18 AM
Problem w/Hands Free Phone FirePix1075 Grand Cherokee - WK2 - 11 09-23-2010 06:59 PM
Hands free/ipod upgrade Paul. Grand Cherokee - WK 2 06-11-2010 12:59 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.