Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-16-2012, 06:05 PM
Unabomber's Avatar
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jun 2012
Location: Wenatchee, WA
Posts: 18
Thanks: 0
Thanked 2 Times in 1 Post
Rep Power: 12535
Unabomber has a reputation beyond reputeUnabomber has a reputation beyond reputeUnabomber has a reputation beyond reputeUnabomber has a reputation beyond reputeUnabomber has a reputation beyond reputeUnabomber has a reputation beyond reputeUnabomber has a reputation beyond reputeUnabomber has a reputation beyond reputeUnabomber has a reputation beyond reputeUnabomber has a reputation beyond reputeUnabomber has a reputation beyond repute
Heated seats not turning on

I've owned my 2011 Laredo since June, and currently have about 37,000 miles on it. I noticed on my way to work today that the seat heater wasn't on, so I pulled over and looked down and noticed the light wasn't on as well. If the button is on LOW or HIGH, nothing, No light indicator, no heat. Weird thing is, it's happening on both passenger and drivers seat. It almost seems like there is just no power getting to them or something, I have no clue. Checked all the connectors and plugins under the seat and all looked well. Checked the fuse in the fusebox for the heated seats, and the fuse looked fine, so I'm not quite sure what my next step should be to try and fix this before taking it to the dealership. Any Advise guys?

Cliffs:
Heated seats not working(Passenger and drivers seat)
Light indicators aren't turning on
Fuse in fusebox looks good
All Connections look good
What do?
__________________

__________________
Reply With Quote
  #2  
Old 11-16-2012, 06:24 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: Ohio
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1188
Onroad has a reputation beyond reputeOnroad has a reputation beyond reputeOnroad has a reputation beyond reputeOnroad has a reputation beyond reputeOnroad has a reputation beyond reputeOnroad has a reputation beyond repute
Re: Heated seats not turning on

Looks like you did a good job troubleshooting the problem. I guess your next step is a trip to the dealer.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heated seats Tanner505 Troubleshooting/Problems 6 08-23-2012 12:26 PM
heated seats broom34 Troubleshooting/Problems 4 12-31-2011 12:48 AM
Seats Turning Blue migganimon Trouble Shooting/Problems/Service 7 04-02-2011 10:20 PM
Heated Seats WK05 Visual Modifications 1 03-09-2011 09:37 AM
Heated Seats stew930 Troubleshooting/Problems 20 02-02-2011 09:28 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.