Help -- weird mileage/power loss - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-25-2015, 11:12 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jul 2012
Location: Washington State
Posts: 15
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1831
Siphon is on a distinguished road
Help -- weird mileage/power loss

2011 5.7 limited with 66k miles. Got an oil chg and tire rotation yesterday before holiday road trip. I'm now about 100 miles into the trip getting 14 mpg highway and seems a little down on power. MDS only engaging rarely, downhill slopes. It's not running rough or feeling like there's an ignition issue. Only thing a little weird is its running a little cooler than normal -- 200 degrees -- but it's cold out, 16 degrees. Jiffy Lube replaced air filter, topped off coolant but no other issues. Other vitals -- oil temp 192 at 49 psi, trans temp 114. No warning lights, cannot check for codes since nothing is open today. Checked to make sure air filter housing was properly seated, looked for loose sensors but would guess that would have thrown a code already.

Baffled. Need some help here, know it's not much to go on...


Sent from my iPhone using JeepGarage

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 12-25-2015, 11:24 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jul 2012
Location: Washington State
Posts: 15
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1831
Siphon is on a distinguished road
Re: Help -- weird mileage/power loss

Sorry should specify I'd usually be getting 18 mpg or so... Big drop, very weird.


Sent from my iPhone using JeepGarage
Reply With Quote
  #3  
Old 12-26-2015, 02:28 PM
Angler's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jan 2012
Location: San Antonio, TX
Posts: 382
Thanks: 30
Thanked 16 Times in 16 Posts
Rep Power: 62928
Angler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond reputeAngler has a reputation beyond repute
Re: Help -- weird mileage/power loss

Since you mention the MDS is not coming on as frequently as it did before the oil change, did Jiffy Lube use the right weight motor oil?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 12-27-2015, 08:20 AM
Lightninrod's Avatar
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Jan 2015
Location: Warner Robins Ga
Posts: 508
Thanks: 658
Thanked 58 Times in 48 Posts
Rep Power: 1646
Lightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond repute
Re: Help -- weird mileage/power loss

Maybe JL lowered the air PSI?

Dan
__________________
2013 Jeep Grand Cherokee Overland
5.7L V8, 2WD, Quadratec mats, Sprint Booster, Northstar AGM Battery, Volant CAI, Blastinbob's axleback exhaust, X-pipe, Shell 93 octane w/Nitrogen, Pennzoil Platinum 5W20, Uniden CB, and K40 magnet antenna
Build date: 9/4/12 Bought 01/27/15 with 47,200 miles
Reply With Quote
  #5  
Old 12-27-2015, 10:02 AM
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Nov 2011
Location: perry hall, maryland
Posts: 498
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 2738
peckmv has a reputation beyond reputepeckmv has a reputation beyond reputepeckmv has a reputation beyond reputepeckmv has a reputation beyond reputepeckmv has a reputation beyond reputepeckmv has a reputation beyond reputepeckmv has a reputation beyond reputepeckmv has a reputation beyond repute
Re: Help -- weird mileage/power loss

Your first mistake was taking it to Jiffy Lube.
Reply With Quote
  #6  
Old 12-30-2015, 12:44 AM
Member
My Jeep: 2014 6.4L SRT WK2
 
Join Date: Jan 2011
Location: Near Tulsa, OK
Posts: 391
Thanks: 0
Thanked 34 Times in 21 Posts
Rep Power: 22141
rich mac has a reputation beyond reputerich mac has a reputation beyond reputerich mac has a reputation beyond reputerich mac has a reputation beyond reputerich mac has a reputation beyond reputerich mac has a reputation beyond reputerich mac has a reputation beyond reputerich mac has a reputation beyond reputerich mac has a reputation beyond reputerich mac has a reputation beyond reputerich mac has a reputation beyond repute
Re: Help -- weird mileage/power loss

I'd check the air filter to make sure it is the rightt one and installed correctly. Restricted air flow could cause both symtoms.
Reply With Quote
  #7  
Old 12-30-2015, 12:55 PM
Ratchet's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2011
Location: Wilson, NC
Posts: 577
Thanks: 22
Thanked 33 Times in 32 Posts
Rep Power: 6665
Ratchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond reputeRatchet has a reputation beyond repute
Re: Help -- weird mileage/power loss

I'd point fingers if they actually added the proper weight oil as mentioned above. That's one of the most common causes for lazy MSD activation.
__________________
2014 WK2 Overland - Billet Silver
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Embarrassing Loss Of Power Question? hella_wk Interior/Exterior/Visual/Lighting 12 01-16-2017 10:28 AM
Complete loss of power when accelerating please help 1994 Jeep Grand Cherokee ChefAsh Grand Cherokee - ZJ 10 05-15-2013 08:02 PM
yea i got another question...sudden loss of power snowchiq16 Troubleshooting/Problems 10 09-09-2011 04:40 PM
Loss of Power w/AC Bleeding Blue Grand Cherokee - WK 3 06-04-2011 10:54 PM
Transmission and loss of power on cruise control? RUDEZ Grand Cherokee - WK 2 02-13-2011 10:37 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:54 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.